summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2012-11-16 17:28:10 +0000
committerThomas Sachau <tommy@gentoo.org>2012-11-16 17:28:10 +0000
commit6f270f68df7e07d0074514133316acf7535aa834 (patch)
treed6915d87fe75efd3051a13b4dfbbc248dcfc0d6e /media-libs
parentRemove old. (diff)
downloadgentoo-2-6f270f68df7e07d0074514133316acf7535aa834.tar.gz
gentoo-2-6f270f68df7e07d0074514133316acf7535aa834.tar.bz2
gentoo-2-6f270f68df7e07d0074514133316acf7535aa834.zip
Initial commit
(Portage version: 2.2.0_alpha142-r1/cvs/Linux x86_64, signed Manifest commit with key 0x35899067)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/elementary/ChangeLog10
-rw-r--r--media-libs/elementary/elementary-1.7.1.ebuild49
-rw-r--r--media-libs/elementary/metadata.xml24
3 files changed, 83 insertions, 0 deletions
diff --git a/media-libs/elementary/ChangeLog b/media-libs/elementary/ChangeLog
new file mode 100644
index 000000000000..8f4a7d6ef097
--- /dev/null
+++ b/media-libs/elementary/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for media-libs/elementary
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/elementary/ChangeLog,v 1.1 2012/11/16 17:28:10 tommy Exp $
+
+*elementary-1.7.1 (16 Nov 2012)
+
+ 16 Nov 2012; Thomas Sachau (Tommy[D]) <tommy@gentoo.org>
+ +elementary-1.7.1.ebuild, +metadata.xml:
+ Initial commit
+
diff --git a/media-libs/elementary/elementary-1.7.1.ebuild b/media-libs/elementary/elementary-1.7.1.ebuild
new file mode 100644
index 000000000000..61e6727d9cc2
--- /dev/null
+++ b/media-libs/elementary/elementary-1.7.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/elementary/elementary-1.7.1.ebuild,v 1.1 2012/11/16 17:28:10 tommy Exp $
+
+EAPI=2
+
+inherit enlightenment
+
+DESCRIPTION="Basic widget set, based on EFL for mobile touch-screen devices."
+HOMEPAGE="http://trac.enlightenment.org/e/wiki/Elementary"
+SRC_URI="http://download.enlightenment.org/releases/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus debug examples fbcon opengl quicklaunch sdl X xcb xdg static-libs"
+
+DEPEND="
+ >=dev-libs/ecore-1.7.0[evas,fbcon?,opengl?,sdl?,X?,xcb?]
+ >=media-libs/evas-1.7.0[fbcon?,opengl?,X?,xcb?]
+ >=media-libs/edje-1.7.0
+ dbus? ( >=dev-libs/e_dbus-1.7.0 )
+ xdg? ( >=dev-libs/efreet-1.7.0 )
+ "
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ MY_ECONF="$(use_enable dbus edbus)
+ $(use_enable debug)
+ $(use_enable doc)
+ --disable-ecore-cocoa
+ --disable-ecore-psl1ght
+ --disable-ecore-wayland
+ --disable-ecore-win32
+ --disable-ecore-wince
+ --disable-emap
+ --disable-emotion
+ --disable-ethumb
+ --disable-eweather
+ $(use_enable examples build-examples)
+ $(use_enable examples install-examples)
+ $(use_enable fbcon ecore-fb)
+ $(use_enable sdl ecore-sdl)
+ --disable-web
+ $(use_enable X ecore-x)
+ $(use_enable quicklaunch quick-launch)
+ $(use_enable xdg efreet)"
+
+ enlightenment_src_configure
+}
diff --git a/media-libs/elementary/metadata.xml b/media-libs/elementary/metadata.xml
new file mode 100644
index 000000000000..1c1d449ad757
--- /dev/null
+++ b/media-libs/elementary/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>enlightenment@gentoo.org</email>
+</maintainer>
+<use>
+ <flag name="dbus">Enable integration with <pkg>dev-libs/e_dbus</pkg>.</flag>
+ <flag name="quicklaunch">Enable quick-launch support</flag>
+ <flag name="xdg">Enable integration with <pkg>dev-libs/efreet</pkg> for cross-desktop standards (freedesktop.org).</flag>
+</use>
+<longdescription>
+Elementary is a widget set. It is a new-style of widget set much more
+canvas object based than anything else. Why not ETK? Why not EWL? Well
+they both tend to veer away from the core of Evas, Ecore and Edje a
+lot to build their own worlds. Also I wanted something focused on
+embedded devices - specifically small touchscreens. Unlike GTK+ and
+Qt, 75% of the "widget set" is already embodied in a common core -
+Ecore, Edje, Evas etc. So this fine-grained library splitting means
+all of this is shared, just a new widget "personality" is on top. And
+that is... Elementary, my dear watson. Elementary.
+</longdescription>
+</pkgmetadata>