summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2002-08-06 15:34:23 +0000
committerBrandon Low <lostlogic@gentoo.org>2002-08-06 15:34:23 +0000
commit79f9896e809b4ac35a74c5fbc8c5fb3d04e37657 (patch)
tree05b24e116c57ac0d1bd5d29805f24da16cae7d59 /media-libs
parentpre-mask xine updates I'm doing (diff)
downloadgentoo-2-79f9896e809b4ac35a74c5fbc8c5fb3d04e37657.tar.gz
gentoo-2-79f9896e809b4ac35a74c5fbc8c5fb3d04e37657.tar.bz2
gentoo-2-79f9896e809b4ac35a74c5fbc8c5fb3d04e37657.zip
new version, please test
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/xine-lib/ChangeLog11
-rw-r--r--media-libs/xine-lib/files/digest-xine-lib-0.9.131
-rw-r--r--media-libs/xine-lib/files/xineconfig.patch-0.9.1311
-rw-r--r--media-libs/xine-lib/xine-lib-0.9.13.ebuild116
4 files changed, 138 insertions, 1 deletions
diff --git a/media-libs/xine-lib/ChangeLog b/media-libs/xine-lib/ChangeLog
index f5e387e8b62c..e3e3da76158e 100644
--- a/media-libs/xine-lib/ChangeLog
+++ b/media-libs/xine-lib/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for media-libs/xine-lib
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/ChangeLog,v 1.16 2002/08/02 16:28:13 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/ChangeLog,v 1.17 2002/08/06 15:34:23 lostlogic Exp $
+
+*xine-lib-0.9.13 (06 Aug 2002)
+
+ 06 Aug 2002; Brandon Low <lostlogic@gentoo.org> xne-lib-0.9.13.ebuild:
+
+ New xine version, looks like a lot more configure options
+ are actually working now, but I give no guarantees on that.
+ Plus we get the xinetic skin back, since that is what most
+ people are still used to.
*xine-lib-0.9.12-r2 (31 Jul 2002)
diff --git a/media-libs/xine-lib/files/digest-xine-lib-0.9.13 b/media-libs/xine-lib/files/digest-xine-lib-0.9.13
new file mode 100644
index 000000000000..8f38da8ba0ba
--- /dev/null
+++ b/media-libs/xine-lib/files/digest-xine-lib-0.9.13
@@ -0,0 +1 @@
+MD5 2e37c40bb78732187e3375a220405063 xine-lib-0.9.13.tar.gz 2751090
diff --git a/media-libs/xine-lib/files/xineconfig.patch-0.9.13 b/media-libs/xine-lib/files/xineconfig.patch-0.9.13
new file mode 100644
index 000000000000..d8b99700bebc
--- /dev/null
+++ b/media-libs/xine-lib/files/xineconfig.patch-0.9.13
@@ -0,0 +1,11 @@
+--- configure.orig Thu Jun 20 16:54:36 2002
++++ configure Thu Jun 20 16:55:03 2002
+@@ -13350,7 +13350,7 @@
+
+
+
+-INCLUDES='-I$(top_srcdir) -I$(top_builddir) -I$(top_srcdir)/src -I$(top_builddir)/src -I$(top_srcdir)/src/xine-engine -I$(top_builddir)/src/xine-engine -I$(top_srcdir)/src/xine-utils -I$(top_builddir)/src/xine-utils $(INTLDIR)'
++INCLUDES='-I/usr/include/directfb -I$(top_srcdir) -I$(top_builddir) -I$(top_srcdir)/src -I$(top_builddir)/src -I$(top_srcdir)/src/xine-engine -I$(top_builddir)/src/xine-engine -I$(top_srcdir)/src/xine-utils -I$(top_builddir)/src/xine-utils $(INTLDIR)'
+
+
+
diff --git a/media-libs/xine-lib/xine-lib-0.9.13.ebuild b/media-libs/xine-lib/xine-lib-0.9.13.ebuild
new file mode 100644
index 000000000000..f560684d599c
--- /dev/null
+++ b/media-libs/xine-lib/xine-lib-0.9.13.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/xine-lib-0.9.13.ebuild,v 1.1 2002/08/06 15:34:23 lostlogic Exp $
+
+inherit libtool || die "I lost my inheritance"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Xine is a free gpl-licensed video player for unix-like systems"
+HOMEPAGE="http://xine.sourceforge.net/"
+SRC_URI="http://xine.sourceforge.net/files/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
+DEPEND="oggvorbis? ( media-libs/libvorbis )
+ X? ( virtual/x11 )
+ avi? ( >=media-libs/win32codecs-0.50
+ media-libs/divx4linux )
+ esd? ( media-sound/esound )
+ dvd? ( >=media-libs/libdvdcss-0.0.3.3
+ >=media-libs/libdvdread-0.9.2 )
+ arts? ( kde-base/kdelibs )
+ alsa? ( media-libs/alsa-lib )
+ aalib? ( media-libs/aalib )
+ directfb? ( >=dev-libs/DirectFB-0.9.9
+ dev-util/pkgconfig )"
+
+RDEPEND="${DEPEND}
+ nls? ( sys-devel/gettext )"
+
+SLOT="0"
+LICENSE="GPL"
+KEYWORDS="x86"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+
+ patch -p1 < ${FILESDIR}/xine-lib-configure.patch || die "configure patch failed"
+
+ if [ `use directfb` ]; then
+ patch -p0 < ${FILESDIR}/xineconfig.patch-${PV} || die "dfb patch 1 failed"
+# patch -p2 < ${FILESDIR}/${PF}-directfb.patch || die "dfb patch 2 failed"
+ else
+ patch -p1 < ${FILESDIR}/${PN}-disable-directfb.patch || die "no dfb patch failed"
+ fi
+}
+
+src_compile() {
+
+ elibtoolize
+
+ # Most of these are not working currently, but are here for completeness
+ # don't use the --disable-XXXtest because that defaults to ON not OFF
+ local myconf
+ use X \
+ || myconf="${myconf} --disable-x11 --disable-xv"
+ use esd \
+ || myconf="${myconf} --disable-esd"
+ # --disable-esdtest"
+ use nls \
+ || myconf="${myconf} --disable-nls"
+ use alsa \
+ || myconf="${myconf} --disable-alsa"
+ # --disable-alsatest"
+ use arts \
+ || myconf="${myconf} --disable-arts"
+ # --disable-artstest"
+
+ # This breaks because with the test disabled, it defaults to "found" check with
+ # the next release until then let it autodetect. See bug #2377.
+ use aalib || myconf="${myconf} --disable-aalib"
+ # --disable-aalibtest"
+
+ # Configure script is broken, even if you pass the flags below it still assumes
+ # ogg is installed and tries to compile it, giving you bug #5244. But leaving
+ # ogg for autodetection works.
+ use oggvorbis \
+ || myconf="${myconf} --disable-ogg --disable-vorbis"
+# --disable-oggtest \
+# --disable-vorbistest"
+
+ use avi \
+ && myconf="${myconf} --with-w32-path=/usr/lib/win32" \
+ || myconf="${myconf} --disable-asf"
+
+ einfo "myconf: ${myconf}"
+
+ econf ${myconf} || die
+
+ elibtoolize
+
+ emake || die
+}
+
+src_install() {
+
+ einstall || die
+
+ dodoc AUTHORS COPYING ChangeLog INSTALL README TODO
+ cd ${S}/doc
+ dodoc dataflow.dia README*
+
+}
+
+pkg_postinst() {
+
+ einfo
+ einfo "Please note, a new version of xine-lib has been installed,"
+ einfo "for library consistency you need to unmerge old versions"
+ einfo "of xine-lib before merging xine-ui."
+ einfo
+
+}