summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaweł Hajdan <phajdan.jr@gentoo.org>2011-06-15 19:01:24 +0000
committerPaweł Hajdan <phajdan.jr@gentoo.org>2011-06-15 19:01:24 +0000
commit7eec3207948b52d3bb62cae5aa621b8e9629c35e (patch)
tree67652531feb079b7af705c633031192ff020283d /media-libs
parentQA: actually make runit build, since it was broken with a blind version bump. (diff)
downloadgentoo-2-7eec3207948b52d3bb62cae5aa621b8e9629c35e.tar.gz
gentoo-2-7eec3207948b52d3bb62cae5aa621b8e9629c35e.tar.bz2
gentoo-2-7eec3207948b52d3bb62cae5aa621b8e9629c35e.zip
Fix build with >=ffmpeg-0.6.90, bug #367437 by hwoarang.
(Portage version: 2.1.9.42/cvs/Linux i686)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/FusionSound/ChangeLog10
-rw-r--r--media-libs/FusionSound/FusionSound-1.1.1-r1.ebuild66
-rw-r--r--media-libs/FusionSound/files/FusionSound-1.1.1-ffmpeg-0.6.90.patch11
3 files changed, 85 insertions, 2 deletions
diff --git a/media-libs/FusionSound/ChangeLog b/media-libs/FusionSound/ChangeLog
index 45b2ba788bcc..2dd62798f11c 100644
--- a/media-libs/FusionSound/ChangeLog
+++ b/media-libs/FusionSound/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/FusionSound
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/FusionSound/ChangeLog,v 1.7 2009/12/23 11:13:31 ssuominen Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/FusionSound/ChangeLog,v 1.8 2011/06/15 19:01:23 phajdan.jr Exp $
+
+*FusionSound-1.1.1-r1 (15 Jun 2011)
+
+ 15 Jun 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
+ +FusionSound-1.1.1-r1.ebuild, +files/FusionSound-1.1.1-ffmpeg-0.6.90.patch:
+ Fix build with >=ffmpeg-0.6.90, bug #367437 by hwoarang.
23 Dec 2009; Samuli Suominen <ssuominen@gentoo.org>
FusionSound-1.1.1.ebuild:
diff --git a/media-libs/FusionSound/FusionSound-1.1.1-r1.ebuild b/media-libs/FusionSound/FusionSound-1.1.1-r1.ebuild
new file mode 100644
index 000000000000..d8c98bdd0de7
--- /dev/null
+++ b/media-libs/FusionSound/FusionSound-1.1.1-r1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/FusionSound/FusionSound-1.1.1-r1.ebuild,v 1.1 2011/06/15 19:01:23 phajdan.jr Exp $
+
+EAPI=2
+inherit autotools eutils
+
+DESCRIPTION="Audio sub system for multiple applications"
+HOMEPAGE="http://www.directfb.org/"
+SRC_URI="http://www.directfb.org/downloads/Core/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="alsa cddb ffmpeg mad oss timidity vorbis"
+
+RDEPEND=">=dev-libs/DirectFB-${PV}
+ alsa? ( media-libs/alsa-lib )
+ timidity? ( media-libs/libtimidity
+ media-sound/timidity++ )
+ vorbis? ( media-libs/libvorbis )
+ mad? ( media-libs/libmad )
+ cddb? ( media-libs/libcddb )
+ ffmpeg? ( >=media-video/ffmpeg-0.6.90_rc0 )
+ !net-zope/zodb"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-apps/sed"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-ffmpeg.patch \
+ "${FILESDIR}"/${P}-ffmpeg-0.6.90.patch
+ sed -i -e 's:-O3 -ffast-math -pipe::' configure.in \
+ || die "sed failed"
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_configure() {
+ local myaudio="wave"
+
+ use alsa && myaudio="${myaudio} alsa"
+ use oss && myaudio="${myaudio} oss"
+
+ # Lite is used only for tests or examples.
+ # Tremor isn't there with latest libvorbis.
+ econf \
+ --disable-dependency-tracking \
+ --without-lite \
+ --with-drivers="${myaudio}" \
+ --without-examples \
+ $(use_with timidity) \
+ --with-wave \
+ $(use_with vorbis) \
+ --without-tremor \
+ $(use_with mad) \
+ $(use_with cddb cdda) \
+ $(use_with ffmpeg) \
+ --with-playlist
+}
+
+src_install() {
+ emake DESTDIR="${D}" htmldir=/usr/share/doc/${PF}/html \
+ install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}
diff --git a/media-libs/FusionSound/files/FusionSound-1.1.1-ffmpeg-0.6.90.patch b/media-libs/FusionSound/files/FusionSound-1.1.1-ffmpeg-0.6.90.patch
new file mode 100644
index 000000000000..b25b85bef621
--- /dev/null
+++ b/media-libs/FusionSound/files/FusionSound-1.1.1-ffmpeg-0.6.90.patch
@@ -0,0 +1,11 @@
+--- interfaces/IFusionSoundMusicProvider/ifusionsoundmusicprovider_ffmpeg.c.orig 2011-06-15 20:01:31.000000000 +0200
++++ interfaces/IFusionSoundMusicProvider/ifusionsoundmusicprovider_ffmpeg.c 2011-06-15 20:01:45.000000000 +0200
+@@ -64,7 +64,7 @@
+
+ DirectStream *stream;
+
+- ByteIOContext pb;
++ AVIOContext pb;
+ AVFormatContext *ctx;
+ AVStream *st;
+ void *iobuf;