summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2011-03-17 21:37:48 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2011-03-17 21:37:48 +0000
commit8b775ed063ceb8c708d62ef3b90452d67553b7c8 (patch)
tree66d01c35aaa11d9cb98e98a52e55d295c369f589 /media-libs
parentBump to 0.10.17, no major changes (diff)
downloadgentoo-2-8b775ed063ceb8c708d62ef3b90452d67553b7c8.tar.gz
gentoo-2-8b775ed063ceb8c708d62ef3b90452d67553b7c8.tar.bz2
gentoo-2-8b775ed063ceb8c708d62ef3b90452d67553b7c8.zip
Bump to 0.10.17, major fixes are:
* asfdemux: Handle new type of DRM'd asf files * mpegparse: re-fix flow return handling * rmdemux: set GST_BUFFER_FLAG_DELTA_UNIT properly * xingmux: Don't ignore WRONG_STATE and NOT_LINKED when pushing data downstream (Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/gst-plugins-ugly/ChangeLog13
-rw-r--r--media-libs/gst-plugins-ugly/gst-plugins-ugly-0.10.17.ebuild57
2 files changed, 69 insertions, 1 deletions
diff --git a/media-libs/gst-plugins-ugly/ChangeLog b/media-libs/gst-plugins-ugly/ChangeLog
index 6d43c57a5538..b21e1d6674b1 100644
--- a/media-libs/gst-plugins-ugly/ChangeLog
+++ b/media-libs/gst-plugins-ugly/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for media-libs/gst-plugins-ugly
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-ugly/ChangeLog,v 1.78 2011/02/13 12:40:30 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-ugly/ChangeLog,v 1.79 2011/03/17 21:37:48 nirbheek Exp $
+
+*gst-plugins-ugly-0.10.17 (17 Mar 2011)
+
+ 17 Mar 2011; Nirbheek Chauhan <nirbheek@gentoo.org>
+ +gst-plugins-ugly-0.10.17.ebuild:
+ Bump to 0.10.17, major fixes are:
+ * asfdemux: Handle new type of DRM'd asf files
+ * mpegparse: re-fix flow return handling
+ * rmdemux: set GST_BUFFER_FLAG_DELTA_UNIT properly
+ * xingmux: Don't ignore WRONG_STATE and NOT_LINKED when pushing data
+ downstream
13 Feb 2011; Raúl Porcel <armin76@gentoo.org>
gst-plugins-ugly-0.10.16.ebuild:
diff --git a/media-libs/gst-plugins-ugly/gst-plugins-ugly-0.10.17.ebuild b/media-libs/gst-plugins-ugly/gst-plugins-ugly-0.10.17.ebuild
new file mode 100644
index 000000000000..0bdf80b55b97
--- /dev/null
+++ b/media-libs/gst-plugins-ugly/gst-plugins-ugly-0.10.17.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-ugly/gst-plugins-ugly-0.10.17.ebuild,v 1.1 2011/03/17 21:37:48 nirbheek Exp $
+
+# order is important, gnome2 after gst-plugins
+inherit gst-plugins-ugly gst-plugins10 gnome2 eutils flag-o-matic libtool
+
+DESCRIPTION="Basepack of plugins for gstreamer"
+HOMEPAGE="http://gstreamer.sourceforge.net"
+SRC_URI="http://gstreamer.freedesktop.org/src/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=media-libs/gst-plugins-base-0.10.26
+ >=media-libs/gstreamer-0.10.26
+ >=dev-libs/glib-2.20"
+DEPEND="${RDEPEND}
+ >=sys-devel/gettext-0.11.5
+ dev-util/pkgconfig
+ !<media-libs/gst-plugins-bad-0.10.13"
+
+GST_PLUGINS_BUILD=""
+
+src_compile() {
+ # gst doesnt handle optimisations well
+ strip-flags
+ replace-flags "-O3" "-O2"
+ filter-flags "-fprefetch-loop-arrays" # see bug 22249
+
+ gst-plugins-ugly_src_configure
+
+ emake || die "emake failed."
+}
+
+# override eclass
+src_install() {
+ gnome2_src_install
+}
+
+DOCS="AUTHORS README RELEASE"
+
+pkg_postinst () {
+ gnome2_pkg_postinst
+
+ elog "The Gstreamer plugins setup has changed quite a bit on Gentoo,"
+ elog "applications now should provide the basic plugins needed."
+ elog ""
+ elog "The new seperate plugins are all named 'gst-plugins-<plugin>'."
+ elog "To get a listing of currently available plugins execute 'emerge -s gst-plugins-'."
+ elog "In most cases it shouldn't be needed though to emerge extra plugins."
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+}