summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2005-06-24 14:58:39 +0000
committerAlastair Tse <liquidx@gentoo.org>2005-06-24 14:58:39 +0000
commit8eabd580076bfe28d793bd54090416e1774eb687 (patch)
tree4b476c6fbb43dc64d92a3bc725933c95f70206da /media-libs
parent~sparc'ed (diff)
downloadgentoo-2-8eabd580076bfe28d793bd54090416e1774eb687.tar.gz
gentoo-2-8eabd580076bfe28d793bd54090416e1774eb687.tar.bz2
gentoo-2-8eabd580076bfe28d793bd54090416e1774eb687.zip
version bump (#96879)
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libgphoto2/ChangeLog8
-rw-r--r--media-libs/libgphoto2/files/digest-libgphoto2-2.1.61
-rw-r--r--media-libs/libgphoto2/libgphoto2-2.1.5.ebuild4
-rw-r--r--media-libs/libgphoto2/libgphoto2-2.1.6.ebuild123
4 files changed, 133 insertions, 3 deletions
diff --git a/media-libs/libgphoto2/ChangeLog b/media-libs/libgphoto2/ChangeLog
index 26a5b26eaecb..862485557c22 100644
--- a/media-libs/libgphoto2/ChangeLog
+++ b/media-libs/libgphoto2/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/libgphoto2
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libgphoto2/ChangeLog,v 1.40 2005/06/17 20:02:00 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libgphoto2/ChangeLog,v 1.41 2005/06/24 14:58:39 liquidx Exp $
+
+*libgphoto2-2.1.6 (24 Jun 2005)
+
+ 24 Jun 2005; Alastair Tse <liquidx@gentoo.org> libgphoto2-2.1.5.ebuild,
+ +libgphoto2-2.1.6.ebuild:
+ version bump (#96879)
17 Jun 2005; Michael Hanselmann <hansmi@gentoo.org>
libgphoto2-2.1.4.ebuild:
diff --git a/media-libs/libgphoto2/files/digest-libgphoto2-2.1.6 b/media-libs/libgphoto2/files/digest-libgphoto2-2.1.6
new file mode 100644
index 000000000000..906a369c0f89
--- /dev/null
+++ b/media-libs/libgphoto2/files/digest-libgphoto2-2.1.6
@@ -0,0 +1 @@
+MD5 1938cbd9718595fd419907bf2f7c3195 libgphoto2-2.1.6.tar.gz 3205731
diff --git a/media-libs/libgphoto2/libgphoto2-2.1.5.ebuild b/media-libs/libgphoto2/libgphoto2-2.1.5.ebuild
index a12bfa97e3bb..44e8fb1f96c6 100644
--- a/media-libs/libgphoto2/libgphoto2-2.1.5.ebuild
+++ b/media-libs/libgphoto2/libgphoto2-2.1.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libgphoto2/libgphoto2-2.1.5.ebuild,v 1.4 2005/06/09 00:56:23 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libgphoto2/libgphoto2-2.1.5.ebuild,v 1.5 2005/06/24 14:58:39 liquidx Exp $
inherit libtool eutils
@@ -10,7 +10,7 @@ SRC_URI="mirror://sourceforge/gphoto/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~ppc ~sparc ~amd64 ~ia64 ~ppc64 ~alpha"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc x86"
IUSE="nls doc jpeg nousb"
# needs >usbutils-0.11-r2 to avoid /usr/lib/libusb*
diff --git a/media-libs/libgphoto2/libgphoto2-2.1.6.ebuild b/media-libs/libgphoto2/libgphoto2-2.1.6.ebuild
new file mode 100644
index 000000000000..c35e1ec95d05
--- /dev/null
+++ b/media-libs/libgphoto2/libgphoto2-2.1.6.ebuild
@@ -0,0 +1,123 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libgphoto2/libgphoto2-2.1.6.ebuild,v 1.1 2005/06/24 14:58:39 liquidx Exp $
+
+inherit libtool eutils
+
+DESCRIPTION="Library that implements support for numerous digital cameras"
+HOMEPAGE="http://www.gphoto.org/"
+SRC_URI="mirror://sourceforge/gphoto/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~amd64 ~ia64 ~ppc64 ~alpha"
+IUSE="nls doc jpeg nousb"
+
+# needs >usbutils-0.11-r2 to avoid /usr/lib/libusb*
+# conflicts with dev-libs/libusb
+RDEPEND="!nousb? (>=dev-libs/libusb-0.1.8
+ >=sys-apps/usbutils-0.11-r2
+ sys-apps/hotplug)
+ jpeg? ( >=media-libs/libexif-0.5.9 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( dev-util/gtk-doc )"
+
+# By default, drivers for all supported cards will be compiled.
+# If you want to only compile for specific card(s), set CAMERAS
+# environment to a comma-separated list (no spaces) of drivers that
+# you want to build.
+IUSE_CAMERAS="adc65 agfa-cl20 aox barbie canon casio digita dimera directory enigma13 fuji gsmart300 iclick jamcam jd11
+kodak konica largan mars minolta mustek panasonic pccam300 pccam600 polaroid ptp2 ricoh samsung
+sierra sipix smal sonydscf1 sonydscf55 soundvision spca50x sq905 stv0674 stv0680 sx330z toshiba"
+
+pkg_setup() {
+ if [ -z "${CAMERAS}" ] ; then
+ ewarn "All camera drivers will be built since you did not specify"
+ ewarn "via the CAMERAS variable what camera you use."
+ einfo "libgphoto2 supports: all ${IUSE_CAMERAS}"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-2.1.2-norpm.patch
+}
+
+src_compile() {
+ local cameras
+ local cam
+ for cam in ${CAMERAS} ; do
+ has ${cam} ${IUSE_CAMERAS} && cameras="${cameras},${cam}"
+ done
+ [ -z "${cameras}" ] \
+ && cameras="all" \
+ || cameras="${cameras:1}"
+ einfo $cameras
+
+ elibtoolize
+
+ local myconf
+
+ myconf="--with-rpmbuild=/bin/false"
+ myconf="--with-drivers=${cameras}"
+ use jpeg \
+ && myconf="${myconf} --with-exif-prefix=/usr" \
+ || myconf="${myconf} --without-exif"
+ myconf="${myconf} `use_enable nls`"
+ myconf="${myconf} `use_enable doc docs`"
+ econf ${myconf} || die "econf failed"
+ # or the documentation fails.
+ emake -j1 || die "make failed"
+}
+
+src_install() {
+ if use !nousb; then
+ make DESTDIR=${D} \
+ gphotodocdir=/usr/share/doc/${PF} \
+ HTML_DIR=/usr/share/doc/${PF}/sgml \
+ hotplugdocdir=/usr/share/doc/${PF}/linux-hotplug \
+ install || die "install failed"
+ else
+ make DESTDIR=${D} \
+ gphotodocdir=/usr/share/doc/${PF} \
+ HTML_DIR=/usr/share/doc/${PF}/sgml \
+ install || die "install failed"
+ fi
+
+ # manually move apidocs
+ if use doc; then
+ dodir /usr/share/doc/${PF}/api
+ mv ${D}/usr/share/doc/libgphoto2/html/api/* ${D}/usr/share/doc/${PF}/api/
+ mv ${D}/usr/share/doc/libgphoto2_port/html/api/* ${D}/usr/share/doc/${PF}/api/
+ fi
+ rm -rf ${D}/usr/share/doc/libgphoto2
+ rm -rf ${D}/usr/share/doc/libgphoto2_port
+
+ dodoc ChangeLog NEWS* README AUTHORS TESTERS MAINTAINERS HACKING CHANGES
+
+ # install hotplug support
+ if use !nousb; then
+ insinto /etc/hotplug/usb
+ newins ${S}/packaging/linux-hotplug/usbcam.console usbcam
+ chmod +x ${D}/etc/hotplug/usb/usbcam
+ fi
+}
+
+pkg_postinst() {
+ if use !nousb; then
+ einfo "Generating usbcam-gphoto2.usermap .."
+ HOTPLUG_USERMAP="/etc/hotplug/usb/usbcam-gphoto2.usermap"
+ if [ -x ${ROOT}/usr/$(get_libdir)/libgphoto2/print-usb-usermap ]; then
+ echo "# !!! DO NOT EDIT THIS FILE !!! This file is automatically generated." > ${ROOT}/${HOTPLUG_USERMAP}
+ echo "# Put your custom entries in /etc/hotplug/usb/usbcam.usermap" >> ${ROOT}/${HOTPLUG_USERMAP}
+ ${ROOT}/usr/$(get_libdir)/libgphoto2/print-usb-usermap >> ${ROOT}/${HOTPLUG_USERMAP}
+ else
+ eerror "Unable to find ${ROOT}/usr/$(get_libdir)/libgphoto2/print-usb-usermap"
+ eerror "and therefore unable to generate hotplug usermap."
+ eerror "You will have to manually generate it by running:"
+ eerror " /usr/$(get_libdir)/libgphoto2/print-usb-usermap > ${HOTPLUG_USERMAP}"
+ fi
+ fi
+}