summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Gavin <pete@gentoo.org>2001-05-22 01:27:07 +0000
committerPeter Gavin <pete@gentoo.org>2001-05-22 01:27:07 +0000
commit925f1f2c04852a5bbe22312ebca1e37605b459a6 (patch)
treef613acc1f5b33fe25ab645afaacfaba3ec403121 /media-libs
parentAdded the --autoclean parameter (diff)
downloadgentoo-2-925f1f2c04852a5bbe22312ebca1e37605b459a6.tar.gz
gentoo-2-925f1f2c04852a5bbe22312ebca1e37605b459a6.tar.bz2
gentoo-2-925f1f2c04852a5bbe22312ebca1e37605b459a6.zip
added media-libs/libsdl-1.2.0, media-libs/sdl-mixer-1.2.0, media-libs/sdl-net-1.2.0
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libsdl/libsdl-1.2.0.ebuild91
-rw-r--r--media-libs/sdl-mixer/files/digest-sdl-mixer-1.2.01
-rw-r--r--media-libs/sdl-mixer/sdl-mixer-1.2.0.ebuild35
-rw-r--r--media-libs/sdl-net/files/digest-sdl-net-1.2.01
-rw-r--r--media-libs/sdl-net/sdl-net-1.2.0.ebuild32
-rw-r--r--media-libs/smpeg/smpeg-0.4.3.ebuild52
6 files changed, 212 insertions, 0 deletions
diff --git a/media-libs/libsdl/libsdl-1.2.0.ebuild b/media-libs/libsdl/libsdl-1.2.0.ebuild
new file mode 100644
index 000000000000..bdb7a6d728c3
--- /dev/null
+++ b/media-libs/libsdl/libsdl-1.2.0.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.0.ebuild,v 1.1 2001/05/22 01:27:07 pete Exp $
+
+A=SDL-${PV}.tar.gz
+S=${WORKDIR}/SDL-${PV}
+DESCRIPTION="Simple Direct Media Layer"
+SRC_URI="http://www.libsdl.org/release/${A}"
+HOMEPAGE="http://www.libsdl.org/"
+
+DEPEND="virtual/glibc
+ >=dev-lang/nasm-0.98
+ >=media-libs/audiofile-0.1.9
+ opengl? ( virtual/opengl )
+ svga? ( >=media-libs/svgalib-1.4.2 )
+ esd? ( >=media-sound/esound-0.2.19 )
+ X? ( virtual/x11 )
+ arts? ( >=kde-base/kdelibs-2.0.1 )
+ nas? ( media-sound/nas )
+ ggi? ( >=medlia-libs/libggi-2.0_beta3 )"
+
+src_compile() {
+
+ local myconf
+
+ if [ -z "`use esd`" ]
+ then
+ myconf="--disable-esd"
+ fi
+
+ if [ -z "`use arts`" ]
+ then
+ myconf="${myconf} --disable-arts"
+ fi
+
+ if [ -z "`use nas`" ]
+ then
+ myconf="${myconf} --disable-nas"
+ fi
+
+ if [ -z "`use X`" ]
+ then
+ myconf="${myconf} --disable-video-x11"
+ fi
+ if [ "`use svga`" ]
+ then
+ myconf="${myconf} --enable-video-svga"
+ fi
+ if [ -z "`use fbcon`" ]
+ then
+ myconf="${myconf} --disable-video-fbcon"
+ fi
+ if [ "`use aalib`" ]
+ then
+ myconf="${myconf} --enable-video-aalib"
+ fi
+ if [ "`use ggi`" ]
+ then
+ myconf="${myconf} --enable-video-ggi"
+ fi
+ if [ -z "`use opengl`" ]
+ then
+ myconf="${myconf} --disable-video-opengl"
+ fi
+
+ try ./configure --host=${CHOST} --prefix=/usr --mandir=/usr/share/man ${myconf}
+
+ try make
+
+}
+
+src_install() {
+ cd ${S}
+ try make DESTDIR=${D} install
+ preplib /usr
+ dodoc BUGS COPYING CREDITS README* TODO WhatsNew
+ docinto html
+ dodoc *.html
+ docinto html/docs
+ dodoc docs/*.html
+
+}
+pkg_postinst() {
+
+ ldconfig -r ${ROOT}
+
+}
+
+
+
diff --git a/media-libs/sdl-mixer/files/digest-sdl-mixer-1.2.0 b/media-libs/sdl-mixer/files/digest-sdl-mixer-1.2.0
new file mode 100644
index 000000000000..f84d9bb7b552
--- /dev/null
+++ b/media-libs/sdl-mixer/files/digest-sdl-mixer-1.2.0
@@ -0,0 +1 @@
+MD5 3348f6b971b9acf54dbc74d5c57abc63 SDL_mixer-1.2.0.tar.gz
diff --git a/media-libs/sdl-mixer/sdl-mixer-1.2.0.ebuild b/media-libs/sdl-mixer/sdl-mixer-1.2.0.ebuild
new file mode 100644
index 000000000000..fd3339d84595
--- /dev/null
+++ b/media-libs/sdl-mixer/sdl-mixer-1.2.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-mixer/sdl-mixer-1.2.0.ebuild,v 1.1 2001/05/22 01:27:07 pete Exp $
+
+A=SDL_mixer-${PV}.tar.gz
+S=${WORKDIR}/SDL_mixer-${PV}
+DESCRIPTION="Simple Direct Media Layer Network Support Library"
+SRC_URI="http://www.libsdl.org/projects/SDL_mixer/release/${A}"
+HOMEPAGE="http://www.libsdl.org/projects/SDL_mixer/index.html"
+
+DEPEND="virtual/glibc
+ >=media-libs/libsdl-1.2.0
+ >=media-libs/smpeg-0.4.3
+ >=media-libs/libvorbis-1.0_beta4
+ >=media-sound/timidity++-2.10.4"
+
+src_compile() {
+ try ./configure --host=${CHOST} --prefix=/usr --mandir=/usr/share/man
+ try make
+}
+
+src_install() {
+ cd ${S}
+ try make DESTDIR=${D} install
+ preplib /usr
+ dodoc CHANGES COPYING README
+}
+
+pkg_postinst() {
+ ldconfig -r ${ROOT}
+}
+
+
+
diff --git a/media-libs/sdl-net/files/digest-sdl-net-1.2.0 b/media-libs/sdl-net/files/digest-sdl-net-1.2.0
new file mode 100644
index 000000000000..187cc685b8f7
--- /dev/null
+++ b/media-libs/sdl-net/files/digest-sdl-net-1.2.0
@@ -0,0 +1 @@
+MD5 c8d4452f58c457b6f3dd6ca04bf3f071 SDL_net-1.2.0.tar.gz
diff --git a/media-libs/sdl-net/sdl-net-1.2.0.ebuild b/media-libs/sdl-net/sdl-net-1.2.0.ebuild
new file mode 100644
index 000000000000..29c9a75efe1d
--- /dev/null
+++ b/media-libs/sdl-net/sdl-net-1.2.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-net/sdl-net-1.2.0.ebuild,v 1.1 2001/05/22 01:27:07 pete Exp $
+
+A=SDL_net-${PV}.tar.gz
+S=${WORKDIR}/SDL_net-${PV}
+DESCRIPTION="Simple Direct Media Layer Network Support Library"
+SRC_URI="http://www.libsdl.org/projects/SDL_net/release/${A}"
+HOMEPAGE="http://www.libsdl.org/projects/SDL_net/index.html"
+
+DEPEND="virtual/glibc
+ >=media-libs/libsdl-1.2.0"
+
+src_compile() {
+ try ./configure --host=${CHOST} --prefix=/usr --mandir=/usr/share/man
+ try make
+}
+
+src_install() {
+ cd ${S}
+ try make DESTDIR=${D} install
+ preplib /usr
+ dodoc CHANGES COPYING README
+}
+
+pkg_postinst() {
+ ldconfig -r ${ROOT}
+}
+
+
+
diff --git a/media-libs/smpeg/smpeg-0.4.3.ebuild b/media-libs/smpeg/smpeg-0.4.3.ebuild
new file mode 100644
index 000000000000..6b76c9481ea8
--- /dev/null
+++ b/media-libs/smpeg/smpeg-0.4.3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-libs/smpeg/smpeg-0.4.3.ebuild,v 1.1 2001/05/22 01:27:07 pete Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="SDL MPEG Player Library"
+SRC_URI="ftp://ftp.lokigames.com/pub/open-source/smpeg/${A}"
+HOMEPAGE="http://www.lokigames.com/development/smpeg.php3"
+
+DEPEND=">=media-libs/libsdl-1.2.0
+ opengl? ( virtual/opengl )
+ gtk? ( >=dev-libs/glib-1.2.8
+ >=x11-libs/gtk+-1.2.8 )"
+
+src_compile() {
+
+ local myconf
+ if [ "`use mmx`" ]
+ then
+ myconf="--enable-mmx"
+ fi
+ if [ -z "`use gtk`" ]
+ then
+ myconf="${myconf} --disable-gtk-player"
+ fi
+ if [ -z "`use X`" ]
+ then
+ myconf="${myconf} --disable-gtk-player --without-x"
+ fi
+
+ if [ -z "`use opengl`" ]
+ then
+ myconf="${myconf} --disable-opengl-player"
+ fi
+ try ./configure --prefix=/usr --mandir=/usr/share/man --host=${CHOST} ${myconf}
+ try make
+
+}
+
+src_install () {
+
+ try make DESTDIR=${D} install
+
+ dodoc CHANGES COPYING README* TODO
+
+}
+
+
+
+