summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2013-04-17 19:51:34 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2013-04-17 19:51:34 +0000
commit9cb27934ba400015fe5b31a48fd98d337d7d275b (patch)
tree106fbc7f817f7dc14acd77077bcd204262f0e80b /media-libs
parentVersion bump (diff)
downloadgentoo-2-9cb27934ba400015fe5b31a48fd98d337d7d275b.tar.gz
gentoo-2-9cb27934ba400015fe5b31a48fd98d337d7d275b.tar.bz2
gentoo-2-9cb27934ba400015fe5b31a48fd98d337d7d275b.zip
Initial commit
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key C2BA7F3C!)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/opusfile/ChangeLog9
-rw-r--r--media-libs/opusfile/Manifest3
-rw-r--r--media-libs/opusfile/metadata.xml13
-rw-r--r--media-libs/opusfile/opusfile-0.2.ebuild32
4 files changed, 57 insertions, 0 deletions
diff --git a/media-libs/opusfile/ChangeLog b/media-libs/opusfile/ChangeLog
new file mode 100644
index 000000000000..54a32c8ec1cb
--- /dev/null
+++ b/media-libs/opusfile/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for media-libs/opusfile
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/opusfile/ChangeLog,v 1.1 2013/04/17 19:51:34 hwoarang Exp $
+
+*opusfile-0.2 (17 Apr 2013)
+
+ 17 Apr 2013; Markos Chandras <hwoarang@gentoo.org> +metadata.xml,
+ +opusfile-0.2.ebuild:
+ Initial commit
diff --git a/media-libs/opusfile/Manifest b/media-libs/opusfile/Manifest
new file mode 100644
index 000000000000..7aee8356e0ff
--- /dev/null
+++ b/media-libs/opusfile/Manifest
@@ -0,0 +1,3 @@
+DIST opusfile-0.2.tar.gz 399527 SHA256 b4a678b3b6c4adfb6aff1f67ef658becfe146ea7c7ff228e99543762171557f9 SHA512 bfcd50d6e7700c7defaa7b45254f587754f815175ecd217d3bee218e14f17150e0b267602110075db7b81b1d907a6d1559faa77824336e424ccf1d38b0139ac6 WHIRLPOOL c508d48c40f2e8806df6902caa0192adb51c84a93e077cff892cee2b72b19262e6a0c13395b6db8a0b27c6186eddbb2c083426c8de04a177b5d011ff0ceab3e5
+EBUILD opusfile-0.2.ebuild 717 SHA256 4e66e28c826d455b02385418a3dc28ca783fdaaf3e6689bfecba592508b698c2 SHA512 a8f1d6884c61c2ec9e7ad7de95d5afcb5ef48d9041a0621c67c658b385e058dcb05091ba865250f40819befb0e17f0c1a2aefbb6f7dab5c605b283756e4ee196 WHIRLPOOL de4a783521c646fb57700701d72c4e7e7493099ff321b43f12a3585fa0a2bd7a8c48eddecf1cb30cc8203a22b1d241dd4c2df6885182878e71f6deb070a558e9
+MISC metadata.xml 435 SHA256 adcd77f39994f02dd0b61b75f86a47473aaac2723de77f6a0f1623e69c0cb97b SHA512 f7ac9cae0e936e6c99ec9bd6ad9cff0b0bd92cb03adfcc06eb5fa1838915b53af1046620c038abbbe3f1d3d0fa7d8f1ff5f9f3113c957e98adbfa61f3ac823f9 WHIRLPOOL 74a41e02750ab49de6faed28ad3118cba120851674e3e5aa9af4779f2ad2e20f6732bd696fb592311ad989dcf6c386de53c32ccfb1d304d3eb769c36660020a6
diff --git a/media-libs/opusfile/metadata.xml b/media-libs/opusfile/metadata.xml
new file mode 100644
index 000000000000..5d867fdf0ea1
--- /dev/null
+++ b/media-libs/opusfile/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>hwoarang@gentoo.org</email>
+<name>Markos Chandras</name>
+</maintainer>
+<use>
+<flag name='fixed-point'>Enable fixed-point arithmetic operations</flag>
+<flag name='float'>Enable floating point arithmetic operations</flag>
+<flag name='http'>Enable http connections</flag>
+</use>
+</pkgmetadata>
diff --git a/media-libs/opusfile/opusfile-0.2.ebuild b/media-libs/opusfile/opusfile-0.2.ebuild
new file mode 100644
index 000000000000..4c29581830dc
--- /dev/null
+++ b/media-libs/opusfile/opusfile-0.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/opusfile/opusfile-0.2.ebuild,v 1.1 2013/04/17 19:51:34 hwoarang Exp $
+
+EAPI=5
+
+DESCRIPTION="A high-level decoding and seeking API for .opus files"
+HOMEPAGE="http://www.opus-codec.org/"
+SRC_URI="http://downloads.xiph.org/releases/opus/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc fixed-point +float +http static-libs"
+
+RDEPEND="media-libs/libogg
+ media-libs/opus
+ http? ( dev-libs/openssl )"
+
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+REQUIRED_USE="^^ ( fixed-point float )"
+
+src_configure() {
+ econf \
+ $(use_enable doc) \
+ $(use_enable fixed-point)\
+ $(use_enable float) \
+ $(use_enable http) \
+ $(use_enable static-libs static)
+}