summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorben Hohn <torbenh@gentoo.org>2004-02-27 07:47:52 +0000
committerTorben Hohn <torbenh@gentoo.org>2004-02-27 07:47:52 +0000
commitb87c20e638cb9fab23bdcb2595fe587e536a4402 (patch)
treef209cc5fc15a83cb7754dff1149b651577ea2c17 /media-libs
parentFixed Dependencies (Manifest recommit) (diff)
downloadgentoo-2-b87c20e638cb9fab23bdcb2595fe587e536a4402.tar.gz
gentoo-2-b87c20e638cb9fab23bdcb2595fe587e536a4402.tar.bz2
gentoo-2-b87c20e638cb9fab23bdcb2595fe587e536a4402.zip
Version bump with USE flag additions
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/raptor/ChangeLog8
-rw-r--r--media-libs/raptor/files/digest-raptor-1.2.01
-rw-r--r--media-libs/raptor/raptor-1.2.0.ebuild65
3 files changed, 73 insertions, 1 deletions
diff --git a/media-libs/raptor/ChangeLog b/media-libs/raptor/ChangeLog
index 8648814891c2..25d384a29812 100644
--- a/media-libs/raptor/ChangeLog
+++ b/media-libs/raptor/ChangeLog
@@ -1,11 +1,17 @@
# ChangeLog for media-libs/raptor
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/raptor/ChangeLog,v 1.6 2004/02/13 03:04:30 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/raptor/ChangeLog,v 1.7 2004/02/27 07:47:50 torbenh Exp $
12 Feb 2004; Jeremy Huddleston <eradicator@gentoo.org> raptor-0.9.12.ebuild,
raptor-0.9.8.ebuild:
Added optional curl and ssl dependencies. Closes bug #34870.
+*raptor-1.2.0 (27 Feb 2004)
+
+ 27 Feb 2004; <torbenh@gentoo.org> raptor-1.2.0.ebuild:
+ Added new Version including many USE flags.
+ This nice ebuild submitted by: iulica@box.co.uk
+
27 Jan 2004; <torbenh@gentoo.org> raptor-0.9.12.ebuild:
bumped 0.9.12 to stable
diff --git a/media-libs/raptor/files/digest-raptor-1.2.0 b/media-libs/raptor/files/digest-raptor-1.2.0
new file mode 100644
index 000000000000..bdf3150efd0d
--- /dev/null
+++ b/media-libs/raptor/files/digest-raptor-1.2.0
@@ -0,0 +1 @@
+MD5 d810016fd0014a1699f2aca69e7ec582 raptor-1.2.0.tar.gz 618917
diff --git a/media-libs/raptor/raptor-1.2.0.ebuild b/media-libs/raptor/raptor-1.2.0.ebuild
new file mode 100644
index 000000000000..105ac55fb0eb
--- /dev/null
+++ b/media-libs/raptor/raptor-1.2.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/raptor/raptor-1.2.0.ebuild,v 1.1 2004/02/27 07:47:50 torbenh Exp $
+
+DESCRIPTION="The RDF Parser Toolkit"
+HOMEPAGE="http://www.redland.opensource.ac.uk/raptor/"
+SRC_URI="http://www.redland.opensource.ac.uk/dist/source/${P}.tar.gz"
+LICENSE="LGPL-2 MPL-1.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="curl xml2 gnome"
+DEPEND="virtual/glibc
+ gnome? ( >=dev-libs/glib-2.2.1 dev-util/pkgconfig )
+ xml2? ( >=dev-libs/libxml2-2.4.0 ) : ( dev-libs/expat )
+ ssl? ( dev-libs/openssl )
+ curl? ( net-ftp/curl )"
+RDEPEND="virtual/glibc
+ gnome? ( >=dev-libs/glib-2.2.1 )
+ xml2? ( >=dev-libs/libxml2-2.4.0 ) : ( dev-libs/expat )
+ ssl? ( dev-libs/openssl )
+ curl? ( net-ftp/curl )"
+
+# compilation with libwww currently breaks and for using libfetch I didn't find the right USE flag
+#IUSE="curl xml2 libwww gnome"
+#DEPEND="virtual/glibc
+# gnome? ( >=dev-libs/glib-2.2.1 dev-util/pkgconfig )
+# xml2? ( >=dev-libs/libxml2-2.4.0 ) : ( dev-libs/expat )
+# ssl? ( dev-libs/openssl )
+# curl? ( net-ftp/curl ) : ( !xml2? ( libwww? ( net-libs/libwww ) ) )
+# "
+#RDEPEND="virtual/glibc
+# gnome? ( >=dev-libs/glib-2.2.1 )
+# xml2? ( >=dev-libs/libxml2-2.4.0 ) : ( dev-libs/expat )
+# ssl? ( dev-libs/openssl )
+# curl? ( net-ftp/curl ) : ( !xml2? ( libwww? ( net-libs/libwww ) ) )"
+
+S=${WORKDIR}/${P}
+
+DOC="AUTHORS COPYING COPYING.LIB ChangeLog INSTALL LICENSE.txt NEWS README"
+HTML="INSTALL.html LICENSE.html MPL.html NEWS.html README.html"
+
+src_compile() {
+ myraptorconf=""
+
+ use xml2 \
+ && myraptorconf="${myraptorconf} --with-xml-parser=libxml" \
+ || myraptorconf="${myraptorconf} --with-xml-parser=expat"
+
+ use curl && myraptorconf="${myraptorconf} --with-www=curl" \
+ || use xml2 && myraptorconf="${myraptorconf} --with-www=xml" \
+ || myraptorconf="${myraptorconf} --with-www=none"
+# || use libwww && myraptorconf="${myraptorconf} --with-www=libwww" \
+ econf \
+ `use_enable gnome nfc-check` \
+ ${myraptorconf} \
+ || die "configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ dodoc ${DOC}
+ dohtml ${HTML}
+}