summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-09-11 19:24:24 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-09-11 19:24:24 +0000
commitb97529cfc05e31105c01755dc2a7a32faf50a733 (patch)
tree07e3ada6408e41253068450f1d84ec2a928a7e5c /media-libs
parentVersion bump. (diff)
downloadgentoo-2-b97529cfc05e31105c01755dc2a7a32faf50a733.tar.gz
gentoo-2-b97529cfc05e31105c01755dc2a7a32faf50a733.tar.bz2
gentoo-2-b97529cfc05e31105c01755dc2a7a32faf50a733.zip
Fix mathlib test wrt #377253 by Brennan Shacklett and Dave Beckett (upstream)
(Portage version: 2.2.0_alpha54/cvs/Linux x86_64)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/raptor/ChangeLog6
-rw-r--r--media-libs/raptor/files/raptor-2.0.4-fix_math_test.patch34
-rw-r--r--media-libs/raptor/raptor-2.0.4.ebuild6
3 files changed, 43 insertions, 3 deletions
diff --git a/media-libs/raptor/ChangeLog b/media-libs/raptor/ChangeLog
index 0c8f239f3b79..b85ad4eacec4 100644
--- a/media-libs/raptor/ChangeLog
+++ b/media-libs/raptor/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/raptor
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/raptor/ChangeLog,v 1.104 2011/08/13 17:22:53 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/raptor/ChangeLog,v 1.105 2011/09/11 19:24:24 ssuominen Exp $
+
+ 11 Sep 2011; Samuli Suominen <ssuominen@gentoo.org> raptor-2.0.4.ebuild,
+ +files/raptor-2.0.4-fix_math_test.patch:
+ Fix mathlib test wrt #377253 by Brennan Shacklett and Dave Beckett (upstream)
13 Aug 2011; Markus Meier <maekke@gentoo.org> raptor-1.4.21-r1.ebuild:
arm stable, bug #376893
diff --git a/media-libs/raptor/files/raptor-2.0.4-fix_math_test.patch b/media-libs/raptor/files/raptor-2.0.4-fix_math_test.patch
new file mode 100644
index 000000000000..76e698a3564a
--- /dev/null
+++ b/media-libs/raptor/files/raptor-2.0.4-fix_math_test.patch
@@ -0,0 +1,34 @@
+This patch is unnecessary for raptor-2.0.5 and above, only to be used with 2.0.4
+
+http://bugs.gentoo.org/show_bug.cgi?id=377253#c12
+
+--- a/configure.ac 2011-09-10 22:31:37.791042002 -0700
++++ b/configure.ac 2011-09-10 22:51:12.789352501 -0700
+@@ -407,8 +407,12 @@
+ #ifdef HAVE_MATH_H
+ #include <math.h>
+ #endif
++#ifdef HAVE_STDLIB_H
++#include <stdlib.h>
++#endif
+ ]], [[
+-double d = trunc(1.0F) + round(1.0F);
++double t = atof("0.000");
++return (int)(trunc(t) * round(t));
+ ]])],
+ AC_MSG_RESULT(yes)
+ trunc_round_lib=libc,
+@@ -421,8 +425,12 @@
+ #ifdef HAVE_MATH_H
+ #include <math.h>
+ #endif
++#ifdef HAVE_STDLIB_H
++#include <stdlib.h>
++#endif
+ ]], [[
+-double d = trunc(1.0F) + round(1.0F);
++double t = atof("0.000");
++return (int)(trunc(t) * round(t));
+ ]])],
+ AC_MSG_RESULT(yes)
+ need_libm=1
diff --git a/media-libs/raptor/raptor-2.0.4.ebuild b/media-libs/raptor/raptor-2.0.4.ebuild
index 04117ea185b0..415f66b5f92f 100644
--- a/media-libs/raptor/raptor-2.0.4.ebuild
+++ b/media-libs/raptor/raptor-2.0.4.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/raptor/raptor-2.0.4.ebuild,v 1.1 2011/07/26 16:40:12 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/raptor/raptor-2.0.4.ebuild,v 1.2 2011/09/11 19:24:24 ssuominen Exp $
EAPI=4
-inherit eutils libtool
+inherit autotools eutils libtool
MY_P=${PN}2-${PV}
@@ -32,6 +32,8 @@ S=${WORKDIR}/${MY_P}
DOCS=( AUTHORS ChangeLog NEWS NOTICE README )
src_prepare() {
+ epatch "${FILESDIR}"/${P}-fix_math_test.patch
+ eautoreconf # only for -fix_math_test.patch
epunt_cxx
elibtoolize
}