summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-06-08 17:54:34 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-06-08 17:54:34 +0000
commitd85629df31310955133fd2fb619bfbe90ac4890a (patch)
tree6f9d2f89f2d29369fd54bdca2f5db51d4dbb2cb0 /media-libs
parentInitial ebuild for aspell-vi-0.01.1.1 (diff)
downloadgentoo-2-d85629df31310955133fd2fb619bfbe90ac4890a.tar.gz
gentoo-2-d85629df31310955133fd2fb619bfbe90ac4890a.tar.bz2
gentoo-2-d85629df31310955133fd2fb619bfbe90ac4890a.zip
Add examples useflag as requested by Stefan de Konink in bug #136081.
(Portage version: 2.1_rc4-r4)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libtheora/ChangeLog6
-rw-r--r--media-libs/libtheora/libtheora-1.0_alpha6.ebuild19
2 files changed, 20 insertions, 5 deletions
diff --git a/media-libs/libtheora/ChangeLog b/media-libs/libtheora/ChangeLog
index 863456e7334c..8acc44631e66 100644
--- a/media-libs/libtheora/ChangeLog
+++ b/media-libs/libtheora/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/libtheora
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libtheora/ChangeLog,v 1.39 2006/06/07 12:01:51 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libtheora/ChangeLog,v 1.40 2006/06/08 17:54:34 flameeyes Exp $
+
+ 08 Jun 2006; Diego Pettenò <flameeyes@gentoo.org>
+ libtheora-1.0_alpha6.ebuild:
+ Add examples useflag as requested by Stefan de Konink in bug #136081.
*libtheora-1.0_alpha6 (07 Jun 2006)
diff --git a/media-libs/libtheora/libtheora-1.0_alpha6.ebuild b/media-libs/libtheora/libtheora-1.0_alpha6.ebuild
index ba648c70a949..4e910d546959 100644
--- a/media-libs/libtheora/libtheora-1.0_alpha6.ebuild
+++ b/media-libs/libtheora/libtheora-1.0_alpha6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libtheora/libtheora-1.0_alpha6.ebuild,v 1.1 2006/06/07 12:01:51 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libtheora/libtheora-1.0_alpha6.ebuild,v 1.2 2006/06/08 17:54:34 flameeyes Exp $
inherit flag-o-matic libtool autotools
@@ -11,7 +11,7 @@ SRC_URI="http://downloads.xiph.org/releases/theora/${P/_}.tar.bz2"
LICENSE="xiph"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="encode doc"
+IUSE="encode doc examples"
RDEPEND=">=media-libs/libogg-1.1.0
encode? ( >=media-libs/libvorbis-1.0.1 )"
@@ -29,6 +29,12 @@ src_unpack() {
AT_M4DIR="m4" eautoreconf
elibtoolize
+
+ if use examples; then
+ # This creates a clean copy of examples sources
+ cp -R "${S}/examples" "${WORKDIR}"
+ rm -f "${WORKDIR}/examples/Makefile"*
+ fi
}
src_compile() {
@@ -46,10 +52,15 @@ src_compile() {
}
src_install() {
- make \
+ emake \
DESTDIR="${D}" \
- docdir=usr/share/doc/${PF} \
+ docdir="usr/share/doc/${PF}" \
install || die "make install failed"
+ if use examples; then
+ insinto "/usr/share/doc/${PF}/examples"
+ doins "${WORKDIR}/examples/"*
+ fi
+
dodoc README
}