summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-04-26 06:52:08 +0000
committerTim Harder <radhermit@gentoo.org>2011-04-26 06:52:08 +0000
commitd8eb2bd1e5074b83084cddbbe1bf117b7df1db17 (patch)
tree54a0f63850a23e78ef3f54390d0873dc12e84900 /media-libs
parentAdd missing dependency on net-misc/curl. Fixed bug 364767. (diff)
downloadgentoo-2-d8eb2bd1e5074b83084cddbbe1bf117b7df1db17.tar.gz
gentoo-2-d8eb2bd1e5074b83084cddbbe1bf117b7df1db17.tar.bz2
gentoo-2-d8eb2bd1e5074b83084cddbbe1bf117b7df1db17.zip
Add patch to fix build with gcc-4.6 (bug #364781).
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/rubberband/ChangeLog6
-rw-r--r--media-libs/rubberband/files/rubberband-1.6.0-gcc-4.6.patch10
-rw-r--r--media-libs/rubberband/rubberband-1.6.0.ebuild8
3 files changed, 21 insertions, 3 deletions
diff --git a/media-libs/rubberband/ChangeLog b/media-libs/rubberband/ChangeLog
index 098ee3cc43e9..79f54f90ed45 100644
--- a/media-libs/rubberband/ChangeLog
+++ b/media-libs/rubberband/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/rubberband
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/rubberband/ChangeLog,v 1.13 2011/04/26 05:34:56 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/rubberband/ChangeLog,v 1.14 2011/04/26 06:52:08 radhermit Exp $
+
+ 26 Apr 2011; Tim Harder <radhermit@gentoo.org> rubberband-1.6.0.ebuild,
+ +files/rubberband-1.6.0-gcc-4.6.patch:
+ Add patch to fix build with gcc-4.6 (bug #364781).
*rubberband-1.6.0 (26 Apr 2011)
diff --git a/media-libs/rubberband/files/rubberband-1.6.0-gcc-4.6.patch b/media-libs/rubberband/files/rubberband-1.6.0-gcc-4.6.patch
new file mode 100644
index 000000000000..38ac76d42756
--- /dev/null
+++ b/media-libs/rubberband/files/rubberband-1.6.0-gcc-4.6.patch
@@ -0,0 +1,10 @@
+--- rubberband-1.6.0.orig/rubberband/RubberBandStretcher.h
++++ rubberband-1.6.0/rubberband/RubberBandStretcher.h
+@@ -21,6 +21,7 @@
+
+ #include <vector>
+ #include <map>
++#include <cstddef>
+
+ /**
+ * @mainpage RubberBand
diff --git a/media-libs/rubberband/rubberband-1.6.0.ebuild b/media-libs/rubberband/rubberband-1.6.0.ebuild
index b7ed4df929f1..f78e0503ba09 100644
--- a/media-libs/rubberband/rubberband-1.6.0.ebuild
+++ b/media-libs/rubberband/rubberband-1.6.0.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/rubberband/rubberband-1.6.0.ebuild,v 1.1 2011/04/26 05:34:56 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/rubberband/rubberband-1.6.0.ebuild,v 1.2 2011/04/26 06:52:08 radhermit Exp $
EAPI=4
-inherit multilib
+inherit multilib eutils
DESCRIPTION="An audio time-stretching and pitch-shifting library and utility program"
HOMEPAGE="http://www.breakfastquay.com/rubberband/"
@@ -22,6 +22,10 @@ RDEPEND="media-libs/vamp-plugin-sdk
DEPEND="${RDEPEND}
dev-util/pkgconfig"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc-4.6.patch
+}
+
src_install() {
emake INSTALL_BINDIR="${D}/usr/bin" \
INSTALL_INCDIR="${D}/usr/include/rubberband" \