summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon Stelling <blubb@gentoo.org>2007-02-17 21:39:40 +0000
committerSimon Stelling <blubb@gentoo.org>2007-02-17 21:39:40 +0000
commitded9c082f68bbb8dcb5ea5ccf66a295601382504 (patch)
treee6905e78e6a291138e62a1439c099a5d531b8cef /media-libs
parentRemove old versions. (diff)
downloadgentoo-2-ded9c082f68bbb8dcb5ea5ccf66a295601382504.tar.gz
gentoo-2-ded9c082f68bbb8dcb5ea5ccf66a295601382504.tar.bz2
gentoo-2-ded9c082f68bbb8dcb5ea5ccf66a295601382504.zip
fix from my last commit: string equality != integer equality
(Portage version: 2.1.2-r9)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/mesa/ChangeLog5
-rw-r--r--media-libs/mesa/mesa-6.5.1-r1.ebuild8
2 files changed, 9 insertions, 4 deletions
diff --git a/media-libs/mesa/ChangeLog b/media-libs/mesa/ChangeLog
index e867c82f46d0..bc472d546ec9 100644
--- a/media-libs/mesa/ChangeLog
+++ b/media-libs/mesa/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-libs/mesa
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/ChangeLog,v 1.136 2007/02/17 15:54:26 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/ChangeLog,v 1.137 2007/02/17 21:39:40 blubb Exp $
+
+ 17 Feb 2007; Simon Stelling <blubb@gentoo.org> mesa-6.5.1-r1.ebuild:
+ fix from my last commit: string equality != integer equality
17 Feb 2007; Simon Stelling <blubb@gentoo.org> mesa-6.5.1-r1.ebuild,
mesa-6.5.2.ebuild:
diff --git a/media-libs/mesa/mesa-6.5.1-r1.ebuild b/media-libs/mesa/mesa-6.5.1-r1.ebuild
index f2d4baa880ea..3d96f3b34fcb 100644
--- a/media-libs/mesa/mesa-6.5.1-r1.ebuild
+++ b/media-libs/mesa/mesa-6.5.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/mesa-6.5.1-r1.ebuild,v 1.11 2007/02/17 15:54:26 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/mesa-6.5.1-r1.ebuild,v 1.12 2007/02/17 21:39:40 blubb Exp $
inherit eutils toolchain-funcs multilib flag-o-matic portability
@@ -86,13 +86,15 @@ pkg_setup() {
elif use x86 ; then
CONFIG="linux-dri-x86"
elif use amd64; then
- [[ ${ABI} -eq "amd64" ]] && CONFIG="linux-dri-x86-64"
- [[ ${ABI} -eq "x86" ]] && CONFIG="linux-dri-x86"
+ [[ ${ABI} == "amd64" ]] && CONFIG="linux-dri-x86-64"
+ [[ ${ABI} == "x86" ]] && CONFIG="linux-dri-x86"
elif use ppc; then
CONFIG="linux-dri-ppc"
else
CONFIG="linux-dri"
fi
+ eerror $CONFIG
+ eerror $ABI
}
src_unpack() {