summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2012-01-17 15:27:34 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2012-01-17 15:27:34 +0000
commite0e582d45e978a27a197c23a161e645aa5e05856 (patch)
tree50710287ffa6fbcce123c47bf6c0f10a47038bea /media-libs
parentFix DESCRIPTION and HOMEPAGE, thanks to James Rowe, wrt bug #399175 (diff)
downloadgentoo-2-e0e582d45e978a27a197c23a161e645aa5e05856.tar.gz
gentoo-2-e0e582d45e978a27a197c23a161e645aa5e05856.tar.bz2
gentoo-2-e0e582d45e978a27a197c23a161e645aa5e05856.zip
EAPI=2; split mod support between mikmod and modplug
(Portage version: 2.1.10.41/cvs/Linux i686)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/sdl-sound/ChangeLog7
-rw-r--r--media-libs/sdl-sound/sdl-sound-1.0.3.ebuild20
2 files changed, 15 insertions, 12 deletions
diff --git a/media-libs/sdl-sound/ChangeLog b/media-libs/sdl-sound/ChangeLog
index 9465bad2b3f2..f0218d7894cd 100644
--- a/media-libs/sdl-sound/ChangeLog
+++ b/media-libs/sdl-sound/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-libs/sdl-sound
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-sound/ChangeLog,v 1.39 2010/07/27 00:33:06 mr_bones_ Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-sound/ChangeLog,v 1.40 2012/01/17 15:27:34 mr_bones_ Exp $
+
+ 17 Jan 2012; Michael Sterrett <mr_bones_@gentoo.org> sdl-sound-1.0.3.ebuild:
+ EAPI=2; split mod support between mikmod and modplug
27 Jul 2010; Michael Sterrett <mr_bones_@gentoo.org>
sdl-sound-1.0.3.ebuild:
diff --git a/media-libs/sdl-sound/sdl-sound-1.0.3.ebuild b/media-libs/sdl-sound/sdl-sound-1.0.3.ebuild
index 0bfe6a588d3a..6d658527c57d 100644
--- a/media-libs/sdl-sound/sdl-sound-1.0.3.ebuild
+++ b/media-libs/sdl-sound/sdl-sound-1.0.3.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-sound/sdl-sound-1.0.3.ebuild,v 1.6 2010/07/27 00:33:06 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-sound/sdl-sound-1.0.3.ebuild,v 1.7 2012/01/17 15:27:34 mr_bones_ Exp $
+EAPI=2
MY_P="${P/sdl-/SDL_}"
DESCRIPTION="A library that handles the decoding of sound file formats"
HOMEPAGE="http://icculus.org/SDL_sound/"
@@ -10,11 +11,12 @@ SRC_URI="http://icculus.org/SDL_sound/downloads/${MY_P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="amd64 ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="flac mikmod mp3 mpeg physfs speex static-libs vorbis"
+IUSE="flac mikmod modplug mp3 mpeg physfs speex static-libs vorbis"
RDEPEND=">=media-libs/libsdl-1.2
flac? ( media-libs/flac )
- mikmod? ( >=media-libs/libmikmod-3.1.9 media-libs/libmodplug )
+ mikmod? ( >=media-libs/libmikmod-3.1.9 )
+ modplug? ( media-libs/libmodplug )
vorbis? ( >=media-libs/libvorbis-1.0_beta4 )
speex? ( media-libs/speex media-libs/libogg )
physfs? ( dev-games/physfs )
@@ -24,7 +26,7 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${MY_P}
-src_compile() {
+src_configure() {
econf \
--disable-dependency-tracking \
--enable-midi \
@@ -34,15 +36,13 @@ src_compile() {
$(use_enable speex) \
$(use_enable static-libs static) \
$(use_enable mikmod) \
- $(use_enable mikmod modplug) \
+ $(use_enable modplug) \
$(use_enable physfs) \
- $(use_enable vorbis ogg) \
- || die
- emake || die "emake failed"
+ $(use_enable vorbis ogg)
}
src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
+ emake DESTDIR="${D}" install || die
dodoc CHANGELOG CREDITS README TODO
if ! use static-libs ; then
find "${D}" -type f -name '*.la' -exec rm {} + \