summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2008-08-06 22:37:29 +0000
committerBen de Groot <yngwin@gentoo.org>2008-08-06 22:37:29 +0000
commit0053feedd88b4dbdc0673f18dc075ee76a6571a1 (patch)
treee6f762171da400124f7a6f090316b26cc7ca4e2c /media-plugins/alsa-plugins
parentfix build with gcc 4.3, bug #232773 (diff)
downloadgentoo-2-0053feedd88b4dbdc0673f18dc075ee76a6571a1.tar.gz
gentoo-2-0053feedd88b4dbdc0673f18dc075ee76a6571a1.tar.bz2
gentoo-2-0053feedd88b4dbdc0673f18dc075ee76a6571a1.zip
Adding patch to detect new ffmpeg headers location. Thanks to Rafał Mużyło and Martin von Gagern in bug 218088.
(Portage version: 2.2_rc6/cvs/Linux 2.6.26-hg1 i686)
Diffstat (limited to 'media-plugins/alsa-plugins')
-rw-r--r--media-plugins/alsa-plugins/ChangeLog9
-rw-r--r--media-plugins/alsa-plugins/alsa-plugins-1.0.17-r1.ebuild72
-rw-r--r--media-plugins/alsa-plugins/files/ffmpeg-headers.patch54
3 files changed, 134 insertions, 1 deletions
diff --git a/media-plugins/alsa-plugins/ChangeLog b/media-plugins/alsa-plugins/ChangeLog
index 5667e1ae0d36..d13f01aa0256 100644
--- a/media-plugins/alsa-plugins/ChangeLog
+++ b/media-plugins/alsa-plugins/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-plugins/alsa-plugins
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/alsa-plugins/ChangeLog,v 1.77 2008/08/03 08:02:00 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/alsa-plugins/ChangeLog,v 1.78 2008/08/06 22:37:28 yngwin Exp $
+
+*alsa-plugins-1.0.17-r1 (06 Aug 2008)
+
+ 06 Aug 2008; Ben de Groot <yngwin@gentoo.org> +files/ffmpeg-headers.patch,
+ +alsa-plugins-1.0.17-r1.ebuild:
+ Adding patch to detect new ffmpeg headers location. Thanks to Rafał
+ Mużyło and Martin von Gagern in bug 218088.
03 Aug 2008; Petteri Räty <betelgeuse@gentoo.org>
alsa-plugins-1.0.14.ebuild, alsa-plugins-1.0.16.ebuild:
diff --git a/media-plugins/alsa-plugins/alsa-plugins-1.0.17-r1.ebuild b/media-plugins/alsa-plugins/alsa-plugins-1.0.17-r1.ebuild
new file mode 100644
index 000000000000..90b3e0b0de06
--- /dev/null
+++ b/media-plugins/alsa-plugins/alsa-plugins-1.0.17-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/alsa-plugins/alsa-plugins-1.0.17-r1.ebuild,v 1.1 2008/08/06 22:37:28 yngwin Exp $
+
+inherit libtool autotools eutils flag-o-matic
+
+MY_P="${P/_/}"
+
+DESCRIPTION="ALSA extra plugins"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/plugins/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="debug ffmpeg jack libsamplerate pulseaudio speex"
+
+RDEPEND=">=media-libs/alsa-lib-${PV}
+ ffmpeg? ( media-video/ffmpeg )
+ jack? ( >=media-sound/jack-audio-connection-kit-0.98 )
+ libsamplerate? ( media-libs/libsamplerate )
+ pulseaudio? ( media-sound/pulseaudio )
+ speex? ( media-libs/speex )
+ !media-plugins/alsa-jack"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${PN}-1.0.17-automagic.patch"
+ epatch "${FILESDIR}/${PN}-1.0.14_rc1-init-ffmpeg.patch"
+ epatch "${FILESDIR}"/ffmpeg-headers.patch
+
+ # For some reasons the polyp/pulse plugin does fail with alsaplayer with a
+ # failed assert. As the code works just fine with asserts disabled, for now
+ # disable them waiting for a better solution.
+ sed -i -e '/AM_CFLAGS/s:-Wall:-DNDEBUG -Wall:' \
+ "${S}/pulse/Makefile.am"
+
+ eautoreconf
+ elibtoolize
+}
+
+src_compile() {
+ use debug || append-flags -DNDEBUG
+
+ econf \
+ $(use_enable ffmpeg avcodec) \
+ $(use_enable jack) \
+ $(use_enable libsamplerate samplerate) \
+ $(use_enable pulseaudio) \
+ $(use_with speex speex lib) \
+ --disable-dependency-tracking \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ cd "${S}/doc"
+ dodoc upmix.txt vdownmix.txt README-pcm-oss
+ use jack && dodoc README-jack
+ use libsamplerate && dodoc samplerate.txt
+ use pulseaudio && dodoc README-pulse
+ use ffmpeg && dodoc lavcrate.txt a52.txt
+}
diff --git a/media-plugins/alsa-plugins/files/ffmpeg-headers.patch b/media-plugins/alsa-plugins/files/ffmpeg-headers.patch
new file mode 100644
index 000000000000..86026d48d54c
--- /dev/null
+++ b/media-plugins/alsa-plugins/files/ffmpeg-headers.patch
@@ -0,0 +1,54 @@
+diff -ru alsa-plugins-1.0.17.orig/a52/pcm_a52.c alsa-plugins-1.0.17/a52/pcm_a52.c
+--- alsa-plugins-1.0.17.orig/a52/pcm_a52.c 2008-08-06 18:28:39.000000000 +0200
++++ alsa-plugins-1.0.17/a52/pcm_a52.c 2008-08-06 18:28:54.000000000 +0200
+@@ -18,6 +18,7 @@
+ * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ */
+
++#include "config.h"
+ #include <stdio.h>
+ #include <string.h>
+ #define __USE_XOPEN
+@@ -25,7 +26,11 @@
+ #include <alsa/asoundlib.h>
+ #include <alsa/pcm_external.h>
+ #include <alsa/pcm_plugin.h>
++#ifdef HAVE_FFMPEG_AVCODEC_H
+ #include <ffmpeg/avcodec.h>
++#elif defined(HAVE_LIBAVCODEC_AVCODEC_H)
++#include <libavcodec/avcodec.h>
++#endif
+
+ struct a52_ctx {
+ snd_pcm_ioplug_t io;
+diff -ru alsa-plugins-1.0.17.orig/configure.in alsa-plugins-1.0.17/configure.in
+--- alsa-plugins-1.0.17.orig/configure.in 2008-08-06 18:28:39.000000000 +0200
++++ alsa-plugins-1.0.17/configure.in 2008-08-06 18:31:00.000000000 +0200
+@@ -77,7 +77,7 @@
+ if test "x$enable_avcodec" != "xno"; then
+ AC_CHECK_LIB([avcodec], [avcodec_open], [HAVE_AVCODEC=yes], [HAVE_AVCODEC=no])
+ if test x$HAVE_AVCODEC = xyes; then
+- AC_CHECK_HEADER([ffmpeg/avcodec.h], [], [HAVE_AVCODEC=no])
++ AC_CHECK_HEADERS([ffmpeg/avcodec.h], , [AC_CHECK_HEADERS([libavcodec/avcodec.h], , [HAVE_AVCODEC=no])])
+ fi
+ fi
+ AM_CONDITIONAL(HAVE_AVCODEC, test x$HAVE_AVCODEC = xyes)
+diff -ru alsa-plugins-1.0.17.orig/rate-lavc/rate_lavcrate.c alsa-plugins-1.0.17/rate-lavc/rate_lavcrate.c
+--- alsa-plugins-1.0.17.orig/rate-lavc/rate_lavcrate.c 2008-08-06 18:28:39.000000000 +0200
++++ alsa-plugins-1.0.17/rate-lavc/rate_lavcrate.c 2008-08-06 18:28:54.000000000 +0200
+@@ -16,10 +16,15 @@
+ * Lesser General Public License for more details.
+ */
+
++#include "config.h"
+ #include <stdio.h>
+ #include <alsa/asoundlib.h>
+ #include <alsa/pcm_rate.h>
++#ifdef HAVE_FFMPEG_AVCODEC_H
+ #include <ffmpeg/avcodec.h>
++#elif defined(HAVE_LIBAVCODEC_AVCODEC_H)
++#include <libavcodec/avcodec.h>
++#endif
+ #include "gcd.h"
+
+ static int filter_size = 16;