summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Callen <abcd@gentoo.org>2010-01-16 01:44:16 +0000
committerJonathan Callen <abcd@gentoo.org>2010-01-16 01:44:16 +0000
commitfb1db047b0044edb28c9c03fddea60549d2a9822 (patch)
treeb227a8dd2fedbcdd31028e47059b5e2245d1a5e0 /media-plugins/audacious-plugins
parentAdd prefix keywords (diff)
downloadgentoo-2-fb1db047b0044edb28c9c03fddea60549d2a9822.tar.gz
gentoo-2-fb1db047b0044edb28c9c03fddea60549d2a9822.tar.bz2
gentoo-2-fb1db047b0044edb28c9c03fddea60549d2a9822.zip
Add prefix keywords
(Portage version: -svn/cvs/Linux i686)
Diffstat (limited to 'media-plugins/audacious-plugins')
-rw-r--r--media-plugins/audacious-plugins/ChangeLog6
-rw-r--r--media-plugins/audacious-plugins/audacious-plugins-2.2-r2.ebuild17
2 files changed, 13 insertions, 10 deletions
diff --git a/media-plugins/audacious-plugins/ChangeLog b/media-plugins/audacious-plugins/ChangeLog
index 76177584e4d6..834236b774f7 100644
--- a/media-plugins/audacious-plugins/ChangeLog
+++ b/media-plugins/audacious-plugins/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-plugins/audacious-plugins
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/audacious-plugins/ChangeLog,v 1.157 2010/01/04 23:20:48 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/audacious-plugins/ChangeLog,v 1.158 2010/01/16 01:44:16 abcd Exp $
+
+ 16 Jan 2010; Jonathan Callen <abcd@gentoo.org>
+ audacious-plugins-2.2-r2.ebuild:
+ Add prefix keywords
04 Jan 2010; <chainsaw@gentoo.org> audacious-plugins-2.2-r2.ebuild:
Add missing dependency on media-video/ffmpeg for USE="ffmpeg" as suggested
diff --git a/media-plugins/audacious-plugins/audacious-plugins-2.2-r2.ebuild b/media-plugins/audacious-plugins/audacious-plugins-2.2-r2.ebuild
index 465e46d0b625..b285e2e7d0ea 100644
--- a/media-plugins/audacious-plugins/audacious-plugins-2.2-r2.ebuild
+++ b/media-plugins/audacious-plugins/audacious-plugins-2.2-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/audacious-plugins/audacious-plugins-2.2-r2.ebuild,v 1.7 2010/01/04 23:20:48 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/audacious-plugins/audacious-plugins-2.2-r2.ebuild,v 1.8 2010/01/16 01:44:16 abcd Exp $
inherit eutils flag-o-matic
@@ -12,9 +12,9 @@ SRC_URI="http://distfiles.atheme.org/${MY_P}.tgz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha amd64 ~hppa ~ppc ~ppc64 ~sparc x86 ~x86-fbsd"
-IUSE="aac adplug alsa bs2b cdda cue esd ffmpeg flac fluidsynth gnome icecast ipv6 jack lame lirc
-midi mp3 mtp nls oss pulseaudio projectm scrobbler sdl sid sndfile sse2 vorbis wavpack"
+KEYWORDS="~alpha amd64 ~hppa ~ppc ~ppc64 ~sparc x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux"
+IUSE="aac adplug alsa aqua bs2b cdda cue esd ffmpeg flac fluidsynth gnome icecast ipv6 jack lame
+lirc midi mp3 mtp nls oss pulseaudio projectm scrobbler sdl sid sndfile sse2 vorbis wavpack"
RDEPEND="app-arch/unzip
>=dev-libs/dbus-glib-0.60
@@ -64,7 +64,7 @@ src_unpack() {
}
mp3_warning() {
- if ! useq mp3 ; then
+ if ! use mp3 ; then
ewarn "MP3 support is optional, you may want to enable the mp3 USE-flag"
fi
}
@@ -77,14 +77,14 @@ src_compile() {
--enable-dbus \
--enable-modplug \
--enable-neon \
- --disable-coreaudio \
- --disable-dockalbumart \
--disable-projectm \
$(use_enable adplug) \
$(use_enable aac) \
$(use_enable alsa) \
$(use_enable alsa bluetooth) \
$(use_enable alsa amidiplug-alsa) \
+ $(use_enable aqua coreaudio) \
+ $(use_enable aqua dockalbumart) \
$(use_enable bs2b) \
$(use_enable cdda cdaudio) \
$(use_enable cue) \
@@ -112,8 +112,7 @@ src_compile() {
$(use_enable sse2) \
$(use_enable vorbis) \
$(use_enable vorbis filewriter_vorbis) \
- $(use_enable wavpack) \
- || die
+ $(use_enable wavpack)
emake || die "make failed"
}