summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2008-01-27 13:38:31 +0000
committerChristoph Mende <angelos@gentoo.org>2008-01-27 13:38:31 +0000
commit7b9c1d639c31c0a5fab12c076adc97b6bef94056 (patch)
tree6e67bd82b7b4d6bac2b931e02974b438282eca89 /media-plugins/gmpc-magnatune/gmpc-magnatune-0.15.5.0.ebuild
parentReally take over maintainership (diff)
downloadgentoo-2-7b9c1d639c31c0a5fab12c076adc97b6bef94056.tar.gz
gentoo-2-7b9c1d639c31c0a5fab12c076adc97b6bef94056.tar.bz2
gentoo-2-7b9c1d639c31c0a5fab12c076adc97b6bef94056.zip
Taking over maintainership and version bump (Bug #202995 by Jesse Adelman)
(Portage version: 2.1.4)
Diffstat (limited to 'media-plugins/gmpc-magnatune/gmpc-magnatune-0.15.5.0.ebuild')
-rw-r--r--media-plugins/gmpc-magnatune/gmpc-magnatune-0.15.5.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/media-plugins/gmpc-magnatune/gmpc-magnatune-0.15.5.0.ebuild b/media-plugins/gmpc-magnatune/gmpc-magnatune-0.15.5.0.ebuild
new file mode 100644
index 000000000000..20985601a7e9
--- /dev/null
+++ b/media-plugins/gmpc-magnatune/gmpc-magnatune-0.15.5.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/gmpc-magnatune/gmpc-magnatune-0.15.5.0.ebuild,v 1.1 2008/01/27 13:38:30 angelos Exp $
+
+inherit eutils
+
+DESCRIPTION="This plugin allows you to browse and preview available albums on magnatune.com"
+HOMEPAGE="http://sarine.nl/gmpc-plugins-magnatune"
+SRC_URI="http://download.sarine.nl/gmpc-0.15.5/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=media-sound/gmpc-${PV}
+ dev-libs/libxml2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ if ! built_with_use =x11-libs/gtk+-2* jpeg ; then
+ echo
+ eerror "x11-libs/gtk+-2 needs to be built with \"jpeg\" USE flag"
+ die "x11-libs/gtk+-2 needs to be built with \"jpeg\" USE flag"
+ fi
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die
+}