summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-05-10 16:27:24 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-05-10 16:27:24 +0000
commita1032feeff410ac3b233acfd9a396d9a8b0c244f (patch)
treec1b4822369c833624e87ba7fdffc1624862f897f /media-plugins/gst-plugins-gl
parentpackage.use.mask dev-libs/udis86 test (diff)
downloadgentoo-2-a1032feeff410ac3b233acfd9a396d9a8b0c244f.tar.gz
gentoo-2-a1032feeff410ac3b233acfd9a396d9a8b0c244f.tar.bz2
gentoo-2-a1032feeff410ac3b233acfd9a396d9a8b0c244f.zip
Fix building with libpng14 wrt #319159 by Xavier Parizet.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'media-plugins/gst-plugins-gl')
-rw-r--r--media-plugins/gst-plugins-gl/ChangeLog8
-rw-r--r--media-plugins/gst-plugins-gl/files/gst-plugins-gl-0.10.1-libpng14.patch105
-rw-r--r--media-plugins/gst-plugins-gl/gst-plugins-gl-0.10.1.ebuild16
3 files changed, 123 insertions, 6 deletions
diff --git a/media-plugins/gst-plugins-gl/ChangeLog b/media-plugins/gst-plugins-gl/ChangeLog
index 65f4f16056bf..b71e4d7185ba 100644
--- a/media-plugins/gst-plugins-gl/ChangeLog
+++ b/media-plugins/gst-plugins-gl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-plugins/gst-plugins-gl
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/gst-plugins-gl/ChangeLog,v 1.1 2009/10/30 18:49:53 ssuominen Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/gst-plugins-gl/ChangeLog,v 1.2 2010/05/10 16:27:24 ssuominen Exp $
+
+ 10 May 2010; Samuli Suominen <ssuominen@gentoo.org>
+ gst-plugins-gl-0.10.1.ebuild, +files/gst-plugins-gl-0.10.1-libpng14.patch:
+ Fix building with libpng14 wrt #319159 by Xavier Parizet.
*gst-plugins-gl-0.10.1 (30 Oct 2009)
diff --git a/media-plugins/gst-plugins-gl/files/gst-plugins-gl-0.10.1-libpng14.patch b/media-plugins/gst-plugins-gl/files/gst-plugins-gl-0.10.1-libpng14.patch
new file mode 100644
index 000000000000..c753c91cdb95
--- /dev/null
+++ b/media-plugins/gst-plugins-gl/files/gst-plugins-gl-0.10.1-libpng14.patch
@@ -0,0 +1,105 @@
+diff -ur gst-plugins-gl-0.10.1.orig/gst/gl/gstglbumper.c gst-plugins-gl-0.10.1/gst/gl/gstglbumper.c
+--- gst-plugins-gl-0.10.1.orig/gst/gl/gstglbumper.c 2009-07-13 12:50:06.000000000 +0300
++++ gst-plugins-gl-0.10.1/gst/gl/gstglbumper.c 2010-05-10 19:27:25.000000000 +0300
+@@ -189,7 +189,7 @@
+ info_ptr = png_create_info_struct (png_ptr);
+ if (info_ptr == NULL) {
+ fclose (fp);
+- png_destroy_read_struct (&png_ptr, png_infopp_NULL, png_infopp_NULL);
++ png_destroy_read_struct (&png_ptr, NULL, NULL);
+ LOAD_ERROR ("failed to initialize the memory for image information");
+ }
+
+@@ -200,11 +200,11 @@
+ png_read_info (png_ptr, info_ptr);
+
+ png_get_IHDR (png_ptr, info_ptr, &width, &height, &bit_depth, &color_type,
+- &interlace_type, int_p_NULL, int_p_NULL);
++ &interlace_type, NULL, NULL);
+
+ if (color_type != PNG_COLOR_TYPE_RGB) {
+ fclose (fp);
+- png_destroy_read_struct (&png_ptr, png_infopp_NULL, png_infopp_NULL);
++ png_destroy_read_struct (&png_ptr, NULL, NULL);
+ LOAD_ERROR ("color type is not rgb");
+ }
+
+@@ -220,7 +220,7 @@
+ free (rows);
+
+ png_read_end (png_ptr, info_ptr);
+- png_destroy_read_struct (&png_ptr, &info_ptr, png_infopp_NULL);
++ png_destroy_read_struct (&png_ptr, &info_ptr, NULL);
+ fclose (fp);
+
+ /* END load png image file */
+diff -ur gst-plugins-gl-0.10.1.orig/gst/gl/gstgldifferencematte.c gst-plugins-gl-0.10.1/gst/gl/gstgldifferencematte.c
+--- gst-plugins-gl-0.10.1.orig/gst/gl/gstgldifferencematte.c 2009-07-13 12:50:06.000000000 +0300
++++ gst-plugins-gl-0.10.1/gst/gl/gstgldifferencematte.c 2010-05-10 19:27:25.000000000 +0300
+@@ -562,7 +562,7 @@
+ info_ptr = png_create_info_struct (png_ptr);
+ if (info_ptr == NULL) {
+ fclose (fp);
+- png_destroy_read_struct (&png_ptr, png_infopp_NULL, png_infopp_NULL);
++ png_destroy_read_struct (&png_ptr, NULL, NULL);
+ LOAD_ERROR ("failed to initialize the memory for image information");
+ }
+
+@@ -573,11 +573,11 @@
+ png_read_info (png_ptr, info_ptr);
+
+ png_get_IHDR (png_ptr, info_ptr, &width, &height, &bit_depth, &color_type,
+- &interlace_type, int_p_NULL, int_p_NULL);
++ &interlace_type, NULL, NULL);
+
+ if (color_type != PNG_COLOR_TYPE_RGB_ALPHA) {
+ fclose (fp);
+- png_destroy_read_struct (&png_ptr, png_infopp_NULL, png_infopp_NULL);
++ png_destroy_read_struct (&png_ptr, NULL, NULL);
+ LOAD_ERROR ("color type is not rgb");
+ }
+
+@@ -597,7 +597,7 @@
+ free (rows);
+
+ png_read_end (png_ptr, info_ptr);
+- png_destroy_read_struct (&png_ptr, &info_ptr, png_infopp_NULL);
++ png_destroy_read_struct (&png_ptr, &info_ptr, NULL);
+ fclose (fp);
+
+ return TRUE;
+diff -ur gst-plugins-gl-0.10.1.orig/gst/gl/gstgloverlay.c gst-plugins-gl-0.10.1/gst/gl/gstgloverlay.c
+--- gst-plugins-gl-0.10.1.orig/gst/gl/gstgloverlay.c 2009-07-13 12:50:06.000000000 +0300
++++ gst-plugins-gl-0.10.1/gst/gl/gstgloverlay.c 2010-05-10 19:27:25.000000000 +0300
+@@ -390,7 +390,7 @@
+ info_ptr = png_create_info_struct (png_ptr);
+ if (info_ptr == NULL) {
+ fclose (fp);
+- png_destroy_read_struct (&png_ptr, png_infopp_NULL, png_infopp_NULL);
++ png_destroy_read_struct (&png_ptr, NULL, NULL);
+ LOAD_ERROR ("failed to initialize the memory for image information");
+ }
+
+@@ -401,11 +401,11 @@
+ png_read_info (png_ptr, info_ptr);
+
+ png_get_IHDR (png_ptr, info_ptr, &width, &height, &bit_depth, &color_type,
+- &interlace_type, int_p_NULL, int_p_NULL);
++ &interlace_type, NULL, NULL);
+
+ if (color_type != PNG_COLOR_TYPE_RGB_ALPHA) {
+ fclose (fp);
+- png_destroy_read_struct (&png_ptr, png_infopp_NULL, png_infopp_NULL);
++ png_destroy_read_struct (&png_ptr, NULL, NULL);
+ LOAD_ERROR ("color type is not rgb");
+ }
+
+@@ -424,7 +424,7 @@
+ free (rows);
+
+ png_read_end (png_ptr, info_ptr);
+- png_destroy_read_struct (&png_ptr, &info_ptr, png_infopp_NULL);
++ png_destroy_read_struct (&png_ptr, &info_ptr, NULL);
+ fclose (fp);
+
+ return TRUE;
diff --git a/media-plugins/gst-plugins-gl/gst-plugins-gl-0.10.1.ebuild b/media-plugins/gst-plugins-gl/gst-plugins-gl-0.10.1.ebuild
index 6fff3a6938e0..a9ce0d54211a 100644
--- a/media-plugins/gst-plugins-gl/gst-plugins-gl-0.10.1.ebuild
+++ b/media-plugins/gst-plugins-gl/gst-plugins-gl-0.10.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/gst-plugins-gl/gst-plugins-gl-0.10.1.ebuild,v 1.1 2009/10/30 18:49:53 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/gst-plugins-gl/gst-plugins-gl-0.10.1.ebuild,v 1.2 2010/05/10 16:27:24 ssuominen Exp $
EAPI=2
-inherit multilib
+inherit eutils multilib
DESCRIPTION="GStreamer OpenGL plugins"
HOMEPAGE="http://gstreamer.freedesktop.org/"
@@ -17,13 +17,21 @@ IUSE="nls"
RDEPEND=">=dev-libs/liboil-0.3.8
media-libs/mesa
>=media-libs/glew-1.4
- media-libs/libpng
+ >=media-libs/libpng-1.2
>=media-libs/gstreamer-0.10.15.1
>=media-libs/gst-plugins-base-0.10.15.1"
DEPEND="${RDEPEND}
dev-util/pkgconfig
nls? ( sys-devel/gettext )"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-libpng14.patch
+ # avoid autoreconf for no good reason
+ sed -i \
+ -e 's:libpng12:libpng:' \
+ configure || die
+}
+
src_configure() {
econf \
--disable-static \