summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2005-05-20 09:07:07 +0000
committerDoug Goldstein <cardoe@gentoo.org>2005-05-20 09:07:07 +0000
commitf8fd115cb881422cd7659916111c2d331f56f69f (patch)
treece46e09a80da5bb0668808c20eb28bf84a8d3106 /media-plugins/mythmusic
parentrev bump; new eclass; clean ups (diff)
downloadgentoo-2-f8fd115cb881422cd7659916111c2d331f56f69f.tar.gz
gentoo-2-f8fd115cb881422cd7659916111c2d331f56f69f.tar.bz2
gentoo-2-f8fd115cb881422cd7659916111c2d331f56f69f.zip
a little src_compile cleanage
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'media-plugins/mythmusic')
-rw-r--r--media-plugins/mythmusic/mythmusic-0.18.1.ebuild10
1 files changed, 3 insertions, 7 deletions
diff --git a/media-plugins/mythmusic/mythmusic-0.18.1.ebuild b/media-plugins/mythmusic/mythmusic-0.18.1.ebuild
index b858bdc672a9..27bf0b042748 100644
--- a/media-plugins/mythmusic/mythmusic-0.18.1.ebuild
+++ b/media-plugins/mythmusic/mythmusic-0.18.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythmusic/mythmusic-0.18.1.ebuild,v 1.1 2005/05/20 02:31:35 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythmusic/mythmusic-0.18.1.ebuild,v 1.2 2005/05/20 09:07:07 cardoe Exp $
inherit mythtv-plugins flag-o-matic toolchain-funcs eutils
@@ -23,7 +23,7 @@ DEPEND=">=media-sound/cdparanoia-3.9.8
fftw? ( =sci-libs/fftw-2* )
opengl? ( virtual/opengl =sci-libs/fftw-2* )
sdl? ( >=media-libs/libsdl-1.2.5 )
- || ( ~media-tv/mythtv-${PV} )"
+ ~media-tv/mythtv-${PV}"
src_unpack() {
if [[ $(gcc-version) = "3.2" || $(gcc-version) == "3.3" ]]; then
@@ -33,8 +33,4 @@ src_unpack() {
mythtv-plugins_src_unpack || die "unpack failed"
}
-src_compile() {
- MTVCONF="$(use_enable aac) $(use_enable fftw) $(use_enable opengl) $(use_enable sdl)"
-
- mythtv-plugins_src_compile || die
-}
+MTVCONF="$(use_enable aac) $(use_enable fftw) $(use_enable opengl) $(use_enable sdl)"