summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2013-01-02 06:26:27 +0000
committerDoug Goldstein <cardoe@gentoo.org>2013-01-02 06:26:27 +0000
commit6927c398ffb78f1e0124272b3b5250c04365ce21 (patch)
tree674e12a4570983c4352cacc9e33ea8d99780b58b /media-plugins/mythplugins
parentRemove empty RDEPEND. (diff)
downloadgentoo-2-6927c398ffb78f1e0124272b3b5250c04365ce21.tar.gz
gentoo-2-6927c398ffb78f1e0124272b3b5250c04365ce21.tar.bz2
gentoo-2-6927c398ffb78f1e0124272b3b5250c04365ce21.zip
Version bump and additional upstream fixes.
(Portage version: 2.1.11.31/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'media-plugins/mythplugins')
-rw-r--r--media-plugins/mythplugins/ChangeLog10
-rw-r--r--media-plugins/mythplugins/mythplugins-0.25.3_p20130101.ebuild129
2 files changed, 137 insertions, 2 deletions
diff --git a/media-plugins/mythplugins/ChangeLog b/media-plugins/mythplugins/ChangeLog
index 86ec64e1fbb3..0ad4e7566107 100644
--- a/media-plugins/mythplugins/ChangeLog
+++ b/media-plugins/mythplugins/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-plugins/mythplugins
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythplugins/ChangeLog,v 1.5 2012/08/26 02:44:37 cardoe Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythplugins/ChangeLog,v 1.6 2013/01/02 06:26:27 cardoe Exp $
+
+*mythplugins-0.25.3_p20130101 (02 Jan 2013)
+
+ 02 Jan 2013; Doug Goldstein <cardoe@gentoo.org>
+ +mythplugins-0.25.3_p20130101.ebuild:
+ Version bump and additional upstream fixes.
*mythplugins-0.25.2_p20120825 (26 Aug 2012)
diff --git a/media-plugins/mythplugins/mythplugins-0.25.3_p20130101.ebuild b/media-plugins/mythplugins/mythplugins-0.25.3_p20130101.ebuild
new file mode 100644
index 000000000000..ae1fe1c13125
--- /dev/null
+++ b/media-plugins/mythplugins/mythplugins-0.25.3_p20130101.ebuild
@@ -0,0 +1,129 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythplugins/mythplugins-0.25.3_p20130101.ebuild,v 1.1 2013/01/02 06:26:27 cardoe Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2:2.6"
+BACKPORTS="ff8c4960"
+MY_P=${P%_p*}
+
+inherit eutils python
+
+DESCRIPTION="Official MythTV plugins"
+HOMEPAGE="http://www.mythtv.org"
+SRC_URI="ftp://ftp.osuosl.org/pub/mythtv/${MY_P}.tar.bz2
+ ${BACKPORTS:+http://dev.gentoo.org/~cardoe/distfiles/${MY_P}-${BACKPORTS}.tar.xz}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+MYTHPLUGINS="mytharchive mythbrowser mythgallery mythgame \
+mythmusic mythnetvision mythnews mythweather"
+
+IUSE="${MYTHPLUGINS} cdda cdr exif fftw raw"
+
+DEPEND="!media-plugins/mytharchive
+ !media-plugins/mythbrowser
+ !media-plugins/mythgallery
+ !media-plugins/mythgame
+ !media-plugins/mythmovies
+ !media-plugins/mythmusic
+ !media-plugins/mythnetvision
+ !media-plugins/mythnews
+ !media-plugins/mythweather
+ =media-tv/mythtv-${PV}*[python]
+ mytharchive? (
+ app-cdr/dvd+rw-tools
+ dev-python/imaging
+ media-video/dvdauthor
+ media-video/mjpegtools[png]
+ media-video/transcode
+ virtual/cdrtools
+ )
+ mythgallery? (
+ media-libs/tiff
+ virtual/opengl
+ exif? ( >media-libs/libexif-0.6.9 )
+ raw? ( media-gfx/dcraw )
+ )
+ mythmusic? (
+ >=media-libs/flac-1.1.2
+ >=media-libs/libvorbis-1.0
+ >=media-libs/taglib-1.6
+ media-sound/lame
+ virtual/opengl
+ cdda? (
+ dev-libs/libcdio
+ cdr? ( virtual/cdrtools )
+ )
+ fftw? ( sci-libs/fftw )
+ )
+ mythnetvision? (
+ =dev-lang/python-2*[xml]
+ dev-python/lxml
+ dev-python/mysql-python
+ dev-python/oauth
+ dev-python/pycurl
+ )
+ mythweather? (
+ dev-perl/DateManip
+ dev-perl/DateTime-Format-ISO8601
+ dev-perl/ImageSize
+ dev-perl/JSON
+ dev-perl/SOAP-Lite
+ dev-perl/XML-Simple
+ dev-perl/XML-Parser
+ dev-perl/XML-SAX
+ dev-perl/XML-XPath
+ )"
+RDEPEND="${DEPEND}"
+
+REQUIRED_USE="
+ cdda? ( mythmusic )
+ cdr? ( mythmusic cdda )
+ exif? ( mythgallery )
+ fftw? ( mythmusic )
+ mythnews? ( mythbrowser )
+ raw? ( mythgallery )"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ [[ -n ${BACKPORTS} ]] && \
+ EPATCH_FORCE=yes EPATCH_SUFFIX="patch" EPATCH_SOURCE="${S}/patches" \
+ epatch
+
+ epatch_user
+}
+
+src_configure() {
+ ./configure \
+ --prefix=/usr \
+ --python=python2 \
+ --enable-opengl \
+ --disable-mythzoneminder \
+ $(use_enable mytharchive) \
+ $(use_enable mythbrowser) \
+ $(use_enable mythgallery) \
+ $(use_enable mythgame) \
+ $(use_enable mythmusic) \
+ $(use_enable mythnetvision) \
+ $(use_enable mythnews) \
+ $(use_enable mythweather) \
+ $(use_enable cdda cdio) \
+ $(use_enable exif) \
+ $(use_enable exif new-exif) \
+ $(use_enable raw dcraw) \
+ || die "configure failed"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install || die "make install failed"
+}