summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Kalika <max@gentoo.org>2004-02-06 14:44:42 +0000
committerMax Kalika <max@gentoo.org>2004-02-06 14:44:42 +0000
commit6f8c6f6b60cd9465fca47db8517d38a93f8348ac (patch)
treea54c6a7aeb6754f3c50e11f68428a55cf1721b40 /media-plugins/mythvideo
parentDitch the postinst() message and don't attempt to install non-existant db fil... (diff)
downloadgentoo-2-6f8c6f6b60cd9465fca47db8517d38a93f8348ac.tar.gz
gentoo-2-6f8c6f6b60cd9465fca47db8517d38a93f8348ac.tar.bz2
gentoo-2-6f8c6f6b60cd9465fca47db8517d38a93f8348ac.zip
Ditch the postinst() message and don't attempt to install non-existant db files.
Diffstat (limited to 'media-plugins/mythvideo')
-rw-r--r--media-plugins/mythvideo/mythvideo-0.14.ebuild26
1 files changed, 2 insertions, 24 deletions
diff --git a/media-plugins/mythvideo/mythvideo-0.14.ebuild b/media-plugins/mythvideo/mythvideo-0.14.ebuild
index 26bfe5e79fa9..ae510d6162b7 100644
--- a/media-plugins/mythvideo/mythvideo-0.14.ebuild
+++ b/media-plugins/mythvideo/mythvideo-0.14.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythvideo/mythvideo-0.14.ebuild,v 1.1 2004/02/03 13:51:53 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythvideo/mythvideo-0.14.ebuild,v 1.2 2004/02/06 14:44:42 max Exp $
inherit flag-o-matic
@@ -17,7 +17,7 @@ DEPEND=">=sys-apps/sed-4
|| ( >=media-tv/mythtv-${PV} >=media-tv/mythfrontend-${PV} )"
src_unpack() {
- unpack ${A}
+ unpack ${A} && cd "${S}"
for i in `grep -lr "usr/local" "${S}"` ; do
sed -e "s:/usr/local:/usr:" -i "${i}" || die "sed failed"
@@ -36,27 +36,5 @@ src_compile() {
src_install () {
einstall INSTALL_ROOT="${D}"
-
- insinto "/usr/share/mythtv/database/${PN}"
- doins videodb/*.sql
-
dodoc COPYING README UPGRADING
- newdoc videodb/README README.db
-}
-
-pkg_postinst() {
- einfo "If this is the first time you install MythVideo,"
- einfo "you need to add /usr/share/mythtv/database/${PN}/metadata.sql"
- einfo "to your MythTV database."
- einfo
- einfo "You might run 'mysql < /usr/share/mythtv/database/${PN}/metadata.sql'"
- einfo
- einfo "If you're upgrading from an older version and for more"
- einfo "setup and usage instructions, please refer to:"
- einfo " /usr/share/doc/${PF}/README.gz"
- einfo " /usr/share/doc/${PF}/UPGRADING.gz"
- ewarn "This part is important as there might be database changes"
- ewarn "which need to be performed or this package will not work"
- ewarn "properly."
- echo
}