summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2004-02-03 13:51:53 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2004-02-03 13:51:53 +0000
commite4f208dd887e639fdac3f8a599c7c06cac41dde1 (patch)
tree59db30fcd642a5476b02fdfb3a3ff5fd7dc18f2f /media-plugins/mythweather/mythweather-0.14.ebuild
parentIntroduced CVS snapshot (diff)
downloadgentoo-2-e4f208dd887e639fdac3f8a599c7c06cac41dde1.tar.gz
gentoo-2-e4f208dd887e639fdac3f8a599c7c06cac41dde1.tar.bz2
gentoo-2-e4f208dd887e639fdac3f8a599c7c06cac41dde1.zip
Version bump
Diffstat (limited to 'media-plugins/mythweather/mythweather-0.14.ebuild')
-rw-r--r--media-plugins/mythweather/mythweather-0.14.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/media-plugins/mythweather/mythweather-0.14.ebuild b/media-plugins/mythweather/mythweather-0.14.ebuild
new file mode 100644
index 000000000000..b459052d4261
--- /dev/null
+++ b/media-plugins/mythweather/mythweather-0.14.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythweather/mythweather-0.14.ebuild,v 1.1 2004/02/03 13:51:53 aliz Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Weather forcast module for MythTV."
+HOMEPAGE="http://www.mythtv.org/"
+SRC_URI="http://www.mythtv.org/mc/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND=">=sys-apps/sed-4
+ || ( >=media-tv/mythtv-${PV} >=media-tv/mythfrontend-${PV} )"
+
+src_unpack() {
+ unpack ${A}
+
+ for i in `grep -lr "usr/local" "${S}"` ; do
+ sed -e "s:/usr/local:/usr:" -i "${i}" || die "sed failed"
+ done
+}
+
+src_compile() {
+ local cpu="`get-flag march || get-flag mcpu`"
+ if [ ! -z "${cpu}" ] ; then
+ sed -e "s:pentiumpro:${cpu}:g" -i "settings.pro" || die "sed failed"
+ fi
+
+ qmake -o "Makefile" "${PN}.pro"
+ emake || die "compile problem"
+}
+
+src_install() {
+ einstall INSTALL_ROOT="${D}"
+ dodoc AUTHORS COPYING README
+}