summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-03-28 23:45:53 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-03-28 23:45:53 +0000
commit3bb5b9c8c68b9af16d321f87d6b9a2787fca506f (patch)
treecac5c37d21b8c5792256c474690b987e050a0c8c /media-plugins/rmxmms
parentadded changelog (diff)
downloadgentoo-2-3bb5b9c8c68b9af16d321f87d6b9a2787fca506f.tar.gz
gentoo-2-3bb5b9c8c68b9af16d321f87d6b9a2787fca506f.tar.bz2
gentoo-2-3bb5b9c8c68b9af16d321f87d6b9a2787fca506f.zip
can't support for gcc3
Diffstat (limited to 'media-plugins/rmxmms')
-rw-r--r--media-plugins/rmxmms/ChangeLog5
-rw-r--r--media-plugins/rmxmms/rmxmms-0.5.1.ebuild22
2 files changed, 24 insertions, 3 deletions
diff --git a/media-plugins/rmxmms/ChangeLog b/media-plugins/rmxmms/ChangeLog
index 0bd764a16db4..53d6bb148bc3 100644
--- a/media-plugins/rmxmms/ChangeLog
+++ b/media-plugins/rmxmms/ChangeLog
@@ -1,11 +1,14 @@
# ChangeLog for media-plugins/rmxmms
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/rmxmms/ChangeLog,v 1.4 2003/02/12 07:19:13 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/rmxmms/ChangeLog,v 1.5 2003/03/28 23:45:53 liquidx Exp $
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
*rmxmms-0.5.1 (09 Jul 2002)
+ 28 Mar 2003; Alastair Tse <liquidx@gentoo.org> rmxmms-0.5.1.ebuild:
+ block merge if using gcc3. #18132.
+
27 Nov 2002; Seemant Kulleen <seemant@gentoo.org> * :
Moved to media-plugins
diff --git a/media-plugins/rmxmms/rmxmms-0.5.1.ebuild b/media-plugins/rmxmms/rmxmms-0.5.1.ebuild
index b437d31b5faa..ef32b53fe094 100644
--- a/media-plugins/rmxmms/rmxmms-0.5.1.ebuild
+++ b/media-plugins/rmxmms/rmxmms-0.5.1.ebuild
@@ -1,6 +1,10 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/rmxmms/rmxmms-0.5.1.ebuild,v 1.3 2003/02/13 12:58:43 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/rmxmms/rmxmms-0.5.1.ebuild,v 1.4 2003/03/28 23:45:53 liquidx Exp $
+
+IUSE=""
+
+inherit gcc
S=${WORKDIR}/rmxmms/${P}
DESCRIPTION="RealAudio plugin for xmms"
@@ -15,6 +19,15 @@ KEYWORDS="x86 -ppc -sparc "
DEPEND="media-sound/xmms
media-video/realplayer"
+pkg_setup() {
+ if [ `gcc-major-ver` = 3 ]; then
+ eerror "This plugin will not work when compiled with gcc-3.x"
+ eerror "Either install and select a gcc-2.95.x compiler with"
+ eerror "gcc-config, or give up."
+ die "Doesn't work with gcc-3.xx"
+ fi
+}
+
src_unpack () {
# Check if we got the SDK from real.com
@@ -41,8 +54,13 @@ src_unpack () {
}
src_compile () {
+ # patch Makefiles to use -lgcc
+ cd ${S}/rmxmms
+ sed -e 's/^LIBS =/LIBS = -lgcc/' Makefile.in > Makefile.in.new
+ sed -e 's/^LDFLAGS =/LDFLAGS = -lgcc/' Makefile.in.new > Makefile.in
+
+ cd ${S}
econf "--with-realsdk-dir=${WORKDIR}/realsdk/rmasdk_6_0" || die
-
emake || die
}