summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2008-12-17 14:15:34 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2008-12-17 14:15:34 +0000
commitf105822428ef4d09b7c052f25826766c3bca7f92 (patch)
treea2fcdf94339e6fd0f83b1b348425f5ef70dacc39 /media-plugins/vdr-amarok
parentRestrict tests as they die with JDKs higher than 1.4 (diff)
downloadgentoo-2-f105822428ef4d09b7c052f25826766c3bca7f92.tar.gz
gentoo-2-f105822428ef4d09b7c052f25826766c3bca7f92.tar.bz2
gentoo-2-f105822428ef4d09b7c052f25826766c3bca7f92.zip
Fix compilation with gcc-4.3. Bug #251185.
(Portage version: 2.1.6.1/cvs/Linux 2.6.27-gentoo-r1 i686)
Diffstat (limited to 'media-plugins/vdr-amarok')
-rw-r--r--media-plugins/vdr-amarok/ChangeLog8
-rw-r--r--media-plugins/vdr-amarok/files/vdr-amarok-0.0.2-gcc4.3.patch23
-rw-r--r--media-plugins/vdr-amarok/vdr-amarok-0.0.2.ebuild6
3 files changed, 33 insertions, 4 deletions
diff --git a/media-plugins/vdr-amarok/ChangeLog b/media-plugins/vdr-amarok/ChangeLog
index d3fad598552d..b1a416832c55 100644
--- a/media-plugins/vdr-amarok/ChangeLog
+++ b/media-plugins/vdr-amarok/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-plugins/vdr-amarok
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-amarok/ChangeLog,v 1.2 2007/12/19 14:06:37 hd_brummy Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-amarok/ChangeLog,v 1.3 2008/12/17 14:15:34 zzam Exp $
+
+ 17 Dec 2008; Matthias Schwarzott <zzam@gentoo.org>
+ +files/vdr-amarok-0.0.2-gcc4.3.patch, vdr-amarok-0.0.2.ebuild:
+ Fix compilation with gcc-4.3. Bug #251185.
19 Dec 2007; Joerg Bornkessel <hd_brummy@gentoo.org>
vdr-amarok-0.0.2.ebuild:
diff --git a/media-plugins/vdr-amarok/files/vdr-amarok-0.0.2-gcc4.3.patch b/media-plugins/vdr-amarok/files/vdr-amarok-0.0.2-gcc4.3.patch
new file mode 100644
index 000000000000..313453e24b54
--- /dev/null
+++ b/media-plugins/vdr-amarok/files/vdr-amarok-0.0.2-gcc4.3.patch
@@ -0,0 +1,23 @@
+diff -ru amarok-0.0.2-orig/menuAmarok.cpp amarok-0.0.2/menuAmarok.cpp
+--- amarok-0.0.2-orig/menuAmarok.cpp 2008-12-17 15:06:48.487227787 +0100
++++ amarok-0.0.2/menuAmarok.cpp 2008-12-17 15:07:39.700550051 +0100
+@@ -720,7 +720,7 @@
+
+
+ // unfortunately these playlists are not managed by the amarok DB in v1.4 or older
+-char *AMAROK_STATIC_PLAYLISTS []=
++const char *AMAROK_STATIC_PLAYLISTS []=
+ {
+ "50 Random Tracks",
+ "All Collection",
+diff -ru amarok-0.0.2-orig/Sockets.cpp amarok-0.0.2/Sockets.cpp
+--- amarok-0.0.2-orig/Sockets.cpp 2008-12-17 15:06:48.487227787 +0100
++++ amarok-0.0.2/Sockets.cpp 2008-12-17 15:07:20.357219764 +0100
+@@ -20,6 +20,7 @@
+ #ifndef WIN32
+ // this is for Linux
+ #include <unistd.h>
++#include <string.h>
+ #include <sys/types.h>
+ #include <sys/socket.h>
+ #include <netinet/in.h>
diff --git a/media-plugins/vdr-amarok/vdr-amarok-0.0.2.ebuild b/media-plugins/vdr-amarok/vdr-amarok-0.0.2.ebuild
index 949e4af52ea9..bd9779777a1c 100644
--- a/media-plugins/vdr-amarok/vdr-amarok-0.0.2.ebuild
+++ b/media-plugins/vdr-amarok/vdr-amarok-0.0.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-amarok/vdr-amarok-0.0.2.ebuild,v 1.3 2007/12/19 14:06:37 hd_brummy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-amarok/vdr-amarok-0.0.2.ebuild,v 1.4 2008/12/17 14:15:34 zzam Exp $
inherit vdr-plugin
@@ -15,6 +15,8 @@ IUSE=""
DEPEND=">=media-video/vdr-1.4.0"
+PATCHES=("${FILESDIR}/${P}-gcc4.3.patch")
+
pkg_postinst() {
vdr-plugin_pkg_postinst