summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJörg Bornkessel <hd_brummy@gentoo.org>2010-12-28 18:44:25 +0000
committerJörg Bornkessel <hd_brummy@gentoo.org>2010-12-28 18:44:25 +0000
commitfb1c2cda48417664868b8daab85a1bf4510724a5 (patch)
tree654b84c940a5973186fa2467b033d991f8d5da6b /media-plugins/vdr-audiorecorder
parentRaise cairo dependencies to 1.10.0, bug 349917. (diff)
downloadgentoo-2-fb1c2cda48417664868b8daab85a1bf4510724a5.tar.gz
gentoo-2-fb1c2cda48417664868b8daab85a1bf4510724a5.tar.bz2
gentoo-2-fb1c2cda48417664868b8daab85a1bf4510724a5.zip
use shared tinyxml lib now, see bug #349507; some minor fixes in source code
(Portage version: 2.1.9.24/cvs/Linux i686)
Diffstat (limited to 'media-plugins/vdr-audiorecorder')
-rw-r--r--media-plugins/vdr-audiorecorder/ChangeLog11
-rw-r--r--media-plugins/vdr-audiorecorder/files/rc-addon.sh3
-rw-r--r--media-plugins/vdr-audiorecorder/files/vdr-audiorecorder-0.1.0_pre14-shared-tinyxml.diff132
-rw-r--r--media-plugins/vdr-audiorecorder/vdr-audiorecorder-0.1.0_pre14-r1.ebuild48
4 files changed, 192 insertions, 2 deletions
diff --git a/media-plugins/vdr-audiorecorder/ChangeLog b/media-plugins/vdr-audiorecorder/ChangeLog
index 01c00ec4a255..0974f915e8ef 100644
--- a/media-plugins/vdr-audiorecorder/ChangeLog
+++ b/media-plugins/vdr-audiorecorder/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for media-plugins/vdr-audiorecorder
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-audiorecorder/ChangeLog,v 1.12 2010/12/23 16:28:15 hd_brummy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-audiorecorder/ChangeLog,v 1.13 2010/12/28 18:44:25 hd_brummy Exp $
+
+*vdr-audiorecorder-0.1.0_pre14-r1 (28 Dec 2010)
+
+ 28 Dec 2010; Joerg Bornkessel <hd_brummy@gentoo.org>
+ +vdr-audiorecorder-0.1.0_pre14-r1.ebuild,
+ +files/vdr-audiorecorder-0.1.0_pre14-shared-tinyxml.diff,
+ files/rc-addon.sh:
+ use shared tinyxml lib now, see bug #349507; some minor fixes in source
+ code
*vdr-audiorecorder-0.1.0_pre14 (23 Dec 2010)
diff --git a/media-plugins/vdr-audiorecorder/files/rc-addon.sh b/media-plugins/vdr-audiorecorder/files/rc-addon.sh
index 8a6946c857a4..e431363a931e 100644
--- a/media-plugins/vdr-audiorecorder/files/rc-addon.sh
+++ b/media-plugins/vdr-audiorecorder/files/rc-addon.sh
@@ -1,4 +1,4 @@
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-audiorecorder/files/rc-addon.sh,v 1.1 2006/07/05 16:57:35 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-audiorecorder/files/rc-addon.sh,v 1.2 2010/12/28 18:44:25 hd_brummy Exp $
#
# rc-addon-script for plugin audiorecorder
#
@@ -8,5 +8,6 @@
plugin_pre_vdr_start() {
add_plugin_param "--recdir=${AUDIORECORDER_DIR}"
+ add_plugin_param "--debug=0"
}
diff --git a/media-plugins/vdr-audiorecorder/files/vdr-audiorecorder-0.1.0_pre14-shared-tinyxml.diff b/media-plugins/vdr-audiorecorder/files/vdr-audiorecorder-0.1.0_pre14-shared-tinyxml.diff
new file mode 100644
index 000000000000..d664a35d0add
--- /dev/null
+++ b/media-plugins/vdr-audiorecorder/files/vdr-audiorecorder-0.1.0_pre14-shared-tinyxml.diff
@@ -0,0 +1,132 @@
+unbundle source included tinyxml, use now shared libs from dev-libs/tinyxml
+bugs.gentoo.org #349507
+Joerg bornkessel <hd_brummy@g.o> 2010 Dec 28
+
+diff -Naur audiorecorder-0.1.0-pre14.orig/Makefile audiorecorder-0.1.0-pre14/Makefile
+--- audiorecorder-0.1.0-pre14.orig/Makefile 2010-12-28 16:10:30.000000000 +0100
++++ audiorecorder-0.1.0-pre14/Makefile 2010-12-28 16:25:52.000000000 +0100
+@@ -46,6 +46,8 @@
+
+ LIBS = $(shell taglib-config --libs)
+
++LIBS += -ltinyxml
++
+ DEFINES += -D_GNU_SOURCE -DPLUGIN_NAME_I18N='"$(PLUGIN)"' -DTIXML_USE_STL
+
+ ifdef AUDIORECORDER_DEVEL
+@@ -68,7 +70,7 @@
+
+ ### The object files (add further files here):
+
+-OBJS = $(PLUGIN).o mainmenu.o browse.o browse-item.o column.o dispatcher.o audioreceiver.o postdata.o trackinfo.o postproc.o rds.o convert.o cache.o xml-cache.o xml-base.o setup.o mpa-frame.o tinyxml/tinyxml.o tinyxml/tinyxmlerror.o tinyxml/tinyxmlparser.o audiorecorder_i18n.o
++OBJS = $(PLUGIN).o mainmenu.o browse.o browse-item.o column.o dispatcher.o audioreceiver.o postdata.o trackinfo.o postproc.o rds.o convert.o cache.o xml-cache.o xml-base.o setup.o mpa-frame.o audiorecorder_i18n.o
+
+ ### Implicit rules:
+
+diff -Naur audiorecorder-0.1.0-pre14.orig/xml-base.c audiorecorder-0.1.0-pre14/xml-base.c
+--- audiorecorder-0.1.0-pre14.orig/xml-base.c 2010-12-28 16:10:30.000000000 +0100
++++ audiorecorder-0.1.0-pre14/xml-base.c 2010-12-28 16:38:29.000000000 +0100
+@@ -10,7 +10,7 @@
+
+
+ using namespace std;
+-using namespace a_land;
++/*using namespace a_land; */
+
+ /* --- cXmlBase ------------------------------------------------------------- */
+
+diff -Naur audiorecorder-0.1.0-pre14.orig/xml-base.h audiorecorder-0.1.0-pre14/xml-base.h
+--- audiorecorder-0.1.0-pre14.orig/xml-base.h 2010-12-28 16:10:30.000000000 +0100
++++ audiorecorder-0.1.0-pre14/xml-base.h 2010-12-28 16:39:35.000000000 +0100
+@@ -5,7 +5,7 @@
+ #ifndef __XML_BASE_H
+ #define __XML_BASE_H
+
+-#include "tinyxml/tinyxml.h"
++#include <tinyxml.h>
+
+ #include <string>
+
+@@ -13,8 +14,8 @@
+ private:
+ std::string path, root_element;
+
+- a_land::TiXmlDocument *document;
+- a_land::TiXmlElement *root;
++ TiXmlDocument *document;
++ TiXmlElement *root;
+ protected:
+ virtual ~cXmlBase();
+
+@@ -25,11 +26,11 @@
+ bool load(const std::string &_path);
+ void clear(void);
+
+- void add_subelement(a_land::TiXmlElement &main_element,
++ void add_subelement(TiXmlElement &main_element,
+ const char *name, const std::string &text);
+
+- a_land::TiXmlDocument *get_document(void) { return document; }
+- a_land::TiXmlElement *get_root(void) { return root; }
++ TiXmlDocument *get_document(void) { return document; }
++ TiXmlElement *get_root(void) { return root; }
+ void set_root(void);
+ };
+
+diff -Naur audiorecorder-0.1.0-pre14.orig/xml-cache.c audiorecorder-0.1.0-pre14/xml-cache.c
+--- audiorecorder-0.1.0-pre14.orig/xml-cache.c 2010-12-28 16:10:30.000000000 +0100
++++ audiorecorder-0.1.0-pre14/xml-cache.c 2010-12-28 16:41:27.000000000 +0100
+@@ -19,7 +19,7 @@
+
+
+ using namespace std;
+-using namespace a_land;
++/*using namespace a_land; */
+
+ /* --- cXmlCache ------------------------------------------------------------ */
+
+@@ -111,7 +111,7 @@
+ trackinfo.get_title().empty())
+ return;
+
+- a_land::TiXmlElement track("track");
++ TiXmlElement track("track");
+ track.SetAttribute("path", trackinfo.get_partial_path());
+ track.SetAttribute("date", trackinfo.get_date());
+ track.SetAttribute("time", trackinfo.get_time());
+@@ -146,7 +146,7 @@
+
+ void cXmlCache::copy_to_objects(void)
+ {
+- a_land::TiXmlElement *xml_track = get_root()->FirstChildElement("track");
++ TiXmlElement *xml_track = get_root()->FirstChildElement("track");
+
+ while (xml_track) {
+ cTrackInfo trackinfo;
+@@ -155,7 +155,7 @@
+
+ if (path.empty()) {
+ /* remove deleted files from the xml-cache */
+- a_land::TiXmlElement *tmp = xml_track;
++ TiXmlElement *tmp = xml_track;
+ xml_track = xml_track->NextSiblingElement("track");
+ get_root()->RemoveChild(tmp);
+
+@@ -169,7 +169,7 @@
+ if (access(path.c_str(), F_OK) == -1) {
+ dsyslog("[audiorecorder]: copy %s : (%s, %s())", path.c_str(), __FILE__, __func__);
+ /* remove deleted files from the xml-cache */
+- a_land::TiXmlElement *tmp = xml_track;
++ TiXmlElement *tmp = xml_track;
+ xml_track = xml_track->NextSiblingElement("track");
+ get_root()->RemoveChild(tmp);
+
+@@ -181,7 +181,7 @@
+ if (xml_track->Attribute("time"))
+ trackinfo.set_time(xml_track->Attribute("time"));
+
+- for (a_land::TiXmlElement *element = xml_track->FirstChildElement();
++ for (TiXmlElement *element = xml_track->FirstChildElement();
+ element; element = element->NextSiblingElement()) {
+ if (element->FirstChild() == NULL)
+ continue;
diff --git a/media-plugins/vdr-audiorecorder/vdr-audiorecorder-0.1.0_pre14-r1.ebuild b/media-plugins/vdr-audiorecorder/vdr-audiorecorder-0.1.0_pre14-r1.ebuild
new file mode 100644
index 000000000000..01e1e82414f9
--- /dev/null
+++ b/media-plugins/vdr-audiorecorder/vdr-audiorecorder-0.1.0_pre14-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-audiorecorder/vdr-audiorecorder-0.1.0_pre14-r1.ebuild,v 1.1 2010/12/28 18:44:25 hd_brummy Exp $
+
+EAPI="2"
+
+inherit vdr-plugin flag-o-matic
+
+MY_P=${P/_pre/-pre}
+
+DESCRIPTION="VDR plugin: automatically record radio-channels and split it into tracks according to RadioText-Info"
+HOMEPAGE="http://www.a-land.de/audiorecorder/"
+SRC_URI="http://www.zulu-entertainment.de/files/${PN}/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+S=${WORKDIR}/${MY_P#vdr-}
+
+DEPEND=">=media-video/vdr-1.6.0
+ media-libs/taglib
+ >=media-video/ffmpeg-0.6[mp3]
+ >=dev-libs/tinyxml-2.6.1[stl]"
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ vdr-plugin_src_prepare
+
+ epatch "${FILESDIR}/${P}-shared-tinyxml.diff"
+
+ sed -i "s:include <avcodec.h>:include <libavcodec/avcodec.h>:" convert.h audiorecorder.c
+ sed -i "s:RegisterI18n:// RegisterI18n:" audiorecorder.c
+
+ # UINT64_C is needed by ffmpeg headers
+ append-flags -D__STDC_CONSTANT_MACROS
+}
+
+src_install() {
+ vdr-plugin_src_install
+ keepdir /var/vdr/audiorecorder
+ chown -R vdr:vdr "${D}"/var/vdr
+
+ insinto /etc/vdr/plugins/audiorecorder
+ doins "${S}"/contrib/audiorecorder.conf
+}