summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJörg Bornkessel <hd_brummy@gentoo.org>2009-02-23 23:50:41 +0000
committerJörg Bornkessel <hd_brummy@gentoo.org>2009-02-23 23:50:41 +0000
commit27b1d5aa35aeb4d0844a220f1494bda55d356982 (patch)
tree0a48af86d88ff71bf3c4753106f577c90facbac3 /media-plugins/vdr-xxvautotimer
parentmake eclass ready for eapi2 (diff)
downloadgentoo-2-27b1d5aa35aeb4d0844a220f1494bda55d356982.tar.gz
gentoo-2-27b1d5aa35aeb4d0844a220f1494bda55d356982.tar.bz2
gentoo-2-27b1d5aa35aeb4d0844a220f1494bda55d356982.zip
fixed gettext support, fixed compile for distcc, multicore support
(Portage version: 2.1.6.7/cvs/Linux i686)
Diffstat (limited to 'media-plugins/vdr-xxvautotimer')
-rw-r--r--media-plugins/vdr-xxvautotimer/ChangeLog9
-rw-r--r--media-plugins/vdr-xxvautotimer/files/vdr-1.5.7-gettext.diff466
-rw-r--r--media-plugins/vdr-xxvautotimer/files/vdr-xxvautotimer-0.1.2-makefile-fix.diff14
-rw-r--r--media-plugins/vdr-xxvautotimer/vdr-xxvautotimer-0.1.2-r1.ebuild29
4 files changed, 517 insertions, 1 deletions
diff --git a/media-plugins/vdr-xxvautotimer/ChangeLog b/media-plugins/vdr-xxvautotimer/ChangeLog
index f8a195bbf174..569f0a8ab490 100644
--- a/media-plugins/vdr-xxvautotimer/ChangeLog
+++ b/media-plugins/vdr-xxvautotimer/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-plugins/vdr-xxvautotimer
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-xxvautotimer/ChangeLog,v 1.2 2009/01/24 13:35:38 hd_brummy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-xxvautotimer/ChangeLog,v 1.3 2009/02/23 23:50:41 hd_brummy Exp $
+
+*vdr-xxvautotimer-0.1.2-r1 (23 Feb 2009)
+
+ 23 Feb 2009; Joerg Bornkessel <hd_brummy@gentoo.org>
+ +files/vdr-xxvautotimer-0.1.2-makefile-fix.diff,
+ +files/vdr-1.5.7-gettext.diff, +vdr-xxvautotimer-0.1.2-r1.ebuild:
+ fixed gettext support, fixed compile for distcc, multicore support
24 Jan 2009; Joerg Bornkessel <hd_brummy@gentoo.org>
+files/vdr-xxvautotimer-0.1.2_compile-warn.diff,
diff --git a/media-plugins/vdr-xxvautotimer/files/vdr-1.5.7-gettext.diff b/media-plugins/vdr-xxvautotimer/files/vdr-1.5.7-gettext.diff
new file mode 100644
index 000000000000..c0901c025c7e
--- /dev/null
+++ b/media-plugins/vdr-xxvautotimer/files/vdr-1.5.7-gettext.diff
@@ -0,0 +1,466 @@
+diff -Naur xxvautotimer-0.1.2.orig/i18n.cpp xxvautotimer-0.1.2/i18n.cpp
+--- xxvautotimer-0.1.2.orig/i18n.cpp 2009-02-24 00:27:40.274639619 +0100
++++ xxvautotimer-0.1.2/i18n.cpp 2009-02-24 00:27:47.561300115 +0100
+@@ -8,6 +8,7 @@
+ *
+ * Copyright (C) 2005 by Ralf Dotzert
+ ****************************************************************************/
++#if APIVERSNUM < 10507
+ #include "i18n.h"
+
+ const tI18nPhrase Phrases[] = {
+@@ -1237,3 +1238,4 @@
+
+ { NULL }
+ };
++#endif
+diff -Naur xxvautotimer-0.1.2.orig/Makefile xxvautotimer-0.1.2/Makefile
+--- xxvautotimer-0.1.2.orig/Makefile 2009-02-24 00:27:40.274639619 +0100
++++ xxvautotimer-0.1.2/Makefile 2009-02-24 00:31:08.828339549 +0100
+@@ -74,9 +74,34 @@
+
+ -include $(DEPFILE)
+
++### Internationalization (I18N):
++
++PODIR = po
++LOCALEDIR = $(VDRDIR)/locale
++I18Npo = $(wildcard $(PODIR)/*.po)
++I18Nmsgs = $(addprefix $(LOCALEDIR)/, $(addsuffix /LC_MESSAGES/vdr-$(PLUGIN).mo, $(notdir $(foreach file, $(I18Npo), $(basename $(file))))))
++I18Npot = $(PODIR)/$(PLUGIN).pot
++
++%.mo: %.po
++ msgfmt -c -o $@ $<
++
++$(I18Npot): $(wildcard *.c)
++ xgettext -C -cTRANSLATORS --no-wrap --no-location -k -ktr -ktrNOOP --msgid-bugs-address='<automatically created from i18n.cpp by vdr-plugin.eclass <vdr@gentoo.org>>' -o $@ $^
++
++%.po: $(I18Npot)
++ msgmerge -U --no-wrap --no-location --backup=none -q $@ $<
++ @touch $@
++
++$(I18Nmsgs): $(LOCALEDIR)/%/LC_MESSAGES/vdr-$(PLUGIN).mo: $(PODIR)/%.mo
++ @mkdir -p $(dir $@)
++ cp $< $@
++
++.PHONY: i18n
++i18n: $(I18Nmsgs)
++
+ ### Targets:
+
+-all: $(MYSQLWRAPPERDIR)/$(MYSQLWRAPPERLIB) libvdr-$(PLUGIN).so
++all: $(MYSQLWRAPPERDIR)/$(MYSQLWRAPPERLIB) libvdr-$(PLUGIN).so i18n
+
+
+ $(MYSQLWRAPPERDIR)/$(MYSQLWRAPPERLIB):
+@@ -104,5 +129,6 @@
+ @echo Distribution package created as $(PACKAGE).tgz
+
+ clean:
+- @ cd $(MYSQLWRAPPERDIR);make clean
+- @rm -f $(OBJS) $(DEPFILE) *.so *.tgz core* *~
++ @-rm -f $(PODIR)/*.mo $(PODIR)/*.pot
++ @ cd $(MYSQLWRAPPERDIR);make clean @rm -f $(OBJS) $(DEPFILE) *.so
++ *.tgz core* *~
+diff -Naur xxvautotimer-0.1.2.orig/po/de_DE.po xxvautotimer-0.1.2/po/de_DE.po
+--- xxvautotimer-0.1.2.orig/po/de_DE.po 1970-01-01 01:00:00.000000000 +0100
++++ xxvautotimer-0.1.2/po/de_DE.po 2009-02-24 00:32:02.260203445 +0100
+@@ -0,0 +1,196 @@
++# VDR plugin language source file.
++# Copyright (C) 2007 Klaus Schmidinger <kls@cadsoft.de>
++# This file is distributed under the same license as the VDR package.
++# Klaus Schmidinger <kls@cadsoft.de>, 2000
++#
++msgid ""
++msgstr ""
++"Project-Id-Version: VDR 1.5.7\n"
++"Report-Msgid-Bugs-To: automatically created from i18n.cpp by vdr-plugin.eclass <vdr@gentoo.org>\n"
++"POT-Creation-Date: 2009-02-23 19:55+0100\n"
++"PO-Revision-Date: 2009-02-23 19:55+0100\n"
++"Last-Translator: Klaus Schmidinger <kls@cadsoft.de>\n"
++"Language-Team: <vdr@linuxtv.org>\n"
++"MIME-Version: 1.0\n"
++"Content-Type: text/plain; charset=ISO-8859-15\n"
++"Content-Transfer-Encoding: 8bit\n"
++
++msgid "Autotimer for XXV"
++msgstr "XXV Autotimer editieren"
++
++msgid "Could not connect to Mysql Database"
++msgstr "Keine Verbindung zur Mysql Datenbank"
++
++msgid "Commands"
++msgstr "Kommando"
++
++msgid "Delete"
++msgstr "Löschen"
++
++msgid "New"
++msgstr "Neu"
++
++msgid "On/Off"
++msgstr "Ein/Aus"
++
++msgid "Delete autotimer?"
++msgstr "Autotimer entfernen?"
++
++msgid "Update of Database failed!"
++msgstr "Fehler beim Update der Datenbank!"
++
++msgid "Can not Insert Record!"
++msgstr "Fehler beim Einfügen des Datensatzes!"
++
++msgid "Can not Delete Record!"
++msgstr "Fehler beim löschen des Datensatzes!"
++
++msgid "Edit XXV Autotimers"
++msgstr "XXV Autotimer editieren"
++
++msgid "Active"
++msgstr "Aktiv"
++
++msgid "no"
++msgstr "Nein"
++
++msgid "yes"
++msgstr "Ja"
++
++msgid "Searchstring"
++msgstr "Suchstring"
++
++msgid "Search in title"
++msgstr "Suche in Titel"
++
++msgid "Search in subtitle"
++msgstr "Suche in Untertitel"
++
++msgid "Search in descritption"
++msgstr "Suche in Beschreibung"
++
++msgid "Ignore recurrences"
++msgstr "Ignoriere Wiederholungen"
++
++msgid "Use start time"
++msgstr "Nutze Startzeit"
++
++msgid " Start time of search"
++msgstr " Startzeit der Suche"
++
++msgid "Use stop time"
++msgstr "Nutze Endzeit"
++
++msgid " End time of search"
++msgstr " Endzeit der Suche"
++
++msgid "Use channel select"
++msgstr "Senderwahl benutzen"
++
++msgid "Nr of channels"
++msgstr "Anzahl der Kanäle"
++
++msgid " Channel"
++msgstr " Kanal"
++
++msgid "Directory for recording"
++msgstr "Verzeichnis für Aufnahme"
++
++msgid "Minimum length"
++msgstr "Mindest Spielzeit"
++
++msgid "Priority"
++msgstr "Priorität"
++
++msgid "Lifetime"
++msgstr "Lebensdauer"
++
++msgid "Use VPS"
++msgstr "Benutze VPS"
++
++msgid "Weekdays"
++msgstr "Wochentage"
++
++msgid " Monday"
++msgstr " Montag"
++
++msgid " Tuesday"
++msgstr " Dienstag"
++
++msgid " Wednesday"
++msgstr " Mittwoch"
++
++msgid " Thursday"
++msgstr " Donnerstag"
++
++msgid " Friday"
++msgstr " Freitag"
++
++msgid " Saturday"
++msgstr " Samstag"
++
++msgid " Sunday"
++msgstr " Sonntag"
++
++msgid "Default Recording at start"
++msgstr "Standard-Zeitpuffer am Anfang"
++
++msgid " Recording at start (min)"
++msgstr " Zeitpuffer am Anfang (min)"
++
++msgid "Default Recording at stop"
++msgstr "Standard-Zeitpuffer am Ende"
++
++msgid " Recording at stop (min)"
++msgstr " Zeitpuffer am Ende (min)"
++
++msgid "Missing search text!"
++msgstr "Suchtext fehlt!"
++
++msgid "Search text to small - use anyway?"
++msgstr "Suchtext zu kurz - trotzdem suchen?"
++
++msgid "XXV Commands"
++msgstr "XXV Komandos"
++
++msgid "Please Wait ..."
++msgstr "Bitte Warten"
++
++msgid "Error can not send XXV Command"
++msgstr "Fehler, konnte Kommando nicht senden"
++
++msgid "XXVD Configuration is used:"
++msgstr "Nutze XXV Konfiguration:"
++
++msgid "create timers"
++msgstr "Erstelle Timer"
++
++msgid "read EPG data"
++msgstr "Lese EPG Daten"
++
++msgid "read channels"
++msgstr "Lese Kanäle"
++
++msgid "Database"
++msgstr "Datenbank"
++
++msgid "Database-Port"
++msgstr "Datenbank-Port"
++
++msgid "Database-User"
++msgstr "Datenbank-User"
++
++msgid "Database-Password"
++msgstr "Datenbank-Passwort"
++
++msgid "Default-Lifetime"
++msgstr "Lebenszeit"
++
++msgid "Default-Priority"
++msgstr "Priortät"
++
++msgid "Default-prevminutes"
++msgstr "Pufferzeit vor Aufnahmen"
++
++msgid "Default-afterminutes"
++msgstr "Pufferzeit nach Aufnahmen"
+diff -Naur xxvautotimer-0.1.2.orig/po/xxvautotimer.pot xxvautotimer-0.1.2/po/xxvautotimer.pot
+--- xxvautotimer-0.1.2.orig/po/xxvautotimer.pot 1970-01-01 01:00:00.000000000 +0100
++++ xxvautotimer-0.1.2/po/xxvautotimer.pot 2009-02-24 00:32:22.971284148 +0100
+@@ -0,0 +1,198 @@
++# SOME DESCRIPTIVE TITLE.
++# Copyright (C) YEAR THE PACKAGE'S COPYRIGHT HOLDER
++# This file is distributed under the same license as the PACKAGE package.
++# FIRST AUTHOR <EMAIL@ADDRESS>, YEAR.
++#
++#, fuzzy
++msgid ""
++msgstr ""
++"Project-Id-Version: PACKAGE VERSION\n"
++"Report-Msgid-Bugs-To: automatically created from i18n.cpp by vdr-plugin.eclass <vdr@gentoo.org>\n"
++"POT-Creation-Date: 2009-02-23 19:55+0100\n"
++"PO-Revision-Date: YEAR-MO-DA HO:MI+ZONE\n"
++"Last-Translator: FULL NAME <EMAIL@ADDRESS>\n"
++"Language-Team: LANGUAGE <LL@li.org>\n"
++"MIME-Version: 1.0\n"
++"Content-Type: text/plain; charset=CHARSET\n"
++"Content-Transfer-Encoding: 8bit\n"
++
++msgid "Autotimer for XXV"
++msgstr ""
++
++msgid "Could not connect to Mysql Database"
++msgstr ""
++
++msgid "Commands"
++msgstr ""
++
++msgid "Delete"
++msgstr ""
++
++msgid "New"
++msgstr ""
++
++msgid "On/Off"
++msgstr ""
++
++msgid "Delete autotimer?"
++msgstr ""
++
++msgid "Update of Database failed!"
++msgstr ""
++
++msgid "Can not Insert Record!"
++msgstr ""
++
++msgid "Can not Delete Record!"
++msgstr ""
++
++msgid "Edit XXV Autotimers"
++msgstr ""
++
++msgid "Active"
++msgstr ""
++
++msgid "no"
++msgstr ""
++
++msgid "yes"
++msgstr ""
++
++msgid "Searchstring"
++msgstr ""
++
++msgid "Search in title"
++msgstr ""
++
++msgid "Search in subtitle"
++msgstr ""
++
++msgid "Search in descritption"
++msgstr ""
++
++msgid "Ignore recurrences"
++msgstr ""
++
++msgid "Use start time"
++msgstr ""
++
++msgid " Start time of search"
++msgstr ""
++
++msgid "Use stop time"
++msgstr ""
++
++msgid " End time of search"
++msgstr ""
++
++msgid "Use channel select"
++msgstr ""
++
++msgid "Nr of channels"
++msgstr ""
++
++msgid " Channel"
++msgstr ""
++
++msgid "Directory for recording"
++msgstr ""
++
++msgid "Minimum length"
++msgstr ""
++
++msgid "Priority"
++msgstr ""
++
++msgid "Lifetime"
++msgstr ""
++
++msgid "Use VPS"
++msgstr ""
++
++msgid "Weekdays"
++msgstr ""
++
++msgid " Monday"
++msgstr ""
++
++msgid " Tuesday"
++msgstr ""
++
++msgid " Wednesday"
++msgstr ""
++
++msgid " Thursday"
++msgstr ""
++
++msgid " Friday"
++msgstr ""
++
++msgid " Saturday"
++msgstr ""
++
++msgid " Sunday"
++msgstr ""
++
++msgid "Default Recording at start"
++msgstr ""
++
++msgid " Recording at start (min)"
++msgstr ""
++
++msgid "Default Recording at stop"
++msgstr ""
++
++msgid " Recording at stop (min)"
++msgstr ""
++
++msgid "Missing search text!"
++msgstr ""
++
++msgid "Search text to small - use anyway?"
++msgstr ""
++
++msgid "XXV Commands"
++msgstr ""
++
++msgid "Please Wait ..."
++msgstr ""
++
++msgid "Error can not send XXV Command"
++msgstr ""
++
++msgid "XXVD Configuration is used:"
++msgstr ""
++
++msgid "create timers"
++msgstr ""
++
++msgid "read EPG data"
++msgstr ""
++
++msgid "read channels"
++msgstr ""
++
++msgid "Database"
++msgstr ""
++
++msgid "Database-Port"
++msgstr ""
++
++msgid "Database-User"
++msgstr ""
++
++msgid "Database-Password"
++msgstr ""
++
++msgid "Default-Lifetime"
++msgstr ""
++
++msgid "Default-Priority"
++msgstr ""
++
++msgid "Default-prevminutes"
++msgstr ""
++
++msgid "Default-afterminutes"
++msgstr ""
++
diff --git a/media-plugins/vdr-xxvautotimer/files/vdr-xxvautotimer-0.1.2-makefile-fix.diff b/media-plugins/vdr-xxvautotimer/files/vdr-xxvautotimer-0.1.2-makefile-fix.diff
new file mode 100644
index 000000000000..f3bf2a8357ea
--- /dev/null
+++ b/media-plugins/vdr-xxvautotimer/files/vdr-xxvautotimer-0.1.2-makefile-fix.diff
@@ -0,0 +1,14 @@
+fix compile probs for distcc and multicore cpu
+2009 Feb 23; hd_brummy@g.o
+diff -Naur xxvautotimer-0.1.2.orig/Makefile xxvautotimer-0.1.2/Makefile
+--- xxvautotimer-0.1.2.orig/Makefile 2009-02-23 21:01:22.046514520 +0100
++++ xxvautotimer-0.1.2/Makefile 2009-02-23 21:02:00.720161608 +0100
+@@ -107,7 +107,7 @@
+
+
+ $(MYSQLWRAPPERDIR)/$(MYSQLWRAPPERLIB):
+- cd $(MYSQLWRAPPERDIR);make all
++ ${MAKE} -C $(MYSQLWRAPPERDIR) all
+
+
+ libvdr-$(PLUGIN).so: $(OBJS) $(MYSQLWRAPPERDIR)/$(MYSQLWRAPPERLIB)
diff --git a/media-plugins/vdr-xxvautotimer/vdr-xxvautotimer-0.1.2-r1.ebuild b/media-plugins/vdr-xxvautotimer/vdr-xxvautotimer-0.1.2-r1.ebuild
new file mode 100644
index 000000000000..86069607e1ad
--- /dev/null
+++ b/media-plugins/vdr-xxvautotimer/vdr-xxvautotimer-0.1.2-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-xxvautotimer/vdr-xxvautotimer-0.1.2-r1.ebuild,v 1.1 2009/02/23 23:50:41 hd_brummy Exp $
+
+inherit vdr-plugin
+
+DESCRIPTION="VDR plugin: edit Autotimers of XXV via VDR on-screen-display"
+HOMEPAGE="http://www.vdrtools.de/vdrxxvautotimer.html"
+SRC_URI="http://www.vdrtools.de/download/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND=">=media-video/vdr-1.3.0"
+
+RDEPEND=">=net-www/xxv-0.30"
+
+PATCHES=("${FILESDIR}/vdr-1.5.7-gettext.diff"
+ "${FILESDIR}/${P}_gcc-4.3.x.diff"
+ "${FILESDIR}/${P}_compile-warn.diff"
+ "${FILESDIR}/${P}-makefile-fix.diff")
+
+src_unpack() {
+ vdr-plugin_src_unpack
+
+ sed -i "s:CFLAGS =:CFLAGS ?=:" "${S}"/mysqlwrapped-1.4/Makefile
+}