summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2007-06-29 15:38:25 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2007-06-29 15:38:25 +0000
commit13ee6bb4d516fc73bdc0b1570aa0008937192d27 (patch)
tree24d8e36a65d5d8a79f79fddda1d84cf7524e0fec /media-plugins
parentFix libgpod dep and use absolute path for configure (diff)
downloadgentoo-2-13ee6bb4d516fc73bdc0b1570aa0008937192d27.tar.gz
gentoo-2-13ee6bb4d516fc73bdc0b1570aa0008937192d27.tar.bz2
gentoo-2-13ee6bb4d516fc73bdc0b1570aa0008937192d27.zip
Replace append of -fPIC with a proper patch for PIC support, remove bad -lintl linking, add another patch to fix plugins directory choice and one to fix the extra CFLAGS; replace ppc-macos checks with userland_Darwin and add it to IUSE; make pkgconfig a buildtime-only dependency, remove sed dependency.
(Portage version: 2.1.3_rc6)
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/swh-plugins/ChangeLog12
-rw-r--r--media-plugins/swh-plugins/files/swh-plugins-0.4.15-pic.patch135
-rw-r--r--media-plugins/swh-plugins/files/swh-plugins-0.4.15-plugindir.patch13
-rw-r--r--media-plugins/swh-plugins/files/swh-plugins-0.4.15-riceitdown.patch23
-rw-r--r--media-plugins/swh-plugins/swh-plugins-0.4.15.ebuild37
5 files changed, 203 insertions, 17 deletions
diff --git a/media-plugins/swh-plugins/ChangeLog b/media-plugins/swh-plugins/ChangeLog
index 46f53537bc38..104562ff559b 100644
--- a/media-plugins/swh-plugins/ChangeLog
+++ b/media-plugins/swh-plugins/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for media-plugins/swh-plugins
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/swh-plugins/ChangeLog,v 1.32 2007/06/16 14:28:18 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/swh-plugins/ChangeLog,v 1.33 2007/06/29 15:38:25 flameeyes Exp $
+
+ 29 Jun 2007; Diego Pettenò <flameeyes@gentoo.org>
+ +files/swh-plugins-0.4.15-pic.patch,
+ +files/swh-plugins-0.4.15-plugindir.patch,
+ +files/swh-plugins-0.4.15-riceitdown.patch, swh-plugins-0.4.15.ebuild:
+ Replace append of -fPIC with a proper patch for PIC support, remove bad
+ -lintl linking, add another patch to fix plugins directory choice and one to
+ fix the extra CFLAGS; replace ppc-macos checks with userland_Darwin and add
+ it to IUSE; make pkgconfig a buildtime-only dependency, remove sed
+ dependency.
*swh-plugins-0.4.15 (16 Jun 2007)
diff --git a/media-plugins/swh-plugins/files/swh-plugins-0.4.15-pic.patch b/media-plugins/swh-plugins/files/swh-plugins-0.4.15-pic.patch
new file mode 100644
index 000000000000..58fcd64bce88
--- /dev/null
+++ b/media-plugins/swh-plugins/files/swh-plugins-0.4.15-pic.patch
@@ -0,0 +1,135 @@
+Index: swh-plugins-0.4.15/gsm/Makefile.am
+===================================================================
+--- swh-plugins-0.4.15.orig/gsm/Makefile.am
++++ swh-plugins-0.4.15/gsm/Makefile.am
+@@ -2,12 +2,12 @@ LIBTOOL=libtool
+ RANLIB=ranlib
+
+ noinst_HEADERS = gsm.h config.h private.h proto.h unproto.h
+-noinst_LIBRARIES = libgsm.a
++noinst_LTLIBRARIES = libgsm.la
+
+ CFILES = add.c decode.c gsm_decode.c gsm_encode.c long_term.c preprocess.c \
+ short_term.c code.c gsm_create.c gsm_destroy.c gsm_option.c lpc.c rpe.c table.c
+
+-libgsm_a_SOURCES = $(CFILES) $(noinst_HEADERS)
++libgsm_la_SOURCES = $(CFILES) $(noinst_HEADERS)
+
+ # Disable autoheader.
+ AUTOHEADER=echo
+Index: swh-plugins-0.4.15/Makefile.am
+===================================================================
+--- swh-plugins-0.4.15.orig/Makefile.am
++++ swh-plugins-0.4.15/Makefile.am
+@@ -48,10 +48,10 @@ DESTDIR = $(INSTALL_ROOT)
+ DISTFN = $(distdir)
+
+ # Files needed for FFT based plugins
+-pitch_scale_1193_la_LIBADD = util/libpitchscale.a $(FFTW_LIBS)
++pitch_scale_1193_la_LIBADD = util/libpitchscale.la $(FFTW_LIBS)
+ pitch_scale_1193_la_CFLAGS = $(FFTW_CFLAGS)
+ pitch_scale_1193_la_SOURCES = pitch_scale_1193.c
+-pitch_scale_1194_la_LIBADD = util/libpitchscale.a $(FFTW_LIBS)
++pitch_scale_1194_la_LIBADD = util/libpitchscale.la $(FFTW_LIBS)
+ pitch_scale_1194_la_CFLAGS = $(FFTW_CFLAGS)
+ pitch_scale_1194_la_SOURCES = pitch_scale_1194.c
+ mbeq_1197_la_LIBADD = $(FFTW_LIBS)
+@@ -60,33 +60,33 @@ mbeq_1197_la_SOURCES = mbeq_1197.c
+ imp_1199_la_LIBADD = $(FFTW_LIBS)
+ imp_1199_la_CFLAGS = $(FFTW_CFLAGS)
+ imp_1199_la_DEPENDENCIES = @top_srcdir@/impulses/*
+-hermes_filter_1200_la_DEPENDENCIES = util/libblo.a
+-hermes_filter_1200_la_LIBADD = util/libblo.a
+-fm_osc_1415_la_DEPENDENCIES = util/libblo.a
+-fm_osc_1415_la_LIBADD = util/libblo.a
+-analogue_osc_1416_la_DEPENDENCIES = util/libblo.a
+-analogue_osc_1416_la_LIBADD = util/libblo.a
+-sc1_1425_la_LIBADD = util/libdb.a util/librms.a
+-sc2_1426_la_LIBADD = util/libdb.a util/librms.a
+-sc3_1427_la_LIBADD = util/libdb.a util/librms.a
+-sc4_1882_la_LIBADD = util/libdb.a util/librms.a
+-sc4m_1916_la_LIBADD = util/libdb.a util/librms.a
+-se4_1883_la_LIBADD = util/libdb.a util/librms.a
+-gsm_1215_la_LIBADD = gsm/libgsm.a
+-gverb_1216_la_LIBADD = gverb/libgverb.a
++hermes_filter_1200_la_DEPENDENCIES = util/libblo.la
++hermes_filter_1200_la_LIBADD = util/libblo.la
++fm_osc_1415_la_DEPENDENCIES = util/libblo.la
++fm_osc_1415_la_LIBADD = util/libblo.la
++analogue_osc_1416_la_DEPENDENCIES = util/libblo.la
++analogue_osc_1416_la_LIBADD = util/libblo.la
++sc1_1425_la_LIBADD = util/libdb.la util/librms.la
++sc2_1426_la_LIBADD = util/libdb.la util/librms.la
++sc3_1427_la_LIBADD = util/libdb.la util/librms.la
++sc4_1882_la_LIBADD = util/libdb.la util/librms.la
++sc4m_1916_la_LIBADD = util/libdb.la util/librms.la
++se4_1883_la_LIBADD = util/libdb.la util/librms.la
++gsm_1215_la_LIBADD = gsm/libgsm.la
++gverb_1216_la_LIBADD = gverb/libgverb.la
+ lcr_delay_1436_la_DEPENDENCIES = util/biquad.h
+
+-highpass_iir_1890_la_LIBADD = util/libiir.a
++highpass_iir_1890_la_LIBADD = util/libiir.la
+ highpass_iir_1890_la_SOURCES = highpass_iir_1890.c
+-lowpass_iir_1891_la_LIBADD = util/libiir.a
++lowpass_iir_1891_la_LIBADD = util/libiir.la
+ lowpass_iir_1891_la_SOURCES = lowpass_iir_1891.c
+-bandpass_iir_1892_la_LIBADD = util/libiir.a
++bandpass_iir_1892_la_LIBADD = util/libiir.la
+ bandpass_iir_1892_la_SOURCES = bandpass_iir_1892.c
+-bandpass_a_iir_1893_la_LIBADD = util/libiir.a
++bandpass_a_iir_1893_la_LIBADD = util/libiir.la
+ bandpass_a_iir_1893_la_SOURCES = bandpass_a_iir_1893.c
+-notch_iir_1894_la_LIBADD = util/libiir.a
++notch_iir_1894_la_LIBADD = util/libiir.la
+ notch_iir_1894_la_SOURCES = notch_iir_1894.c
+-butterworth_1902_la_LIBADD = util/libiir.a
++butterworth_1902_la_LIBADD = util/libiir.la
+ butterworth_1902_la_SOURCES = butterworth_1902.c
+
+ # Rule to build .c files from XML source
+Index: swh-plugins-0.4.15/util/Makefile.am
+===================================================================
+--- swh-plugins-0.4.15.orig/util/Makefile.am
++++ swh-plugins-0.4.15/util/Makefile.am
+@@ -3,16 +3,16 @@ RANLIB=ranlib
+
+ noinst_HEADERS = rms.h db.h blo.h pitchscale.h waveguide_nl.h biquad.h iir.h buffer.h ls_filter.h
+
+-noinst_LIBRARIES = librms.a libdb.a libblo.a libpitchscale.a libiir.a
++noinst_LTLIBRARIES = librms.la libdb.la libblo.la libpitchscale.la libiir.la
+
+-librms_a_SOURCES = rms.c
+-libdb_a_SOURCES = db.c
+-libblo_a_SOURCES = blo.c
+-libblo_a_CFLAGS = -I@top_srcdir@
+-libpitchscale_a_SOURCES = pitchscale.c
+-libpitchscale_a_CFLAGS = $(FFTW_CFLAGS)
++librms_la_SOURCES = rms.c
++libdb_la_SOURCES = db.c
++libblo_la_SOURCES = blo.c
++libblo_la_CFLAGS = -I@top_srcdir@
++libpitchscale_la_SOURCES = pitchscale.c
++libpitchscale_la_CFLAGS = $(FFTW_CFLAGS)
+ #libpitchscale_a_LIBS = $(FFTW_LIBS)
+-libiir_a_SOURCES = iir.c
++libiir_la_SOURCES = iir.c
+ #libbuffer_a_SOURCES = buffer.c
+ # Disable autoheader.
+ AUTOHEADER=echo
+Index: swh-plugins-0.4.15/gverb/Makefile.am
+===================================================================
+--- swh-plugins-0.4.15.orig/gverb/Makefile.am
++++ swh-plugins-0.4.15/gverb/Makefile.am
+@@ -3,9 +3,9 @@ RANLIB=ranlib
+
+ noinst_HEADERS = gverb.h gverbdsp.h
+
+-noinst_LIBRARIES = libgverb.a
++noinst_LTLIBRARIES = libgverb.la
+
+-libgverb_a_SOURCES = gverb.c gverbdsp.c
++libgverb_la_SOURCES = gverb.c gverbdsp.c
+
+ # Disable autoheader.
+ AUTOHEADER=echo
diff --git a/media-plugins/swh-plugins/files/swh-plugins-0.4.15-plugindir.patch b/media-plugins/swh-plugins/files/swh-plugins-0.4.15-plugindir.patch
new file mode 100644
index 000000000000..011ea9882090
--- /dev/null
+++ b/media-plugins/swh-plugins/files/swh-plugins-0.4.15-plugindir.patch
@@ -0,0 +1,13 @@
+Index: swh-plugins-0.4.15/Makefile.am
+===================================================================
+--- swh-plugins-0.4.15.orig/Makefile.am
++++ swh-plugins-0.4.15/Makefile.am
+@@ -39,7 +39,7 @@ SUBDIRS = m4 po util gsm gverb metadata
+ EXTRA_DIST = @top_srcdir@/*.xml @top_srcdir@/*.c @top_srcdir@/*.h \
+ @top_srcdir@/*.dtd @top_srcdir@/*.pl @top_srcdir@/*.css \
+ @top_srcdir@/impulses/*.h autogen.sh bozosoity-checker.pl
+-plugindir = @prefix@/lib/ladspa
++plugindir = $(libdir)/ladspa
+
+ # Uncomment below for Darwin support. Or add a conditional for this.
+ #AM_CFLAGS = -fno-common -flat_namespace -bundle -undefined suppress -lbundle1.o
diff --git a/media-plugins/swh-plugins/files/swh-plugins-0.4.15-riceitdown.patch b/media-plugins/swh-plugins/files/swh-plugins-0.4.15-riceitdown.patch
new file mode 100644
index 000000000000..f514425e2a94
--- /dev/null
+++ b/media-plugins/swh-plugins/files/swh-plugins-0.4.15-riceitdown.patch
@@ -0,0 +1,23 @@
+Index: swh-plugins-0.4.15/configure.in
+===================================================================
+--- swh-plugins-0.4.15.orig/configure.in
++++ swh-plugins-0.4.15/configure.in
+@@ -99,12 +99,12 @@ else
+ AC_MSG_WARN([Can't find architecture specifaction in CFLAGS, picking one from build host CPU type])
+ AC_MSG_WARN([May result in non-portable code])
+ dnl For gcc use:
+- MACHINE="-march=${build_cpu}"
+- if test ${build_cpu} = "powerpc"; then MACHINE=""; fi
+- if test ${build_cpu} = "powerpc64"; then MACHINE=""; fi
+- if test ${build_cpu} = "x86_64"; then MACHINE=""; fi
+-
+- CFLAGS="$CFLAGS -Wall -O3 -fomit-frame-pointer -fstrength-reduce -funroll-loops -ffast-math -fPIC -DPIC ${MACHINE} ${USE_SSE} ${DARWIN_CFLAGS}"
++ # MACHINE="-march=${build_cpu}"
++ # if test ${build_cpu} = "powerpc"; then MACHINE=""; fi
++ # if test ${build_cpu} = "powerpc64"; then MACHINE=""; fi
++ # if test ${build_cpu} = "x86_64"; then MACHINE=""; fi
++ #
++ # CFLAGS="$CFLAGS -Wall -O3 -fomit-frame-pointer -fstrength-reduce -funroll-loops -ffast-math -fPIC -DPIC ${MACHINE} ${USE_SSE} ${DARWIN_CFLAGS}"
+
+ dnl For Intel's C compiler use:
+ dnl CC="icc"
diff --git a/media-plugins/swh-plugins/swh-plugins-0.4.15.ebuild b/media-plugins/swh-plugins/swh-plugins-0.4.15.ebuild
index b805bb7a9926..d6c99a9c4ba2 100644
--- a/media-plugins/swh-plugins/swh-plugins-0.4.15.ebuild
+++ b/media-plugins/swh-plugins/swh-plugins-0.4.15.ebuild
@@ -1,8 +1,10 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/swh-plugins/swh-plugins-0.4.15.ebuild,v 1.1 2007/06/16 14:28:18 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/swh-plugins/swh-plugins-0.4.15.ebuild,v 1.2 2007/06/29 15:38:25 flameeyes Exp $
-inherit flag-o-matic eutils
+WANT_AUTOMAKE="1.8"
+
+inherit eutils autotools
DESCRIPTION="Large collection of LADSPA audio plugins/effects"
HOMEPAGE="http://plugin.org.uk"
@@ -11,34 +13,37 @@ SRC_URI="http://plugin.org.uk/releases/${PV}/${P}.tar.gz"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~amd64 ~ppc ~ppc-macos ~x86"
-IUSE="3dnow nls sse"
+IUSE="3dnow nls sse userland_Darwin"
-DEPEND="media-libs/ladspa-sdk
- dev-util/pkgconfig
- >=sci-libs/fftw-3
- >=sys-apps/sed-4"
+RDEPEND="media-libs/ladspa-sdk
+ >=sci-libs/fftw-3"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
src_unpack() {
unpack ${A}
- use amd64 && append-flags -fPIC
- use ppc && append-flags -fPIC
- use ppc-macos && append-flags -fPIC
- use ppc-macos && append-ldflags -lintl -lsystem -lm
-
cd "${S}"
- sed -i -e '/MACHINE=/s/.*/MACHINE=""/' configure
- sed -i -r "s/(^plugindir.*)(lib)/\1$(get_libdir)/g" Makefile.in
+ epatch "${FILESDIR}/${P}-pic.patch"
+ epatch "${FILESDIR}/${P}-plugindir.patch"
+ epatch "${FILESDIR}/${P}-riceitdown.patch"
+
+ # This is needed to run autoreconf with newer autotools
+ sed -i -e 's:@MKINSTALLDIRS@:$(top_srcdir)/mkinstalldirs:' \
+ po/Makefile.in.in || die "mkinstalldirs sed failed"
+
+ eautoreconf
+ elibtoolize
}
src_compile() {
- use ppc-macos && myconf="${myconf} --enable-darwin"
econf ${myconf} \
$(use_enable sse) \
$(use_enable 3dnow) \
$(use_enable nls) \
+ $(use_enable userland_Darwin darwin) \
--enable-fast-install \
- --disable-dependency-tracking
+ --disable-dependency-tracking || die "econf failed"
emake || die "emake failed."
}