summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2006-07-17 10:14:17 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2006-07-17 10:14:17 +0000
commit6dac549da3d3fe790034cb4e707ccbaf5caa6c68 (patch)
tree68f31360a01181934f9ec9cfbff9d0e5c4ef6061 /media-plugins
parentBumping kdenlive and masking broken older version. (diff)
downloadgentoo-2-6dac549da3d3fe790034cb4e707ccbaf5caa6c68.tar.gz
gentoo-2-6dac549da3d3fe790034cb4e707ccbaf5caa6c68.tar.bz2
gentoo-2-6dac549da3d3fe790034cb4e707ccbaf5caa6c68.zip
Added patch for handling default-picture settings. Removed older versions.
(Portage version: 2.1.1_pre3-r1)
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/vdr-softdevice/ChangeLog16
-rw-r--r--media-plugins/vdr-softdevice/files/digest-vdr-softdevice-0.2.3.20060511-r73
-rw-r--r--media-plugins/vdr-softdevice/files/vdr-softdevice-0.2.3-picture-settings-use-defaults.diff141
-rw-r--r--media-plugins/vdr-softdevice/vdr-softdevice-0.2.3.20060511-r7.ebuild111
4 files changed, 270 insertions, 1 deletions
diff --git a/media-plugins/vdr-softdevice/ChangeLog b/media-plugins/vdr-softdevice/ChangeLog
index 232100d21674..64c890467c64 100644
--- a/media-plugins/vdr-softdevice/ChangeLog
+++ b/media-plugins/vdr-softdevice/ChangeLog
@@ -1,6 +1,20 @@
# ChangeLog for media-plugins/vdr-softdevice
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-softdevice/ChangeLog,v 1.8 2006/07/15 17:43:16 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-softdevice/ChangeLog,v 1.9 2006/07/17 10:14:17 zzam Exp $
+
+*vdr-softdevice-0.2.3.20060511-r7 (17 Jul 2006)
+
+ 17 Jul 2006; Matthias Schwarzott <zzam@gentoo.org>
+ +files/vdr-softdevice-0.2.3-picture-settings-use-defaults.diff,
+ -vdr-softdevice-0.2.3.20060511.ebuild,
+ -vdr-softdevice-0.2.3.20060511-r1.ebuild,
+ -vdr-softdevice-0.2.3.20060511-r2.ebuild,
+ -vdr-softdevice-0.2.3.20060511-r3.ebuild,
+ -vdr-softdevice-0.2.3.20060511-r4.ebuild,
+ -vdr-softdevice-0.2.3.20060511-r5.ebuild,
+ -vdr-softdevice-0.2.3.20060511-r6.ebuild,
+ +vdr-softdevice-0.2.3.20060511-r7.ebuild, -vdr-softdevice-0.2.3a.ebuild:
+ Added patch for handling default-picture settings. Removed older versions.
*vdr-softdevice-0.2.3.20060511-r6 (15 Jul 2006)
diff --git a/media-plugins/vdr-softdevice/files/digest-vdr-softdevice-0.2.3.20060511-r7 b/media-plugins/vdr-softdevice/files/digest-vdr-softdevice-0.2.3.20060511-r7
new file mode 100644
index 000000000000..cb395c04db4b
--- /dev/null
+++ b/media-plugins/vdr-softdevice/files/digest-vdr-softdevice-0.2.3.20060511-r7
@@ -0,0 +1,3 @@
+MD5 dfae4ed2ab2bb17572de993461cf36f8 vdr-softdevice-0.2.3a.tgz 133780
+RMD160 d97d7a1bbe4a3b325041bbe0e7ef23740f8121b1 vdr-softdevice-0.2.3a.tgz 133780
+SHA256 bbf05254ce6f0559ce6aeed055272ba6fb207ba443a49926b91506e9de69ab92 vdr-softdevice-0.2.3a.tgz 133780
diff --git a/media-plugins/vdr-softdevice/files/vdr-softdevice-0.2.3-picture-settings-use-defaults.diff b/media-plugins/vdr-softdevice/files/vdr-softdevice-0.2.3-picture-settings-use-defaults.diff
new file mode 100644
index 000000000000..9221abe1b61f
--- /dev/null
+++ b/media-plugins/vdr-softdevice/files/vdr-softdevice-0.2.3-picture-settings-use-defaults.diff
@@ -0,0 +1,141 @@
+Index: setup-softdevice.c
+===================================================================
+RCS file: /cvsroot/softdevice/softdevice/setup-softdevice.c,v
+retrieving revision 1.45
+diff -u -r1.45 setup-softdevice.c
+--- setup-softdevice.c 25 Jun 2006 13:46:12 -0000 1.45
++++ setup-softdevice.c 16 Jul 2006 19:48:50 -0000
+@@ -91,6 +91,8 @@
+ {
+ xvAspect = 1; // XV_FORMAT_NORMAL;
+ xvMaxArea = 0;
++ xvFullscreen = 0;
++ xvUseDefaults = 0;
+ outputMethod = 0;
+ cropMode = 0;
+ cropModeToggleKey = 0;
+Index: setup-softdevice.h
+===================================================================
+RCS file: /cvsroot/softdevice/softdevice/setup-softdevice.h,v
+retrieving revision 1.32
+diff -u -r1.32 setup-softdevice.h
+--- setup-softdevice.h 25 Jun 2006 13:46:12 -0000 1.32
++++ setup-softdevice.h 16 Jul 2006 19:48:51 -0000
+@@ -125,6 +125,7 @@
+ int xvAspect;
+ int xvMaxArea;
+ int xvFullscreen;
++ int xvUseDefaults;
+ int outputMethod;
+ int pixelFormat;
+ bool pixelFormatLocked;
+Index: softdevice.c
+===================================================================
+RCS file: /cvsroot/softdevice/softdevice/softdevice.c,v
+retrieving revision 1.64
+diff -u -r1.64 softdevice.c
+--- softdevice.c 11 Jul 2006 20:31:37 -0000 1.64
++++ softdevice.c 16 Jul 2006 19:48:52 -0000
+@@ -368,6 +368,8 @@
+ {
+ esyslog("[softdevice] could not load (%s)[%s] exiting\n",
+ subPluginFileName, err);
++ fprintf(stderr,"[softdevice] could not load (%s)[%s] exiting\n",
++ subPluginFileName, err);
+ exit(1);
+ }
+ }
+@@ -705,6 +707,7 @@
+ " -vo xv:aspect=normal use a 4:3 display area (768x576)\n"
+ " -vo xv:max-area use maximum available area\n"
+ " -vo xv:full startup fullscreen\n"
++ " -vo xv:use-defaults don't change brigtness etc on startup\n"
+ #endif
+ #ifdef FB_SUPPORT
+ " -vo fb: enable output via framebuffer\n"
+@@ -782,6 +785,11 @@
+ fprintf (stderr,
+ "[ProcessArgs] xv: start up fullscreen\n");
+ vo_argv += 4;
++ } else if (!strncmp (vo_argv, "use-defaults", 12)) {
++ fprintf (stderr,
++ "[ProcessArgs] xv: don't change brigtness etc on startup\n");
++ setupStore.xvUseDefaults=true;
++ vo_argv += 12;
+ } else {
+ fprintf(stderr,"[softdevice] ignoring unrecognized option \"%s\"!\n",argv[i]);
+ esyslog("[softdevice] ignoring unrecognized option \"%s\"\n",argv[i]);
+Index: video-xv.c
+===================================================================
+RCS file: /cvsroot/softdevice/softdevice/video-xv.c,v
+retrieving revision 1.57
+diff -u -r1.57 video-xv.c
+--- video-xv.c 16 Jul 2006 02:09:22 -0000 1.57
++++ video-xv.c 16 Jul 2006 19:48:54 -0000
+@@ -126,6 +126,21 @@
+
+ /* ---------------------------------------------------------------------------
+ */
++int cXvPortAttributeStore::GetValuePercent(int index)
++{
++ int value = portAttributeCurrentValues[index];
++
++ value = (int) (((double) value - (double) portAttributes[index].min_value) * 100.0
++ / ((double) portAttributes[index].max_value - (double) portAttributes[index].min_value));
++
++ if (value <= 100 &&
++ value >= 0)
++ return value;
++ return 0;
++}
++
++/* ---------------------------------------------------------------------------
++ */
+ void cXvPortAttributeStore::SetValuePercent(char *name, int value)
+ {
+ for (int i = 0; i < portAttributeCount; ++i)
+@@ -217,13 +232,29 @@
+ portAttributeCurrentValues[i] = portAttributeSaveValues[i];
+ }
+ if (!strcmp(portAttributes[i].name, "XV_BRIGHTNESS"))
++ {
+ setupStore->vidCaps |= CAP_BRIGHTNESS;
++ if (setupStore->xvUseDefaults)
++ setupStore->vidBrightness = currBrightness = GetValuePercent(i);
++ }
+ if (!strcmp(portAttributes[i].name, "XV_CONTRAST"))
++ {
+ setupStore->vidCaps |= CAP_CONTRAST;
++ if (setupStore->xvUseDefaults)
++ setupStore->vidContrast = currContrast = GetValuePercent(i);
++ }
+ if (!strcmp(portAttributes[i].name, "XV_HUE"))
++ {
+ setupStore->vidCaps |= CAP_HUE;
++ if (setupStore->xvUseDefaults)
++ setupStore->vidHue = currHue = GetValuePercent(i);
++ }
+ if (!strcmp(portAttributes[i].name, "XV_SATURATION"))
++ {
+ setupStore->vidCaps |= CAP_SATURATION;
++ if (setupStore->xvUseDefaults)
++ setupStore->vidSaturation = currSaturation = GetValuePercent(i);
++ }
+
+ dsyslog("[XvVideoOut]:"
+ " %-25s %-4sXvGettable %-4sXvSettable "
+Index: video-xv.h
+===================================================================
+RCS file: /cvsroot/softdevice/softdevice/video-xv.h,v
+retrieving revision 1.21
+diff -u -r1.21 video-xv.h
+--- video-xv.h 27 May 2006 19:12:42 -0000 1.21
++++ video-xv.h 16 Jul 2006 19:48:54 -0000
+@@ -91,6 +91,7 @@
+ void SetXInfo(Display *dpy, XvPortID port, cSetupStore *setupStore);
+ void SetValue(char *name, int value);
+ void SetValuePercent(char *name, int value);
++ int GetValuePercent(int index);
+ void SetColorkey(int value);
+ void Increment(char *name);
+ void Decrement(char *name);
diff --git a/media-plugins/vdr-softdevice/vdr-softdevice-0.2.3.20060511-r7.ebuild b/media-plugins/vdr-softdevice/vdr-softdevice-0.2.3.20060511-r7.ebuild
new file mode 100644
index 000000000000..031b220f3221
--- /dev/null
+++ b/media-plugins/vdr-softdevice/vdr-softdevice-0.2.3.20060511-r7.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-softdevice/vdr-softdevice-0.2.3.20060511-r7.ebuild,v 1.1 2006/07/17 10:14:17 zzam Exp $
+
+inherit vdr-plugin versionator
+
+MY_PV="$(get_version_component_range 1-3)a"
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="VDR plugin: Software output-Device"
+HOMEPAGE="http://softdevice.berlios.de/"
+SRC_URI="mirror://gentoo/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="xv fbcon directfb mmx mmxext"
+
+RDEPEND=">=media-video/vdr-1.3.36
+ >=media-video/ffmpeg-0.4.9_pre1
+ directfb? (
+ dev-libs/DirectFB
+ dev-libs/DFB++
+ )
+ media-libs/alsa-lib
+ xv? ( || ( ( x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXv
+ )
+ virtual/x11
+ ) )"
+
+DEPEND="${RDEPEND}
+ xv? ( || ( ( x11-proto/xproto
+ x11-proto/xextproto
+ x11-libs/libXv
+ )
+ virtual/x11
+ ) )
+ fbcon? ( sys-kernel/linux-headers )"
+
+
+S=${WORKDIR}/${VDRPLUGIN}-${MY_PV}
+PATCHES="${FILESDIR}/${MY_P}-Makefile.diff ${FILESDIR}/${MY_P}-CVS-20060511.diff
+ ${FILESDIR}/vdr-softdevice-0.2.3-shm-contrast.diff
+ ${FILESDIR}/vdr-softdevice-0.2.3-shm-key-init.diff
+ ${FILESDIR}/vdr-softdevice-0.2.3-shm-fullscreen.diff
+ ${FILESDIR}/vdr-softdevice-0.2.3-picture-settings-use-defaults.diff"
+
+pkg_setup() {
+ vdr-plugin_pkg_setup
+
+ if use !xv && use !fbcon && use !directfb; then
+ ewarn "You need to set at least one of these use-flags: xv fbcon directfb"
+ die "no output-method enabled"
+ fi
+
+ COMPILE_SHM=0
+ if has_version ">=media-video/vdr-1.3.0"; then
+ if use xv; then
+ COMPILE_SHM=1
+ else
+ einfo "SHM does only support xv at the moment"
+ fi
+ else
+ einfo "SHM not supported on vdr-1.2"
+ fi
+ case ${COMPILE_SHM} in
+ 0) einfo "SHM support will not be compiled." ;;
+ 1) einfo "SHM support will be compiled." ;;
+ esac
+}
+
+src_unpack() {
+ vdr-plugin_src_unpack
+
+ use mmx || sed -i ${S}/Makefile -e '/MMX$/d'
+ use mmxext || sed -i ${S}/Makefile -e '/MMX2$/d'
+
+ # Do not force MMX on in configure
+ sed -i ${S}/configure -e '/USE_MMX/s/^.*$/:/'
+}
+
+src_compile() {
+ local MYOPTS=""
+ MYOPTS="${MYOPTS} --disable-vidix"
+ use xv || MYOPTS="${MYOPTS} --disable-xv"
+ use fbcon || MYOPTS="${MYOPTS} --disable-fb"
+ use directfb || MYOPTS="${MYOPTS} --disable-dfb"
+
+ [[ ${COMPILE_SHM} == 1 ]] || MYOPTS="${MYOPTS} --disable-shm"
+
+ cd ${S}
+ ./configure ${MYOPTS}
+
+ vdr-plugin_src_compile
+}
+
+src_install() {
+ vdr-plugin_src_install
+
+ insinto "${VDR_PLUGIN_DIR}"
+ doins libsubvdr-*.so.*
+
+ if [[ "${COMPILE_SHM}" = "1" ]]; then
+ exeinto "/usr/bin"
+ doexe ShmClient
+ fi
+}
+