summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-11-13 12:30:01 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-11-13 12:30:01 +0000
commit714b4915d4f4835c381d34a4d0341522aaa9ff80 (patch)
tree60463293cfec4cca0f279d176d3610b881382625 /media-plugins
parentVersion bump (diff)
downloadgentoo-2-714b4915d4f4835c381d34a4d0341522aaa9ff80.tar.gz
gentoo-2-714b4915d4f4835c381d34a4d0341522aaa9ff80.tar.bz2
gentoo-2-714b4915d4f4835c381d34a4d0341522aaa9ff80.zip
Update the patch (and the econf options) with what upstream wanted, just to avoid diverging.
(Portage version: 2.2_rc14/cvs/Linux 2.6.27-gentoo-r2 x86_64)
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/alsa-plugins/ChangeLog7
-rw-r--r--media-plugins/alsa-plugins/alsa-plugins-1.0.18.ebuild10
-rw-r--r--media-plugins/alsa-plugins/files/alsa-plugins-1.0.18-automagic.patch37
3 files changed, 32 insertions, 22 deletions
diff --git a/media-plugins/alsa-plugins/ChangeLog b/media-plugins/alsa-plugins/ChangeLog
index c38c75df6d42..ce1cd4252bd8 100644
--- a/media-plugins/alsa-plugins/ChangeLog
+++ b/media-plugins/alsa-plugins/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-plugins/alsa-plugins
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/alsa-plugins/ChangeLog,v 1.80 2008/11/13 00:39:15 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/alsa-plugins/ChangeLog,v 1.81 2008/11/13 12:30:00 flameeyes Exp $
+
+ 13 Nov 2008; Diego Pettenò <flameeyes@gentoo.org>
+ files/alsa-plugins-1.0.18-automagic.patch, alsa-plugins-1.0.18.ebuild:
+ Update the patch (and the econf options) with what upstream wanted, just
+ to avoid diverging.
*alsa-plugins-1.0.18 (13 Nov 2008)
diff --git a/media-plugins/alsa-plugins/alsa-plugins-1.0.18.ebuild b/media-plugins/alsa-plugins/alsa-plugins-1.0.18.ebuild
index 58c2f1e5670c..48a79a8f7d61 100644
--- a/media-plugins/alsa-plugins/alsa-plugins-1.0.18.ebuild
+++ b/media-plugins/alsa-plugins/alsa-plugins-1.0.18.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/alsa-plugins/alsa-plugins-1.0.18.ebuild,v 1.1 2008/11/13 00:39:15 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/alsa-plugins/alsa-plugins-1.0.18.ebuild,v 1.2 2008/11/13 12:30:00 flameeyes Exp $
EAPI=2
@@ -51,10 +51,10 @@ src_configure() {
use debug || append-flags -DNDEBUG
econf \
- $(use_with ffmpeg avcodec) \
- $(use_with jack) \
- $(use_with libsamplerate samplerate) \
- $(use_with pulseaudio) \
+ $(use_enable ffmpeg avcodec) \
+ $(use_enable jack) \
+ $(use_enable libsamplerate samplerate) \
+ $(use_enable pulseaudio) \
$(use_with speex speex lib) \
--disable-dependency-tracking \
|| die "econf failed"
diff --git a/media-plugins/alsa-plugins/files/alsa-plugins-1.0.18-automagic.patch b/media-plugins/alsa-plugins/files/alsa-plugins-1.0.18-automagic.patch
index 8720f8c4852b..a85114d7a990 100644
--- a/media-plugins/alsa-plugins/files/alsa-plugins-1.0.18-automagic.patch
+++ b/media-plugins/alsa-plugins/files/alsa-plugins-1.0.18-automagic.patch
@@ -1,7 +1,10 @@
-From 4aed9c0b2ae244f1a57337ff8c3dc6070c087c49 Mon Sep 17 00:00:00 2001
+From 8e4cd0e52ceda7acbf52616beadf7a355208400e Mon Sep 17 00:00:00 2001
From: =?utf-8?q?Diego=20'Flameeyes'=20Petten=C3=B2?= <flameeyes@gmail.com>
-Date: Thu, 13 Nov 2008 01:23:35 +0100
+Date: Thu, 13 Nov 2008 13:10:31 +0100
Subject: [PATCH] Allow opt-out from jack, pulseaudio and avcodec dependencies.
+MIME-Version: 1.0
+Content-Type: text/plain; charset=utf-8
+Content-Transfer-Encoding: 8bit
Without this patch the jack, pulseaudio and avcodec discovery was
"automagic", without a way for the user to disable the relative
@@ -10,12 +13,14 @@ plugins if the dependencies are installed but the plugin is unwanted.
This patch does not change the default behaviour but allows to opt-out
from the plugins by passing the relative --without option at
./configure time.
+
+Signed-off-by: Diego 'Flameeyes' Pettenò <flameeyes@gmail.com>
---
configure.in | 31 ++++++++++++++++++++++++++-----
1 files changed, 26 insertions(+), 5 deletions(-)
diff --git a/configure.in b/configure.in
-index 9efb890..ffb6528 100644
+index 9efb890..4b5b278 100644
--- a/configure.in
+++ b/configure.in
@@ -15,13 +15,28 @@ PKG_CHECK_MODULES(ALSA, alsa >= 1.0.11)
@@ -23,28 +28,28 @@ index 9efb890..ffb6528 100644
AC_ERROR([*** libasound has no external plugin SDK]), -ldl)
-PKG_CHECK_MODULES(JACK, jack >= 0.98, [HAVE_JACK=yes], [HAVE_JACK=no])
-+AC_ARG_WITH([jack],
-+ AS_HELP_STRING([--without-jack], [Disable building of JACK plugin]))
++AC_ARG_ENABLE([jack],
++ AS_HELP_STRING([--disable-jack], [Disable building of JACK plugin]))
+
-+if test "x$with_jack" != "xno"; then
++if test "x$enable_jack" != "xno"; then
+ PKG_CHECK_MODULES(JACK, jack >= 0.98, [HAVE_JACK=yes], [HAVE_JACK=no])
+fi
AM_CONDITIONAL(HAVE_JACK, test x$HAVE_JACK = xyes)
-PKG_CHECK_MODULES(pulseaudio, [libpulse >= 0.9.2], [HAVE_PULSE=yes], [HAVE_PULSE=no])
-+AC_ARG_WITH([pulseaudio],
-+ AS_HELP_STRING([--without-pulseaudio], [Disable building of pulseaudio plugin]))
++AC_ARG_ENABLE([pulseaudio],
++ AS_HELP_STRING([--disable-pulseaudio], [Disable building of pulseaudio plugin]))
+
-+if test "x$with_pulseaudio" != "xno"; then
++if test "x$enable_pulseaudio" != "xno"; then
+ PKG_CHECK_MODULES(pulseaudio, [libpulse >= 0.9.2], [HAVE_PULSE=yes], [HAVE_PULSE=no])
+fi
AM_CONDITIONAL(HAVE_PULSE, test x$HAVE_PULSE = xyes)
-PKG_CHECK_MODULES(samplerate, [samplerate], [HAVE_SAMPLERATE=yes], [HAVE_SAMPLERATE=no])
-+AC_ARG_WITH([samplerate],
-+ AS_HELP_STRING([--without-samplerate], [Disable building of samplerate plugin]))
++AC_ARG_ENABLE([samplerate],
++ AS_HELP_STRING([--disable-samplerate], [Disable building of samplerate plugin]))
+
-+if test "x$with_samplerate" != "xno"; then
++if test "x$enable_samplerate" != "xno"; then
+ PKG_CHECK_MODULES(samplerate, [samplerate], [HAVE_SAMPLERATE=yes], [HAVE_SAMPLERATE=no])
+fi
AM_CONDITIONAL(HAVE_SAMPLERATE, test x$HAVE_SAMPLERATE = xyes)
@@ -56,14 +61,14 @@ index 9efb890..ffb6528 100644
-PKG_CHECK_MODULES(AVCODEC, [libavcodec], [HAVE_AVCODEC=yes], [HAVE_AVCODEC=no])
-if test "$HAVE_AVCODEC" != "yes"; then
-+AC_ARG_WITH([avcodec],
-+ AS_HELP_STRING([--without-avcodec], [Don't build plugins depending on avcodec (a52)]))
++AC_ARG_ENABLE([avcodec],
++ AS_HELP_STRING([--disable-avcodec], [Don't build plugins depending on avcodec (a52)]))
+
-+if test "x$with_avcodec" != "xno"; then
++if test "x$enable_avcodec" != "xno"; then
+ PKG_CHECK_MODULES(AVCODEC, [libavcodec], [HAVE_AVCODEC=yes], [HAVE_AVCODEC=no])
+fi
+
-+if test "$HAVE_AVCODEC" = "no"; then
++if test "x$HAVE_AVCODEC" = "xno"; then
AC_ARG_WITH([avcodec-includedir],
AS_HELP_STRING([--with-avcodec-includedir=dir],
[AVcodec include directory]),