summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-09-30 17:47:06 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-09-30 17:47:06 +0000
commit82ccbc28d006d77d84b73d8145df953fab5fd6b4 (patch)
tree0a61b28aa689b81bf262b50558328791005e00b7 /media-plugins
parentalpha/arm/ia64/sh/sparc/x86 stable wrt #435072 (diff)
downloadgentoo-2-82ccbc28d006d77d84b73d8145df953fab5fd6b4.tar.gz
gentoo-2-82ccbc28d006d77d84b73d8145df953fab5fd6b4.tar.bz2
gentoo-2-82ccbc28d006d77d84b73d8145df953fab5fd6b4.zip
Build system fixes thanks to Julian Ospald (hasufell). Bug #436660
(Portage version: 2.1.11.23/cvs/Linux x86_64)
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/gimp-lensfun/ChangeLog9
-rw-r--r--media-plugins/gimp-lensfun/files/gimp-lensfun-0.2.2-build.patch34
-rw-r--r--media-plugins/gimp-lensfun/gimp-lensfun-0.2.2-r1.ebuild (renamed from media-plugins/gimp-lensfun/gimp-lensfun-0.2.2.ebuild)18
3 files changed, 55 insertions, 6 deletions
diff --git a/media-plugins/gimp-lensfun/ChangeLog b/media-plugins/gimp-lensfun/ChangeLog
index 191d7adf8e75..d5f6f5c0a4a7 100644
--- a/media-plugins/gimp-lensfun/ChangeLog
+++ b/media-plugins/gimp-lensfun/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-plugins/gimp-lensfun
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/gimp-lensfun/ChangeLog,v 1.2 2012/09/30 13:16:41 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/gimp-lensfun/ChangeLog,v 1.3 2012/09/30 17:47:06 hwoarang Exp $
+
+*gimp-lensfun-0.2.2-r1 (30 Sep 2012)
+
+ 30 Sep 2012; Markos Chandras <hwoarang@gentoo.org>
+ +files/gimp-lensfun-0.2.2-build.patch, +gimp-lensfun-0.2.2-r1.ebuild,
+ -gimp-lensfun-0.2.2.ebuild:
+ Build system fixes thanks to Julian Ospald (hasufell). Bug #436660
*gimp-lensfun-0.2.2 (30 Sep 2012)
diff --git a/media-plugins/gimp-lensfun/files/gimp-lensfun-0.2.2-build.patch b/media-plugins/gimp-lensfun/files/gimp-lensfun-0.2.2-build.patch
new file mode 100644
index 000000000000..41e171e5248f
--- /dev/null
+++ b/media-plugins/gimp-lensfun/files/gimp-lensfun-0.2.2-build.patch
@@ -0,0 +1,34 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Sun Sep 30 13:22:40 UTC 2012
+Subject: build system
+
+ respect CC, CFLAGS and LDFLAGS
+ https://bugs.gentoo.org/show_bug.cgi?id=436660
+
+--- Makefile
++++ Makefile
+@@ -1,8 +1,9 @@
+-CFLAGS = -O3 -Wall $(shell gimptool-2.0 --cflags && pkg-config --cflags lensfun exiv2) -fopenmp
++CXXFLAGS ?= -O3
++CXXFLAGS += -Wall $(shell gimptool-2.0 --cflags && pkg-config --cflags lensfun exiv2) -fopenmp
+ LIBS = $(shell gimptool-2.0 --libs && pkg-config --libs lensfun exiv2)
+ PLUGIN = gimplensfun
+ SOURCES = src/gimplensfun.c
+-CC = g++
++CXX ?= g++
+ # END CONFIG ##################################################################
+
+ .PHONY: all install userinstall clean uninstall useruninstall
+@@ -12,10 +13,10 @@
+ OBJECTS = $(subst .c,.o,$(SOURCES))
+
+ $(PLUGIN): $(OBJECTS)
+- $(CC) $(CFLAGS) -o $@ $^ $(LIBS)
++ $(CXX) $(CXXFLAGS) -o $@ $^ $(LDFLAGS) $(LIBS)
+
+ %.o: %.c $(HEADERS)
+- $(CC) $(CFLAGS) -c -o $@ $*.c
++ $(CXX) $(CXXFLAGS) -c -o $@ $*.c
+
+ install: $(PLUGIN)
+ @gimptool-2.0 --install-admin-bin $^
diff --git a/media-plugins/gimp-lensfun/gimp-lensfun-0.2.2.ebuild b/media-plugins/gimp-lensfun/gimp-lensfun-0.2.2-r1.ebuild
index 29d869fb6027..896797021ebd 100644
--- a/media-plugins/gimp-lensfun/gimp-lensfun-0.2.2.ebuild
+++ b/media-plugins/gimp-lensfun/gimp-lensfun-0.2.2-r1.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/gimp-lensfun/gimp-lensfun-0.2.2.ebuild,v 1.2 2012/09/30 13:16:41 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/gimp-lensfun/gimp-lensfun-0.2.2-r1.ebuild,v 1.1 2012/09/30 17:47:06 hwoarang Exp $
EAPI="4"
+inherit eutils toolchain-funcs
+
MY_PN="gimplensfun"
MY_P="${MY_PN}-${PV}"
@@ -19,12 +21,18 @@ IUSE=""
RDEPEND="media-gfx/gimp
media-gfx/exiv2
media-libs/lensfun"
-DEPEND="${RDEPEND}"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
S="${WORKDIR}/${MY_P}"
-src_install() {
- exeinto $(gimptool-2.0 --gimpplugindir)/plug-ins
- doexe ${MY_PN}
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-build.patch
+
+ tc-export CXX
}
+src_install() {
+ exeinto $(gimptool-2.0 --gimpplugindir)/plug-ins
+ doexe ${MY_PN}
+}