summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJörg Bornkessel <hd_brummy@gentoo.org>2007-07-09 19:35:06 +0000
committerJörg Bornkessel <hd_brummy@gentoo.org>2007-07-09 19:35:06 +0000
commit92f376d6046bd98e2c73ec11f33cd629be7c1aa6 (patch)
tree90cdb994358d03769548289619b4e91a88bbccf6 /media-plugins
parentLatest dev-perl/Heap breaks Graph in tests - hard-depping older Heap. See rt ... (diff)
downloadgentoo-2-92f376d6046bd98e2c73ec11f33cd629be7c1aa6.tar.gz
gentoo-2-92f376d6046bd98e2c73ec11f33cd629be7c1aa6.tar.bz2
gentoo-2-92f376d6046bd98e2c73ec11f33cd629be7c1aa6.zip
patch added to fix compile prob on >=vdr-1.5.3
(Portage version: 2.1.2.9)
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/vdr-nordlichtsepg/ChangeLog9
-rw-r--r--media-plugins/vdr-nordlichtsepg/files/vdr-nordlichtsepg-0.8a_vdr-1.5.3.diff34
-rw-r--r--media-plugins/vdr-nordlichtsepg/vdr-nordlichtsepg-0.8a.ebuild6
3 files changed, 45 insertions, 4 deletions
diff --git a/media-plugins/vdr-nordlichtsepg/ChangeLog b/media-plugins/vdr-nordlichtsepg/ChangeLog
index c0ba572ca159..1ddf4855af2a 100644
--- a/media-plugins/vdr-nordlichtsepg/ChangeLog
+++ b/media-plugins/vdr-nordlichtsepg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-plugins/vdr-nordlichtsepg
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-nordlichtsepg/ChangeLog,v 1.13 2006/11/17 12:07:23 zzam Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-nordlichtsepg/ChangeLog,v 1.14 2007/07/09 19:35:06 hd_brummy Exp $
+
+ 09 Jul 2007; Joerg Bornkessel <hd_brummy@gentoo.org>
+ +files/vdr-nordlichtsepg-0.8a_vdr-1.5.3.diff,
+ vdr-nordlichtsepg-0.8a.ebuild:
+ patch added to fix compile prob on >=vdr-1.5.3
17 Nov 2006; Matthias Schwarzott <zzam@gentoo.org>
-vdr-nordlichtsepg-0.4.ebuild:
diff --git a/media-plugins/vdr-nordlichtsepg/files/vdr-nordlichtsepg-0.8a_vdr-1.5.3.diff b/media-plugins/vdr-nordlichtsepg/files/vdr-nordlichtsepg-0.8a_vdr-1.5.3.diff
new file mode 100644
index 000000000000..3ed0cc6341c6
--- /dev/null
+++ b/media-plugins/vdr-nordlichtsepg/files/vdr-nordlichtsepg-0.8a_vdr-1.5.3.diff
@@ -0,0 +1,34 @@
+patch from http://www.vdr-portal.de/board/thread.php?postid=624285#post624285
+
+diff -ruN nordlichtsepg-0.8a/nordlichtsepg.c nordlichtsepg-0.8a-patched/nordlichtsepg.c
+--- nordlichtsepg-0.8a/nordlichtsepg.c 2006-03-21 14:41:24.000000000 +0100
++++ nordlichtsepg-0.8a-patched/nordlichtsepg.c 2007-06-19 10:27:25.000000000 +0200
+@@ -114,8 +114,10 @@
+
+ myMenuWhatsOn::~myMenuWhatsOn()
+ {
++#if VDRVERSNUM < 10503
+ if(Setup.UseSmallFont==2)cFont::SetFont(fontSml);
+ else cFont::SetFont(fontOsd);
++#endif
+ }
+
+ void myMenuWhatsOn::LoadSchedules(int shift)
+diff -ruN nordlichtsepg-0.8a/patchfont.c nordlichtsepg-0.8a-patched/patchfont.c
+--- nordlichtsepg-0.8a/patchfont.c 2006-03-18 11:53:21.000000000 +0100
++++ nordlichtsepg-0.8a-patched/patchfont.c 2007-06-19 10:29:03.000000000 +0200
+@@ -7,6 +7,7 @@
+ // most of this function is from the epgsearch-plugin
+ void PatchFont(eDvbFont DvbFont)
+ {
++#if VDRVERSNUM < 10503
+ const cFont *font = cFont::GetFont(DvbFont);
+ int num_rows_global = font->Height();
+ int num_rows = num_rows_global+2;
+@@ -322,4 +323,5 @@
+ }
+
+ cFont::SetFont(DvbFont, font_data);
++#endif
+ }
+
diff --git a/media-plugins/vdr-nordlichtsepg/vdr-nordlichtsepg-0.8a.ebuild b/media-plugins/vdr-nordlichtsepg/vdr-nordlichtsepg-0.8a.ebuild
index a4f30d838694..ca2494d8f9b5 100644
--- a/media-plugins/vdr-nordlichtsepg/vdr-nordlichtsepg-0.8a.ebuild
+++ b/media-plugins/vdr-nordlichtsepg/vdr-nordlichtsepg-0.8a.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-nordlichtsepg/vdr-nordlichtsepg-0.8a.ebuild,v 1.2 2006/06/23 10:49:18 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-nordlichtsepg/vdr-nordlichtsepg-0.8a.ebuild,v 1.3 2007/07/09 19:35:06 hd_brummy Exp $
inherit vdr-plugin
@@ -15,3 +15,5 @@ LICENSE="GPL-2"
KEYWORDS="~amd64 x86"
DEPEND=">=media-video/vdr-1.3.31"
+
+PATCHES="${FILESDIR}/${P}_vdr-1.5.3.diff" \ No newline at end of file