summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-05-15 17:55:35 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-05-15 17:55:35 +0000
commitdce0b7a46438c676aa83a329d0f3cc98991c3d0b (patch)
tree716ba2d5350f22c565383bba58f3004c2312e756 /media-plugins
parentFinally remove qimageblitz (diff)
downloadgentoo-2-dce0b7a46438c676aa83a329d0f3cc98991c3d0b.tar.gz
gentoo-2-dce0b7a46438c676aa83a329d0f3cc98991c3d0b.tar.bz2
gentoo-2-dce0b7a46438c676aa83a329d0f3cc98991c3d0b.zip
Version bump wrt #309881 by Alexander Brüning.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/alsaequal/ChangeLog9
-rw-r--r--media-plugins/alsaequal/alsaequal-0.6.ebuild36
2 files changed, 43 insertions, 2 deletions
diff --git a/media-plugins/alsaequal/ChangeLog b/media-plugins/alsaequal/ChangeLog
index 3ea6e55e3794..4616d8007836 100644
--- a/media-plugins/alsaequal/ChangeLog
+++ b/media-plugins/alsaequal/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-plugins/alsaequal
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/alsaequal/ChangeLog,v 1.2 2009/09/30 08:40:41 fauli Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/alsaequal/ChangeLog,v 1.3 2010/05/15 17:55:35 ssuominen Exp $
+
+*alsaequal-0.6 (15 May 2010)
+
+ 15 May 2010; Samuli Suominen <ssuominen@gentoo.org> +alsaequal-0.6.ebuild:
+ Version bump wrt #309881 by Alexander Brüning.
30 Sep 2009; Christian Faulhammer <fauli@gentoo.org> alsaequal-0.4.ebuild:
add ~x86, bug 285200
diff --git a/media-plugins/alsaequal/alsaequal-0.6.ebuild b/media-plugins/alsaequal/alsaequal-0.6.ebuild
new file mode 100644
index 000000000000..b0656e820396
--- /dev/null
+++ b/media-plugins/alsaequal/alsaequal-0.6.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/alsaequal/alsaequal-0.6.ebuild,v 1.1 2010/05/15 17:55:35 ssuominen Exp $
+
+EAPI=2
+inherit multilib toolchain-funcs
+
+DESCRIPTION="a real-time adjustable equalizer plugin for ALSA"
+HOMEPAGE="http://www.thedigitalmachine.net/alsaequal.html"
+SRC_URI="http://www.thedigitalmachine.net/tools/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="media-libs/alsa-lib
+ media-plugins/caps-plugins"
+
+S=${WORKDIR}/${PN}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} -Wall -fPIC -DPIC" \
+ LD="$(tc-getCC)" \
+ LDFLAGS="${LDFLAGS} -shared" \
+ SND_PCM_LIBS="-lasound" \
+ SND_CTL_LIBS="-lasound" || die
+}
+
+src_install() {
+ exeinto /usr/$(get_libdir)/alsa-lib
+ doexe *.so || die
+ dodoc README || die
+}