summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2012-08-06 15:34:30 +0000
committerThomas Beierlein <tomjbe@gentoo.org>2012-08-06 15:34:30 +0000
commitde8112fac84d26d91d47d666dbbd8bb36d7833cb (patch)
treee3d452f0a8dbb328319b056e01105849fb93b69f /media-radio/unixcw
parentPackage moved from net-wireless to sys-firmware, bug 429868. (diff)
downloadgentoo-2-de8112fac84d26d91d47d666dbbd8bb36d7833cb.tar.gz
gentoo-2-de8112fac84d26d91d47d666dbbd8bb36d7833cb.tar.bz2
gentoo-2-de8112fac84d26d91d47d666dbbd8bb36d7833cb.zip
Version bump
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'media-radio/unixcw')
-rw-r--r--media-radio/unixcw/ChangeLog8
-rw-r--r--media-radio/unixcw/files/unixcw-3.1.1-config.patch103
-rw-r--r--media-radio/unixcw/unixcw-3.1.1.ebuild73
3 files changed, 183 insertions, 1 deletions
diff --git a/media-radio/unixcw/ChangeLog b/media-radio/unixcw/ChangeLog
index d58cf3e12bcf..b0e6019674dc 100644
--- a/media-radio/unixcw/ChangeLog
+++ b/media-radio/unixcw/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-radio/unixcw
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-radio/unixcw/ChangeLog,v 1.6 2012/06/21 06:11:00 tomjbe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-radio/unixcw/ChangeLog,v 1.7 2012/08/06 15:34:30 tomjbe Exp $
+
+*unixcw-3.1.1 (06 Aug 2012)
+
+ 06 Aug 2012; Thomas Beierlein <tomjbe@gentoo.org> +unixcw-3.1.1.ebuild,
+ +files/unixcw-3.1.1-config.patch:
+ Version bump
*unixcw-3.0.2 (21 Jun 2012)
diff --git a/media-radio/unixcw/files/unixcw-3.1.1-config.patch b/media-radio/unixcw/files/unixcw-3.1.1-config.patch
new file mode 100644
index 000000000000..4e81e3ac75cd
--- /dev/null
+++ b/media-radio/unixcw/files/unixcw-3.1.1-config.patch
@@ -0,0 +1,103 @@
+# Fix wrong conditional logic
+--- configure.ac.orig 2012-08-05 18:19:57.000000000 +0200
++++ configure.ac 2012-08-06 17:20:50.000000000 +0200
+@@ -101,11 +101,11 @@
+
+ # disable_alsa - 'no' by default
+ AC_ARG_ENABLE(alsa,
+- AS_HELP_STRING([--disable-alsa], [disable support for ALSA audio output]),
+- [disable_alsa=yes],
+- [disable_alsa=no])
++ AS_HELP_STRING([--enable-alsa], [enable support for ALSA audio output]),
++ [enable_alsa=$enableval],
++ [enable_alsa=yes])
+ AC_MSG_CHECKING([whether to include ALSA audio support])
+-if test "$disable_alsa" = "no" ; then
++if test "$enable_alsa" = "yes" ; then
+ AC_MSG_RESULT(yes)
+ else
+ AC_MSG_RESULT(no)
+@@ -114,11 +114,11 @@
+
+ # disable_pulseaudio - 'no' by default
+ AC_ARG_ENABLE(pulseaudio,
+- AS_HELP_STRING([--disable-pulseaudio], [disable support for PulseAudio audio output]),
+- [disable_pulseaudio=yes],
+- [disable_pulseaudio=no])
++ AS_HELP_STRING([--enable-pulseaudio], [enable support for PulseAudio audio output]),
++ [enable_pulseaudio=$enableval],
++ [enable_pulseaudio=yes])
+ AC_MSG_CHECKING([whether to include PulseAudio audio support])
+-if test "$disable_pulseaudio" = "no" ; then
++if test "$enable_pulseaudio" = "yes" ; then
+ AC_MSG_RESULT(yes)
+ else
+ AC_MSG_RESULT(no)
+@@ -127,11 +127,11 @@
+
+ # disable_cwcp - 'no' by default
+ AC_ARG_ENABLE(cwcp,
+- AS_HELP_STRING([--disable-cwcp], [do not build cwcp (application with curses user interface)]),
+- [disable_cwcp=yes],
+- [disable_cwcp=no])
++ AS_HELP_STRING([--enable-cwcp], [build cwcp (application with curses user interface)]),
++ [enable_cwcp=$enableval],
++ [enable_cwcp=yes])
+ AC_MSG_CHECKING([whether to build cwcp])
+-if test "$disable_cwcp" = "no" ; then
++if test "$enable_cwcp" = "yes" ; then
+ AC_MSG_RESULT(yes)
+ else
+ AC_MSG_RESULT(no)
+@@ -140,11 +140,11 @@
+
+ # disable_xcwcp - 'no' by default
+ AC_ARG_ENABLE(xcwcp,
+- AS_HELP_STRING([--disable-xcwcp], [do not build xcwcp (application with Qt4 user interface)]),
+- [disable_xcwcp=yes],
+- [disable_xcwcp=no])
++ AS_HELP_STRING([--enable-xcwcp], [build xcwcp (application with Qt4 user interface)]),
++ [disable_xcwcp=$enableval],
++ [disable_xcwcp=yes])
+ AC_MSG_CHECKING([whether to build xcwcp])
+-if test "$disable_xcwcp" = "no" ; then
++if test "$disable_xcwcp" = "yes" ; then
+ AC_MSG_RESULT(yes)
+ else
+ AC_MSG_RESULT(no)
+@@ -219,7 +219,7 @@
+
+
+
+-if test "$disable_alsa" = "yes" ; then
++if test "$enable_alsa" = "no" ; then
+ WITH_ALSA='no'
+ else
+ AC_CHECK_LIB(asound, snd_pcm_open)
+@@ -246,7 +246,7 @@
+
+
+
+-if test "$disable_pulseaudio" = "yes" ; then
++if test "$enable_pulseaudio" = "no" ; then
+ WITH_PULSEAUDIO='no'
+ else
+ AC_CHECK_LIB(pulse-simple, pa_simple_new)
+@@ -265,7 +265,7 @@
+
+
+
+-if test "$disable_cwcp" = "yes" ; then
++if test "$enable_cwcp" = "no" ; then
+ WITH_CWCP='no'
+ else
+ AC_CHECK_LIB(curses, initscr)
+@@ -279,7 +279,7 @@
+
+
+
+-if test "$disable_xcwcp" = "yes" ; then
++if test "$enable_xcwcp" = "no" ; then
+ WITH_XCWCP='no'
+ else
+ # autodetection of Qt4 dependencies
diff --git a/media-radio/unixcw/unixcw-3.1.1.ebuild b/media-radio/unixcw/unixcw-3.1.1.ebuild
new file mode 100644
index 000000000000..210b5cc6d4cb
--- /dev/null
+++ b/media-radio/unixcw/unixcw-3.1.1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-radio/unixcw/unixcw-3.1.1.ebuild,v 1.1 2012/08/06 15:34:30 tomjbe Exp $
+
+EAPI=4
+
+inherit autotools eutils flag-o-matic multilib
+
+DESCRIPTION="A package of programs that fit together to form a morse code tutor program."
+HOMEPAGE="http://unixcw.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE="alsa ncurses pulseaudio suid qt4"
+
+RDEPEND="ncurses? ( sys-libs/ncurses )
+ qt4? ( x11-libs/qt-gui:4[qt3support] )
+ alsa? ( media-libs/alsa-lib )
+ pulseaudio? ( media-sound/pulseaudio )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ sys-devel/libtool
+ !<=app-misc/cw-1.0.16-r1"
+
+src_prepare() {
+ append-cflags -std=gnu99
+ epatch \
+ "${FILESDIR}"/${P}-config.patch
+ # add path to qt4 libs
+ sed -i -e "s#LDADD = -L#LDADD = -L/usr/$(get_libdir)/qt4 -L#g" \
+ src/xcwcp/Makefile.am
+ eautoreconf
+}
+
+src_configure() {
+ econf --libdir=/usr/$(get_libdir) \
+ $(use_enable pulseaudio ) \
+ $(use_enable alsa ) \
+ $(use_enable ncurses cwcp ) \
+ $(use_enable qt4 xcwcp )
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc ChangeLog NEWS README
+ if ! use suid ; then
+ fperms 711 /usr/bin/cw
+ if use ncurses ; then
+ fperms 711 /usr/bin/cwcp
+ fi
+ if use qt4 ; then
+ fperms 711 /usr/bin/xcwcp
+ fi
+ fi
+}
+
+pkg_postinst() {
+ if use suid ; then
+ ewarn "You have choosen to install 'cw', 'cwcp' and 'xcwcp' setuid"
+ ewarn "by setting USE=suid."
+ ewarn "Be aware that this is a security risk and not recommended."
+ ewarn ""
+ ewarn "These files do only need root access if you want to use the"
+ ewarn "PC speaker for morse sidetone output. You can alternativly"
+ ewarn "drop USE=suid and use sudo."
+ else
+ elog "Be aware that 'cw', 'cwcp' and 'xcwcp' needs root access if"
+ elog "you want to use the PC speaker for morse sidetone output."
+ elog "You can call the programs via sudo for that (see 'man sudo')."
+ fi
+}