summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2010-12-11 11:49:08 +0000
committerThomas Beierlein <tomjbe@gentoo.org>2010-12-11 11:49:08 +0000
commit7921614e3c6b4f65e21dda2245003db7ecc27fb8 (patch)
tree2076916a870a539f769d314fe8b3256dc9c9e6b1 /media-radio
parentVersion bump. (diff)
downloadgentoo-2-7921614e3c6b4f65e21dda2245003db7ecc27fb8.tar.gz
gentoo-2-7921614e3c6b4f65e21dda2245003db7ecc27fb8.tar.bz2
gentoo-2-7921614e3c6b4f65e21dda2245003db7ecc27fb8.zip
Fix bug #347241. Thanks Gary <gem@rellim.com> for reporting.
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'media-radio')
-rw-r--r--media-radio/xastir/ChangeLog8
-rw-r--r--media-radio/xastir/metadata.xml2
-rw-r--r--media-radio/xastir/xastir-2.0.0-r1.ebuild81
3 files changed, 90 insertions, 1 deletions
diff --git a/media-radio/xastir/ChangeLog b/media-radio/xastir/ChangeLog
index aaa8e6a34df7..338977f51a6a 100644
--- a/media-radio/xastir/ChangeLog
+++ b/media-radio/xastir/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-radio/xastir
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-radio/xastir/ChangeLog,v 1.16 2010/11/21 08:23:01 tomjbe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-radio/xastir/ChangeLog,v 1.17 2010/12/11 11:49:08 tomjbe Exp $
+
+*xastir-2.0.0-r1 (11 Dec 2010)
+
+ 11 Dec 2010; Thomas Beierlein <tomjbe@gentoo.org> +xastir-2.0.0-r1.ebuild,
+ metadata.xml:
+ Fix bug #347241. Thanks Gary <gem@rellim.com> for reporting.
*xastir-2.0.0 (21 Nov 2010)
diff --git a/media-radio/xastir/metadata.xml b/media-radio/xastir/metadata.xml
index 36b7b07da984..6feda0c5e4c3 100644
--- a/media-radio/xastir/metadata.xml
+++ b/media-radio/xastir/metadata.xml
@@ -11,5 +11,7 @@
<flag name='gdal'>Support for some further map formats</flag>
<flag name='geotiff'>Install geotiff support. Allows using USGS DRG topo
maps or other types of geotiff mapes/images</flag>
+ <flag name='graphicsmagick'>Use graphicsmagick instead imagemagick for
+ rendering</flag>
</use>
</pkgmetadata>
diff --git a/media-radio/xastir/xastir-2.0.0-r1.ebuild b/media-radio/xastir/xastir-2.0.0-r1.ebuild
new file mode 100644
index 000000000000..acd34b9e09f3
--- /dev/null
+++ b/media-radio/xastir/xastir-2.0.0-r1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-radio/xastir/xastir-2.0.0-r1.ebuild,v 1.1 2010/12/11 11:49:08 tomjbe Exp $
+
+EAPI=2
+inherit autotools eutils multilib
+
+DESCRIPTION="X Amateur Station Tracking and Information Reporting"
+HOMEPAGE="http://xastir.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="festival gdal geotiff graphicsmagick"
+
+DEPEND=">=x11-libs/openmotif-2.3:0
+ x11-libs/libXpm
+ x11-apps/xfontsel
+ dev-libs/libpcre
+ net-misc/curl
+ sys-libs/db
+ sci-libs/shapelib
+ !graphicsmagick? ( media-gfx/imagemagick[-hdri,-q32] )
+ graphicsmagick? ( media-gfx/graphicsmagick[-q32] )
+ geotiff? ( sci-libs/proj
+ sci-libs/libgeotiff
+ media-libs/tiff )
+ gdal? ( sci-libs/gdal )
+ festival? ( app-accessibility/festival )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # fix hardcoded /usr/local paths in scripts
+ epatch "${FILESDIR}"/${PN}-1.9.8-scripts.diff
+ # and patch libdir
+ for f in scripts/permutations.pl scripts/test_coord.pl \
+ scripts/toporama250k.pl scripts/toporama50k.pl; do
+ sed -i -e "s:/usr/lib:/usr/$(get_libdir):g" "${f}" \
+ || die "sed failed on ${f}"
+ done
+
+ # fix __FORTIFY_SOURCE warning (bug #337365)
+ epatch "${FILESDIR}"/${PN}-1.9.8-fortify.diff
+
+ # fix for DESTDIR
+ epatch "${FILESDIR}"/${P}-Destdir.diff
+
+ eautoreconf
+}
+
+src_configure() {
+ econf --without-graphicsmagick \
+ --with-pcre \
+ --with-shapelib \
+ --with-dbfawk \
+ --without-ax25 \
+ --without-gpsman \
+ $(use_with !graphicsmagick imagemagick) \
+ $(use_with graphicsmagick) \
+ $(use_with geotiff libproj) \
+ $(use_with geotiff) \
+ $(use_with gdal) \
+ $(use_with festival)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ rm -rf "${D}"/usr/share/doc/${PN}
+ dodoc AUTHORS ChangeLog FAQ README README.Contributing \
+ README.Getting-Started README.MAPS || die "dodoc failed"
+}
+
+pkg_postinst() {
+ elog "Kernel mode AX.25 and GPSman library not supported."
+ elog
+ elog "Remember you have to be root to add addditional scripts,"
+ elog "maps and other configuration data under /usr/share/xastir"
+ elog "and /usr/$(get_libdir)/xastir."
+}