summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn J. Ellis <jje@gentoo.org>2003-09-28 10:17:17 +0000
committerJohn J. Ellis <jje@gentoo.org>2003-09-28 10:17:17 +0000
commit354be1c518bd649d28741b160978cf29b780a4c1 (patch)
tree24075d3d94aff7a414c386dc209dd6f6a6157c00 /media-sound/SphinxTrain/SphinxTrain-0.9.1-r1.ebuild
parentPatched for gcc 3.3, closes #29461. (diff)
downloadgentoo-2-354be1c518bd649d28741b160978cf29b780a4c1.tar.gz
gentoo-2-354be1c518bd649d28741b160978cf29b780a4c1.tar.bz2
gentoo-2-354be1c518bd649d28741b160978cf29b780a4c1.zip
Patched for gcc 3.3, closes #29461.
Diffstat (limited to 'media-sound/SphinxTrain/SphinxTrain-0.9.1-r1.ebuild')
-rw-r--r--media-sound/SphinxTrain/SphinxTrain-0.9.1-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/media-sound/SphinxTrain/SphinxTrain-0.9.1-r1.ebuild b/media-sound/SphinxTrain/SphinxTrain-0.9.1-r1.ebuild
new file mode 100644
index 000000000000..f627c6ee81b3
--- /dev/null
+++ b/media-sound/SphinxTrain/SphinxTrain-0.9.1-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/SphinxTrain/SphinxTrain-0.9.1-r1.ebuild,v 1.1 2003/09/28 10:17:13 jje Exp $
+
+S=${WORKDIR}/${PN}
+DESCRIPTION="SphinxTrain - Speech Recognition (Training Module)"
+HOMEPAGE="http://www.speech.cs.cmu.edu/SphinxTrain/"
+SRC_URI="http://www.speech.cs.cmu.edu/${PN}/${P}-beta.tar.gz"
+SLOT="0"
+LICENSE="BSD as-is"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="virtual/glibc
+ media-sound/sphinx2
+ media-sound/festival"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/gcc.patch
+}
+
+src_compile() {
+ econf || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+ dodoc etc/*cfg
+ dobin bin.*/*
+ dodoc README
+ dohtml doc/*[txt html sgml]
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Detailed usage and training instructions can be found at"
+ einfo "http://www.speech.cs.cmu.edu/SphinxTrain/"
+ einfo
+}