summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-05-13 07:31:46 +0000
committerTim Harder <radhermit@gentoo.org>2013-05-13 07:31:46 +0000
commit3e7cb7ceb066031f93a5a2e74ed224578803f150 (patch)
treed7f095c109abe0098711337a49d48475093e8d5e /media-sound/abcmidi
parentVersion bump. (diff)
downloadgentoo-2-3e7cb7ceb066031f93a5a2e74ed224578803f150.tar.gz
gentoo-2-3e7cb7ceb066031f93a5a2e74ed224578803f150.tar.bz2
gentoo-2-3e7cb7ceb066031f93a5a2e74ed224578803f150.zip
Version bump.
(Portage version: 2.2.0_alpha174/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'media-sound/abcmidi')
-rw-r--r--media-sound/abcmidi/ChangeLog7
-rw-r--r--media-sound/abcmidi/abcmidi-2013.05.10.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/media-sound/abcmidi/ChangeLog b/media-sound/abcmidi/ChangeLog
index 19db7e0faf8b..2c7e2ffc1c51 100644
--- a/media-sound/abcmidi/ChangeLog
+++ b/media-sound/abcmidi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/abcmidi
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/abcmidi/ChangeLog,v 1.36 2013/05/08 09:58:13 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/abcmidi/ChangeLog,v 1.37 2013/05/13 07:31:46 radhermit Exp $
+
+*abcmidi-2013.05.10 (13 May 2013)
+
+ 13 May 2013; Tim Harder <radhermit@gentoo.org> +abcmidi-2013.05.10.ebuild:
+ Version bump.
*abcmidi-2013.05.07 (08 May 2013)
diff --git a/media-sound/abcmidi/abcmidi-2013.05.10.ebuild b/media-sound/abcmidi/abcmidi-2013.05.10.ebuild
new file mode 100644
index 000000000000..c6872c521d99
--- /dev/null
+++ b/media-sound/abcmidi/abcmidi-2013.05.10.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/abcmidi/abcmidi-2013.05.10.ebuild,v 1.1 2013/05/13 07:31:46 radhermit Exp $
+
+EAPI=5
+
+inherit eutils versionator autotools
+
+MY_P="abcMIDI-$(replace_all_version_separators '-')"
+DESCRIPTION="Programs for processing ABC music notation files"
+HOMEPAGE="http://abc.sourceforge.net/abcMIDI/"
+SRC_URI="http://ifdo.pugmarks.com/~seymour/runabc/${MY_P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2011.10.19-install.patch
+ rm configure makefile || die
+ sed -i -e "s:-O2::" configure.ac || die
+ eautoreconf
+}
+
+src_install() {
+ default
+ dodoc doc/{AUTHORS,CHANGES,abcguide.txt,abcmatch.txt,history.txt,readme.txt,yapshelp.txt}
+
+ if use examples ; then
+ docinto examples
+ dodoc samples/*.abc
+ fi
+}