summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-01-10 12:56:29 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-01-10 12:56:29 +0000
commit6551106ce5cd9b750b5fe60fc0481e4118885f2f (patch)
tree4fd3cf43bf719dfdbfaa04f7a897c48df040867b /media-sound/alsa-driver
parentApply last changes from 1.0.10 to 1.0.11_rc2. (diff)
downloadgentoo-2-6551106ce5cd9b750b5fe60fc0481e4118885f2f.tar.gz
gentoo-2-6551106ce5cd9b750b5fe60fc0481e4118885f2f.tar.bz2
gentoo-2-6551106ce5cd9b750b5fe60fc0481e4118885f2f.zip
Drop ALSA 1.0.11_rc1 packages.
(Portage version: 2529-svn)
Diffstat (limited to 'media-sound/alsa-driver')
-rw-r--r--media-sound/alsa-driver/ChangeLog6
-rw-r--r--media-sound/alsa-driver/alsa-driver-1.0.11_rc1.ebuild163
-rw-r--r--media-sound/alsa-driver/files/alsa-driver-1.0.11_rc1-ppc.patch40
-rw-r--r--media-sound/alsa-driver/files/digest-alsa-driver-1.0.11_rc11
4 files changed, 5 insertions, 205 deletions
diff --git a/media-sound/alsa-driver/ChangeLog b/media-sound/alsa-driver/ChangeLog
index d502c6cdda68..27d591ccdb8a 100644
--- a/media-sound/alsa-driver/ChangeLog
+++ b/media-sound/alsa-driver/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/alsa-driver
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/ChangeLog,v 1.183 2006/01/10 12:45:39 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/ChangeLog,v 1.184 2006/01/10 12:54:23 flameeyes Exp $
+
+ 10 Jan 2006; Diego Pettenò <flameeyes@gentoo.org>
+ -files/alsa-driver-1.0.11_rc1-ppc.patch, -alsa-driver-1.0.11_rc1.ebuild:
+ Drop ALSA 1.0.11_rc1 packages.
10 Jan 2006; Diego Pettenò <flameeyes@gentoo.org>
alsa-driver-1.0.11_rc2.ebuild:
diff --git a/media-sound/alsa-driver/alsa-driver-1.0.11_rc1.ebuild b/media-sound/alsa-driver/alsa-driver-1.0.11_rc1.ebuild
deleted file mode 100644
index 7afcff50987b..000000000000
--- a/media-sound/alsa-driver/alsa-driver-1.0.11_rc1.ebuild
+++ /dev/null
@@ -1,163 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-1.0.11_rc1.ebuild,v 1.2 2005/12/22 01:15:01 flameeyes Exp $
-
-inherit linux-mod flag-o-matic eutils
-
-MY_P="${P/_rc/rc}"
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="Advanced Linux Sound Architecture kernel modules"
-HOMEPAGE="http://www.alsa-project.org/"
-SRC_URI="mirror://alsaproject/driver/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0"
-
-KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~ppc64 ~x86"
-IUSE="oss doc"
-
-RDEPEND="virtual/modutils
- ~media-sound/alsa-headers-${PV}"
-DEPEND="${RDEPEND}
- virtual/linux-sources
- sparc? ( >=sys-devel/autoconf-2.50 )
- sys-apps/debianutils"
-
-PROVIDE="virtual/alsa"
-
-pkg_setup() {
- # By default, drivers for all supported cards will be compiled.
- # If you want to only compile for specific card(s), set ALSA_CARDS
- # environment to a space-separated list of drivers that you want to build.
- # For example:
- #
- # env ALSA_CARDS='emu10k1 intel8x0 ens1370' emerge alsa-driver
- #
- ALSA_CARDS=${ALSA_CARDS:-all}
-
- # Which drivers need PNP
- local PNP_DRIVERS="interwave interwave-stb"
-
- CONFIG_CHECK="SOUND"
- SND_ERROR="ALSA is already compiled into the kernel."
- SOUND_ERROR="Your kernel doesn't have sound support enabled."
- SOUND_PRIME_ERROR="Your kernel is configured to use the deprecated OSS drivers. Please disable them and re-emerge alsa-driver."
- PNP_ERROR="Some of the drivers you selected require PNP in your kernel (${PNP_DRIVERS}). Either enable PNP in your kernel or trim which drivers get compiled using ALSA_CARDS in /etc/make.conf."
-
- if [[ "${ALSA_CARDS}" == "all" ]]; then
-
- # Ignore PNP checks for ppc architecture, as PNP can't be enabled there.
- if [[ ${ARCH} != "ppc" ]]; then
- CONFIG_CHECK="${CONFIG_CHECK} PNP"
- fi
- else
- for pnpdriver in ${PNP_DRIVERS}; do
- hasq ${pnpdriver} ${ALSA_CARDS} && CONFIG_CHECK="${CONFIG_CHECK} PNP"
- done
- fi
-
- linux-mod_pkg_setup
-
- if [[ ${PROFILE_ARCH} == "sparc64" ]] ; then
- CBUILD=${CBUILD-${CHOST}}
- CHOST="sparc64-unknown-linux-gnu"
- fi
-}
-
-src_unpack() {
- unpack ${A}
-
- cd ${S}
-
- epatch "${FILESDIR}"/${PN}-1.0.10_rc1-include.patch
- epatch "${FILESDIR}/${P}-ppc.patch"
-
- convert_to_m ${S}/Makefile
- sed -i -e 's:\(.*depmod\):#\1:' ${S}/Makefile
-}
-
-src_compile() {
- # Should fix bug #46901
- is-flag "-malign-double" && filter-flags "-fomit-frame-pointer"
- append-flags "-I${KV_DIR}/arch/$(tc-arch-kernel)/include"
-
- econf $(use_with oss) \
- --with-kernel="${KV_DIR}" \
- --with-build="${KV_OUT_DIR}" \
- --with-isapnp=yes \
- --with-sequencer=yes \
- --with-cards="${ALSA_CARDS}" || die "econf failed"
-
- # linux-mod_src_compile doesn't work well with alsa
-
- ARCH=$(tc-arch-kernel)
- # -j1 : see bug #71028
- emake -j1 HOSTCC=$(tc-getBUILD_CC) CC=$(tc-getCC) || die "Make Failed"
- ARCH=$(tc-arch)
-
- if use doc;
- then
- ebegin "Building Documentation"
- cd ${S}/scripts
- emake || die Failed making docs in ${S}/scripts
-
- cd ${S}/doc/DocBook
- emake || die Failed making docs in ${S}/doc/DocBook
- eend $?
- fi
-}
-
-
-src_install() {
- make DESTDIR=${D} install-modules || die "make install failed"
-
- dodoc CARDS-STATUS FAQ README WARNING TODO
-
- if use doc; then
- docinto doc
- dodoc doc/*
- rm ${D}/usr/share/doc/${PF}/doc/Makefile.gz
-
- docinto DocBook
- dodoc doc/DocBook/*
- rm ${D}/usr/share/doc/${PF}/DocBook/Makefile.gz
-
- docinto Documentation
- dodoc sound/Documentation/*
- fi
-
- if kernel_is 2 6; then
- # mv the drivers somewhere they won't be killed by the kernel's make modules_install
- mv ${D}/lib/modules/${KV_FULL}/kernel/sound ${D}/lib/modules/${KV_FULL}/${PN}
- rmdir ${D}/lib/modules/${KV_FULL}/kernel &> /dev/null
- fi
-}
-
-pkg_postinst() {
- einfo
- einfo "The alsasound initscript and modules.d/alsa have now moved to alsa-utils"
- einfo
- einfo "Also, remember that all mixer channels will be MUTED by default."
- einfo "Use the 'alsamixer' program to unmute them."
- einfo
- einfo "Version 1.0.3 and above should work with version 2.6 kernels."
- einfo "If you experience problems, please report bugs to http://bugs.gentoo.org."
- einfo
-
- linux-mod_pkg_postinst
-
- einfo "Check out the ALSA installation guide availible at the following URL:"
- einfo "http://www.gentoo.org/doc/en/alsa-guide.xml"
-
- if kernel_is 2 6 && [ -e ${ROOT}/lib/modules/${KV_FULL}/kernel/sound ]; then
- # Cleanup if they had older alsa installed
- for file in $(find ${ROOT}/lib/modules/${KV_FULL}/${PN} -type f); do
- rm -f ${file//${KV_FULL}\/${PN}/${KV_FULL}\/kernel\/sound}
- done
-
- for dir in $(find ${ROOT}/lib/modules/${KV_FULL}/kernel/sound -type d | tac); do
- rmdir ${dir} &> /dev/null
- done
- fi
-}
diff --git a/media-sound/alsa-driver/files/alsa-driver-1.0.11_rc1-ppc.patch b/media-sound/alsa-driver/files/alsa-driver-1.0.11_rc1-ppc.patch
deleted file mode 100644
index f33f9b1325dc..000000000000
--- a/media-sound/alsa-driver/files/alsa-driver-1.0.11_rc1-ppc.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-Index: alsa-driver-1.0.11rc1/ppc/tumbler.patch
-===================================================================
---- alsa-driver-1.0.11rc1.orig/ppc/tumbler.patch
-+++ alsa-driver-1.0.11rc1/ppc/tumbler.patch
-@@ -15,21 +15,21 @@
- static struct work_struct device_change;
- +#endif
-
-- static void
-- device_change_handler(void *self)
--@@ -895,7 +900,11 @@
--
-- /* finally we need to schedule an update of the mixer values
-- (master and DRC are enough for now) -ReneR */
-+ static void device_change_handler(void *self)
-+ {
-+@@ -1009,7 +1014,11 @@
-+ mix = chip->mixer_data;
-+ snd_assert(mix, return);
-+ mix->auto_mute_notify = do_notify;
- +#if LINUX_VERSION_CODE < KERNEL_VERSION(2,5,0)
- + schedule_task(&device_change);
- +#else
- schedule_work(&device_change);
- +#endif
--
- }
- }
--@@ -1156,7 +1165,11 @@
-+ #endif /* PMAC_SUPPORT_AUTOMUTE */
-+@@ -1416,7 +1425,11 @@
- chip->resume = tumbler_resume;
- #endif
-
-@@ -40,4 +40,4 @@
- +#endif
-
- #ifdef PMAC_SUPPORT_AUTOMUTE
-- if (mix->headphone_irq >=0 && (err = snd_pmac_add_automute(chip)) < 0)
-+ if ((mix->headphone_irq >=0 || mix->lineout_irq >= 0)
diff --git a/media-sound/alsa-driver/files/digest-alsa-driver-1.0.11_rc1 b/media-sound/alsa-driver/files/digest-alsa-driver-1.0.11_rc1
deleted file mode 100644
index 8f5997aa7433..000000000000
--- a/media-sound/alsa-driver/files/digest-alsa-driver-1.0.11_rc1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 3972451d7ae38965e0d03d48daf9f77a alsa-driver-1.0.11rc1.tar.bz2 2275581