summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-09-30 13:43:06 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-09-30 13:43:06 +0000
commite49b9e830ba96ac503d8b832e3d8ba842d0e3d3f (patch)
tree34906a30d984df49c64b94c208ec555cf12efd93 /media-sound/alsa-utils
parentVersion bump. (diff)
downloadgentoo-2-e49b9e830ba96ac503d8b832e3d8ba842d0e3d3f.tar.gz
gentoo-2-e49b9e830ba96ac503d8b832e3d8ba842d0e3d3f.tar.bz2
gentoo-2-e49b9e830ba96ac503d8b832e3d8ba842d0e3d3f.zip
Version bump.
(Portage version: 2.1.2_pre2)
Diffstat (limited to 'media-sound/alsa-utils')
-rw-r--r--media-sound/alsa-utils/ChangeLog8
-rw-r--r--media-sound/alsa-utils/alsa-utils-1.0.13.ebuild84
-rw-r--r--media-sound/alsa-utils/files/digest-alsa-utils-1.0.133
3 files changed, 94 insertions, 1 deletions
diff --git a/media-sound/alsa-utils/ChangeLog b/media-sound/alsa-utils/ChangeLog
index 63b3dca97123..2e89dd0bb147 100644
--- a/media-sound/alsa-utils/ChangeLog
+++ b/media-sound/alsa-utils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/alsa-utils
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/ChangeLog,v 1.159 2006/09/28 06:57:12 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/ChangeLog,v 1.160 2006/09/30 13:43:06 flameeyes Exp $
+
+*alsa-utils-1.0.13 (30 Sep 2006)
+
+ 30 Sep 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +alsa-utils-1.0.13.ebuild:
+ Version bump.
*alsa-utils-1.0.13_rc3 (28 Sep 2006)
diff --git a/media-sound/alsa-utils/alsa-utils-1.0.13.ebuild b/media-sound/alsa-utils/alsa-utils-1.0.13.ebuild
new file mode 100644
index 000000000000..8cdc6931a8bc
--- /dev/null
+++ b/media-sound/alsa-utils/alsa-utils-1.0.13.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/alsa-utils-1.0.13.ebuild,v 1.1 2006/09/30 13:43:06 flameeyes Exp $
+
+inherit eutils autotools
+
+MY_P="${P/_rc/rc}"
+
+DESCRIPTION="Advanced Linux Sound Architecture Utils (alsactl, alsamixer, etc.)"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/utils/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0.9"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="nls"
+
+DEPEND=">=sys-libs/ncurses-5.1
+ dev-util/dialog
+ >=media-libs/alsa-lib-1.0.12"
+RDEPEND="${DEPEND}
+ sys-apps/pciutils"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${PN}-1.0.11_rc2-nls.patch"
+ epatch "${FILESDIR}/${PN}-1.0.11_rc5-alsaconf-redirect.patch"
+}
+
+src_compile() {
+ econf \
+ $(use_enable nls) \
+ || die "configure failed"
+
+ emake || die "make failed"
+}
+
+src_install() {
+ local ALSA_UTILS_DOCS="ChangeLog README TODO
+ seq/aconnect/README.aconnect
+ seq/aseqnet/README.aseqnet"
+
+ emake DESTDIR="${D}" install || die "Installation Failed"
+
+ dodoc ${ALSA_UTILS_DOCS}
+ newdoc alsamixer/README README.alsamixer
+
+ newconfd "${FILESDIR}/alsasound.confd" alsasound
+ insinto /etc/modules.d
+ newins "${FILESDIR}/alsa-modules.conf-rc" alsa
+ newinitd "${FILESDIR}/alsasound-1.0.10_rc2" alsasound
+}
+
+pkg_postinst() {
+ echo
+ einfo "The alsasound initscript is now provided by alsa-utils"
+ einfo "instead of alsa-driver for compatibility with kernel-sources"
+ einfo "which provide ALSA internally."
+ echo
+ einfo "To take advantage of this, and automate the process of"
+ einfo "loading and unloading the ALSA sound drivers as well as"
+ einfo "storing and restoring sound-card mixer levels you should"
+ einfo "add alsasound to the boot runlevel. You can do this as"
+ einfo "root like so:"
+ einfo " # rc-update add alsasound boot"
+ echo
+ einfo "You will also need to edit the file /etc/modules.d/alsa"
+ einfo "and run modules-update. You can do this like so:"
+ einfo " # nano -w /etc/modules.d/alsa && modules-update"
+ echo
+
+ if use sparc; then
+ ewarn "Old versions of alsa-drivers had a broken snd-ioctl32 module"
+ ewarn "which causes sparc64 machines to lockup on such tasks as"
+ ewarn "changing the volume. Because of this, it is VERY important"
+ ewarn "that you do not use the snd-ioctl32 modules contained in"
+ ewarn "development-sources or <=gentoo-dev-sources-2.6.7-r14. Doing so"
+ ewarn "may result in an unbootable system if you start alsasound at boot."
+ fi
+}
diff --git a/media-sound/alsa-utils/files/digest-alsa-utils-1.0.13 b/media-sound/alsa-utils/files/digest-alsa-utils-1.0.13
new file mode 100644
index 000000000000..9000baa0be91
--- /dev/null
+++ b/media-sound/alsa-utils/files/digest-alsa-utils-1.0.13
@@ -0,0 +1,3 @@
+MD5 dfe4bb5d3217f3ec662b172ce8397cf0 alsa-utils-1.0.13.tar.bz2 980874
+RMD160 2a3cd882543232f81e211d216c9e8112da3f8977 alsa-utils-1.0.13.tar.bz2 980874
+SHA256 d7fe8a7995bc74331c89fbc1937a0682d239339d6659a402cd7b8e4b96c050f0 alsa-utils-1.0.13.tar.bz2 980874