summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Hood <squinky86@gentoo.org>2004-05-22 15:20:19 +0000
committerJon Hood <squinky86@gentoo.org>2004-05-22 15:20:19 +0000
commitaafedc997a16bad19c45e57df2989b35864ed843 (patch)
tree8c3b801aa3750d97d61a6c3eb144d374893ce8c0 /media-sound/amarok/amarok-1.0_beta3.ebuild
parentadded CA open source licenese (diff)
downloadgentoo-2-aafedc997a16bad19c45e57df2989b35864ed843.tar.gz
gentoo-2-aafedc997a16bad19c45e57df2989b35864ed843.tar.bz2
gentoo-2-aafedc997a16bad19c45e57df2989b35864ed843.zip
version bump, closes #51133
Diffstat (limited to 'media-sound/amarok/amarok-1.0_beta3.ebuild')
-rw-r--r--media-sound/amarok/amarok-1.0_beta3.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/media-sound/amarok/amarok-1.0_beta3.ebuild b/media-sound/amarok/amarok-1.0_beta3.ebuild
new file mode 100644
index 000000000000..4ea9857c6df0
--- /dev/null
+++ b/media-sound/amarok/amarok-1.0_beta3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/amarok-1.0_beta3.ebuild,v 1.1 2004/05/22 15:20:19 squinky86 Exp $
+
+inherit kde
+
+MY_P="${P/_beta/-beta}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="amaroK is a media player for KDE"
+HOMEPAGE="http://amarok.sourceforge.net/"
+SRC_URI="mirror://sourceforge/amarok/${MY_P}.tar.bz2"
+RESTRICT="nomirror"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE="gstreamer xmms arts opengl"
+
+DEPEND=">=kde-base/kdemultimedia-3.2
+ gstreamer? ( >=media-libs/gst-plugins-0.8.0 )
+ opengl? ( virtual/opengl )
+ xmms? ( >=media-sound/xmms-1.2 )
+ >=dev-util/pkgconfig-0.9.0
+ >=media-libs/taglib-0.95"
+
+need-kde 3.2
+
+src_unpack() {
+ if ! use arts && ! use gstreamer
+ then
+ die "You must enable either Arts or Gstreamer"
+ fi
+
+ kde_src_unpack
+}
+
+src_compile() {
+ PREFIX="`kde-config --prefix`"
+ myconf="`use_with arts` `use_with gstreamer` `use_with opengl`"
+
+ kde_src_compile myconf configure make || die
+}