summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2009-11-14 15:20:31 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2009-11-14 15:20:31 +0000
commit1be9e37f9975a2ef1f6d6170fa1f786df722fd9d (patch)
tree389054937f607fb208628d9facb4a3d5a19f4120 /media-sound/amarok
parentsparc stable wrt #286844 (diff)
downloadgentoo-2-1be9e37f9975a2ef1f6d6170fa1f786df722fd9d.tar.gz
gentoo-2-1be9e37f9975a2ef1f6d6170fa1f786df722fd9d.tar.bz2
gentoo-2-1be9e37f9975a2ef1f6d6170fa1f786df722fd9d.zip
after a long time, fix qtscript check, bug 270923, kde bug 189367
(Portage version: 2.2_rc49/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/amarok')
-rw-r--r--media-sound/amarok/ChangeLog6
-rw-r--r--media-sound/amarok/amarok-2.2.0.ebuild4
-rw-r--r--media-sound/amarok/amarok-2.2.1.ebuild4
-rw-r--r--media-sound/amarok/files/amarok-qtscriptcheck.patch24
4 files changed, 33 insertions, 5 deletions
diff --git a/media-sound/amarok/ChangeLog b/media-sound/amarok/ChangeLog
index 130971c4f147..4719a2c67d43 100644
--- a/media-sound/amarok/ChangeLog
+++ b/media-sound/amarok/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/amarok
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.345 2009/11/14 12:48:52 jmbsvicetto Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.346 2009/11/14 15:20:30 tampakrap Exp $
+
+ 14 Nov 2009; Theo Chatzimichos <tampakrap@gentoo.org> amarok-2.2.0.ebuild,
+ amarok-2.2.1.ebuild, +files/amarok-qtscriptcheck.patch:
+ after a long time, fix qtscript check, bug 270923, kde bug 189367
*amarok-2.2.1 (14 Nov 2009)
diff --git a/media-sound/amarok/amarok-2.2.0.ebuild b/media-sound/amarok/amarok-2.2.0.ebuild
index 2006f463161c..0a82457e1f12 100644
--- a/media-sound/amarok/amarok-2.2.0.ebuild
+++ b/media-sound/amarok/amarok-2.2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/amarok-2.2.0.ebuild,v 1.3 2009/11/09 18:18:36 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/amarok-2.2.0.ebuild,v 1.4 2009/11/14 15:20:30 tampakrap Exp $
EAPI="2"
@@ -62,7 +62,7 @@ RDEPEND="${DEPEND}
semantic-desktop? ( >=kde-base/nepomuk-${KDE_MINIMAL} )
"
-PATCHES=( "${FILESDIR}/disable_bindings_test.patch" )
+PATCHES=( "${FILESDIR}/amarok-qtscriptcheck.patch" )
# Only really required for live ebuild, to skip git_src_prepare
src_prepare() {
diff --git a/media-sound/amarok/amarok-2.2.1.ebuild b/media-sound/amarok/amarok-2.2.1.ebuild
index 0d6c5260fc8a..300212da877a 100644
--- a/media-sound/amarok/amarok-2.2.1.ebuild
+++ b/media-sound/amarok/amarok-2.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/amarok-2.2.1.ebuild,v 1.1 2009/11/14 12:48:52 jmbsvicetto Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/amarok-2.2.1.ebuild,v 1.2 2009/11/14 15:20:30 tampakrap Exp $
EAPI="2"
@@ -62,7 +62,7 @@ RDEPEND="${DEPEND}
semantic-desktop? ( >=kde-base/nepomuk-${KDE_MINIMAL} )
"
-PATCHES=( "${FILESDIR}/disable_bindings_test.patch" )
+PATCHES=( "${FILESDIR}/amarok-qtscriptcheck.patch" )
# Only really required for live ebuild, to skip git_src_prepare
src_prepare() {
diff --git a/media-sound/amarok/files/amarok-qtscriptcheck.patch b/media-sound/amarok/files/amarok-qtscriptcheck.patch
new file mode 100644
index 000000000000..643ec30f4eb4
--- /dev/null
+++ b/media-sound/amarok/files/amarok-qtscriptcheck.patch
@@ -0,0 +1,24 @@
+--- a/cmake/modules/bindingstest/QtScriptBindingsTest.cpp 2009-11-14 15:07:20.400971341 +0200
++++ b/cmake/modules/bindingstest/QtScriptBindingsTest.cpp 2009-11-14 16:13:48.156222032 +0200
+@@ -16,9 +16,7 @@
+ * Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
+ */
+
+-#include <KDE/KApplication>
+-#include <KDE/KAboutData>
+-#include <KDE/KCmdLineArgs>
++#include <qt4/QtCore/QCoreApplication>
+ #include <QtScript/QScriptEngine>
+ #include <QtCore/QStringList>
+ #include <QtCore/QDebug>
+@@ -27,9 +25,7 @@
+
+ int main(int argc, char **argv)
+ {
+- KAboutData about( "findgeneratorplugins", "", ki18n("Generator Exists?"), "1.0", ki18n("Find if the QtScript Plugins Are Installed"), KAboutData::License_LGPL_V2 );
+- KCmdLineArgs::init( argc, argv, &about );
+- KApplication app( false ); //no gui pls
++ QCoreApplication app( argc, argv ); //no gui pls
+
+ QStringList allowedBindings;
+ allowedBindings << "qt.core" << "qt.gui" << "qt.sql" << "qt.xml" << "qt.uitools" << "qt.network";