summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-27 18:41:01 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-27 18:41:01 +0000
commit259cfbd36c9ae6a8e540d9345d63d96e4bbfa1cc (patch)
treef09cf8cacd8d717a79f75ce31f91ab5a5604180c /media-sound/amarok
parentMask USE=hdf too since sci-libs/gdal hiddenly uses it (wants sci-libs/hdf whi... (diff)
downloadgentoo-2-259cfbd36c9ae6a8e540d9345d63d96e4bbfa1cc.tar.gz
gentoo-2-259cfbd36c9ae6a8e540d9345d63d96e4bbfa1cc.tar.bz2
gentoo-2-259cfbd36c9ae6a8e540d9345d63d96e4bbfa1cc.zip
Remove old versions, and add the new 1.4.4 not released yet.
(Portage version: 2.1.2_pre3-r9)
Diffstat (limited to 'media-sound/amarok')
-rw-r--r--media-sound/amarok/ChangeLog9
-rw-r--r--media-sound/amarok/amarok-1.4.4.ebuild75
-rw-r--r--media-sound/amarok/files/digest-amarok-1.4.43
3 files changed, 86 insertions, 1 deletions
diff --git a/media-sound/amarok/ChangeLog b/media-sound/amarok/ChangeLog
index 18dff14fc326..66ae52ee6511 100644
--- a/media-sound/amarok/ChangeLog
+++ b/media-sound/amarok/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/amarok
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.170 2006/10/21 17:51:45 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.171 2006/10/27 18:41:01 flameeyes Exp $
+
+*amarok-1.4.4 (27 Oct 2006)
+
+ 27 Oct 2006; Diego Pettenò <flameeyes@gentoo.org>
+ -files/amarok-1.4.0a-strict-aliasing.patch, -amarok-1.3.8.ebuild,
+ -amarok-1.4.0a-r1.ebuild, +amarok-1.4.4.ebuild:
+ Remove old versions, and add the new 1.4.4 not released yet.
21 Oct 2006; Diego Pettenò <flameeyes@gentoo.org> amarok-1.4.3-r1.ebuild:
Allow using libgpod 0.4 with 1.4.3 version.
diff --git a/media-sound/amarok/amarok-1.4.4.ebuild b/media-sound/amarok/amarok-1.4.4.ebuild
new file mode 100644
index 000000000000..fb6b0f618492
--- /dev/null
+++ b/media-sound/amarok/amarok-1.4.4.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/amarok-1.4.4.ebuild,v 1.1 2006/10/27 18:41:01 flameeyes Exp $
+
+LANGS="af ar az bg br ca cs cy da de el en_GB es et fi fr ga gl he hi hu is it
+ja ka km ko lt ms nb nl nn pa pl pt pt_BR ro ru rw sk sl sq sr sr@Latn sv ta tg
+th tr uk uz zh_CN zh_TW"
+LANGS_DOC="da de es et fr it nl pl pt pt_BR ru sv"
+
+USE_KEG_PACKAGING=1
+
+inherit kde eutils flag-o-matic
+
+PKG_SUFFIX=""
+
+MY_P="${P/_/-}"
+S="${WORKDIR}/${P/_/-}"
+
+DESCRIPTION="Advanced audio player based on KDE framework."
+HOMEPAGE="http://amarok.kde.org/"
+
+SRC_URI="mirror://kde/stable/amarok/${PV}/src/${MY_P}.tar.bz2"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="aac kde mysql noamazon opengl postgres
+xmms visualization ipod ifp real njb mtp"
+# kde: enables compilation of the konqueror sidebar plugin
+
+DEPEND="kde? ( || ( kde-base/konqueror kde-base/kdebase ) )
+ >=media-libs/xine-lib-1.1.2_pre20060328-r8
+ >=media-libs/taglib-1.4
+ mysql? ( >=dev-db/mysql-4.0.16 )
+ postgres? ( dev-db/postgresql )
+ opengl? ( virtual/opengl )
+ xmms? ( >=media-sound/xmms-1.2 )
+ visualization? ( media-libs/libsdl
+ =media-plugins/libvisual-plugins-0.4* )
+ ipod? ( >=media-libs/libgpod-0.3 )
+ aac? ( media-libs/libmp4v2 )
+ ifp? ( media-libs/libifp )
+ real? ( media-video/realplayer )
+ njb? ( >=media-libs/libnjb-2.2.4 )
+ mtp? ( media-libs/libmtp )"
+
+RDEPEND="${DEPEND}
+ dev-lang/ruby"
+
+DEPEND="${DEPEND}
+ >=dev-util/pkgconfig-0.9.0"
+
+need-kde 3.3
+
+src_compile() {
+ append-flags -fno-inline
+
+ # Extra, unsupported engines are forcefully disabled.
+ local myconf="$(use_enable mysql) $(use_enable postgres postgresql)
+ $(use_with opengl) $(use_with xmms)
+ $(use_with visualization libvisual)
+ $(use_enable !noamazon amazon)
+ $(use_with ipod libgpod)
+ $(use_with aac mp4v2)
+ $(use_with ifp)
+ $(use_with real helix)
+ $(use_with njb libnjb)
+ $(use_with mtp libmtp)
+ --without-musicbrainz
+ --with-xine
+ --without-mas
+ --without-nmm"
+
+ kde_src_compile
+}
diff --git a/media-sound/amarok/files/digest-amarok-1.4.4 b/media-sound/amarok/files/digest-amarok-1.4.4
new file mode 100644
index 000000000000..9f4ed3ac99e9
--- /dev/null
+++ b/media-sound/amarok/files/digest-amarok-1.4.4
@@ -0,0 +1,3 @@
+MD5 56a9aec42088c338b81252f8e0651781 amarok-1.4.4.tar.bz2 17635707
+RMD160 61cd2748ce0111f4ba388a71e9504abb7362b0d7 amarok-1.4.4.tar.bz2 17635707
+SHA256 760d30337cb73c86b9298e5c2c9836b3a753c39805b54f75b1eea82c15e9a0ea amarok-1.4.4.tar.bz2 17635707