summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2003-01-06 16:35:11 +0000
committerNick Hadaway <raker@gentoo.org>2003-01-06 16:35:11 +0000
commit1960693a5676e8e195295d67e6a7553b6ee48e0d (patch)
treebd8f355afd272df23e8d3bea9ebb7a26d67408eb /media-sound/ardour-cvs
parentNew ebuild added for updated support of ardour-cvs-0.6 (diff)
downloadgentoo-2-1960693a5676e8e195295d67e6a7553b6ee48e0d.tar.gz
gentoo-2-1960693a5676e8e195295d67e6a7553b6ee48e0d.tar.bz2
gentoo-2-1960693a5676e8e195295d67e6a7553b6ee48e0d.zip
The Ardour cvs tree has bumped it's rev numbers into the .6 series.
Updated the ebuild accordingly with some minor changes. :)
Diffstat (limited to 'media-sound/ardour-cvs')
-rw-r--r--media-sound/ardour-cvs/ChangeLog12
-rw-r--r--media-sound/ardour-cvs/ardour-cvs-0.6.ebuild70
-rw-r--r--media-sound/ardour-cvs/files/digest-ardour-cvs-0.61
3 files changed, 81 insertions, 2 deletions
diff --git a/media-sound/ardour-cvs/ChangeLog b/media-sound/ardour-cvs/ChangeLog
index 8fd88a616c63..c61f3a88b56a 100644
--- a/media-sound/ardour-cvs/ChangeLog
+++ b/media-sound/ardour-cvs/ChangeLog
@@ -1,8 +1,16 @@
# ChangeLog for media-sound/ardour-cvs
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/ardour-cvs/ChangeLog,v 1.2 2003/01/02 10:50:02 raker Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ardour-cvs/ChangeLog,v 1.3 2003/01/06 16:35:11 raker Exp $
-*ardour-cvs-0.5-r1 (02 Jan 2002)
+*ardour-cvs-0.6 (06 Jan 2003)
+
+ 06 Jan 2003; Nick Hadaway <raker@gentoo.org> ardour-cvs-0.6.ebuild,
+ files/digest-ardour-cvs-0.6 :
+ Ardour cvs is now in the .6 series. There are a couple new program
+ requirements including libsamplerate and a newer version of
+ ladspa-sdk.
+
+*ardour-cvs-0.5-r1 (02 Jan 2003)
02 Jan 2002; Nick Hadaway <raker@gentoo.org> ardour-cvs-0.5-r1.ebuild,
files/digest-ardour-cvs-0.5-r1 :
diff --git a/media-sound/ardour-cvs/ardour-cvs-0.6.ebuild b/media-sound/ardour-cvs/ardour-cvs-0.6.ebuild
new file mode 100644
index 000000000000..1ade841074c7
--- /dev/null
+++ b/media-sound/ardour-cvs/ardour-cvs-0.6.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ardour-cvs/ardour-cvs-0.6.ebuild,v 1.1 2003/01/06 16:35:11 raker Exp $
+
+inherit cvs
+
+ECVS_SERVER="cvs.ardour.sourceforge.net:/cvsroot/ardour"
+ECVS_MODULE="ardour"
+ECVS_TOP_DIR="${DISTDIR}/cvs-src/ardour"
+
+DESCRIPTION="multi-track hard disk recording software"
+HOMEPAGE="http://ardour.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ardour/ardour-pixmaps-2.5.0.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="dev-util/pkgconfig
+ >=media-libs/alsa-lib-0.9.0_rc6
+ >=media-sound/jack-cvs-0.44
+ =dev-libs/glib-1.2*
+ =x11-libs/gtk+-1.2*
+ >=media-libs/libsndfile-1.0.0
+ sys-libs/gdbm
+ >=media-libs/ladspa-sdk-1.12
+ >=media-libs/libsamplerate-0.0.13"
+
+S="${WORKDIR}/${PN/-cvs/}"
+
+src_compile() {
+
+ sh autogen.sh
+
+ econf || die "configure failed"
+
+ # while troubleshooting upgrades to ardour-cvs-0.6 i changed from
+ # emake to make. Can probably change back. Need to test.
+ make || die "parallel make failed"
+
+}
+
+src_install() {
+
+ einstall || die "make install failed"
+
+ cd ${WORKDIR}
+ mkdir pixmaps
+ cd pixmaps
+ unpack ${DISTFILES}/ardour-pixmaps-2.5.0.tar.gz
+ dodir /usr/share/ardour/pixmaps
+ cp * ${D}/usr/share/ardour/pixmaps
+
+ insinto /etc/skel
+ newins ${FILESDIR}/asoundrc .asoundrc
+
+ insinto /etc
+ doins ${S}/ardour.rc
+
+}
+
+pkg_postinst() {
+
+ einfo ""
+ einfo "ardour-cvs now depends on jack-cvs"
+ einfo "make sure to re-emerge jack-cvs before re-emerging ardour-cvs"
+ einfo "as the development of both programs are closely linked."
+ einfo ""
+
+}
diff --git a/media-sound/ardour-cvs/files/digest-ardour-cvs-0.6 b/media-sound/ardour-cvs/files/digest-ardour-cvs-0.6
new file mode 100644
index 000000000000..630034ac8047
--- /dev/null
+++ b/media-sound/ardour-cvs/files/digest-ardour-cvs-0.6
@@ -0,0 +1 @@
+MD5 9eb5bf0952d55fe30e05a39e109f1d60 ardour-pixmaps-2.5.0.tar.gz 105044