summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Holland <robh@gentoo.org>2003-06-03 10:48:48 +0000
committerRob Holland <robh@gentoo.org>2003-06-03 10:48:48 +0000
commit5585754d9bdeb311dbaab3435f72939cd75115fc (patch)
tree4b59fdcf6aabf3b77dd590de2e62a1e2b06d14e6 /media-sound/audiocompress
parentInitial import. Thanks to Theofilos Intzoglou, bug #21053 (diff)
downloadgentoo-2-5585754d9bdeb311dbaab3435f72939cd75115fc.tar.gz
gentoo-2-5585754d9bdeb311dbaab3435f72939cd75115fc.tar.bz2
gentoo-2-5585754d9bdeb311dbaab3435f72939cd75115fc.zip
Initial import. Thanks to Theofilos Intzoglou, bug #21053
Diffstat (limited to 'media-sound/audiocompress')
-rw-r--r--media-sound/audiocompress/ChangeLog10
-rw-r--r--media-sound/audiocompress/Manifest4
-rw-r--r--media-sound/audiocompress/audiocompress-1.3.ebuild37
3 files changed, 49 insertions, 2 deletions
diff --git a/media-sound/audiocompress/ChangeLog b/media-sound/audiocompress/ChangeLog
new file mode 100644
index 000000000000..ae929439f719
--- /dev/null
+++ b/media-sound/audiocompress/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for media-sound/audiocompress
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audiocompress/ChangeLog,v 1.1 2003/06/03 10:48:39 robh Exp $
+
+*audiocompress-1.3 (03 Jun 2003)
+
+ 03 Jun 2003; robh <robh@gentoo.org> audiocompress-1.3.ebuild:
+ initial version. ebuild supplied by: Theofilos Intzoglou <oscar10@yifan.net>,
+ tweaked by me
+
diff --git a/media-sound/audiocompress/Manifest b/media-sound/audiocompress/Manifest
index 55399ff8fa16..49c1d531d077 100644
--- a/media-sound/audiocompress/Manifest
+++ b/media-sound/audiocompress/Manifest
@@ -1,3 +1,3 @@
-MD5 a7421d36c1f2f2ebd7c775f2d57a6717 audiocompress-1.3.ebuild 963
-MD5 4ab0ab93051b50e5673519c18c7b0682 ChangeLog 329
+MD5 02b674a28cc95e9b78d6a7cd1d8d7314 audiocompress-1.3.ebuild 1074
+MD5 721024f161786de63d22f69a1a659f85 ChangeLog 425
MD5 45241faef0fdd3134f481dd0e30f8079 files/digest-audiocompress-1.3 68
diff --git a/media-sound/audiocompress/audiocompress-1.3.ebuild b/media-sound/audiocompress/audiocompress-1.3.ebuild
new file mode 100644
index 000000000000..d78524ed9a33
--- /dev/null
+++ b/media-sound/audiocompress/audiocompress-1.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audiocompress/audiocompress-1.3.ebuild,v 1.1 2003/06/03 10:48:39 robh Exp $
+
+MY_P="AudioCompress-${PV}"
+
+DESCRIPTION="AudioCompress is (essentially) a very gentle, 1-band dynamic range compressor intended to keep audio output at a consistent volume without introducing any audible artifacts"
+SRC_URI="http://trikuare.cx/code/${MY_P}.tar.gz"
+HOMEPAGE="http://trikuare.cx/code/AudioCompress.html"
+IUSE="xmms"
+
+S=${WORKDIR}/${MY_P}
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+DEPEND="xmms? ( media-sound/xmms )"
+
+src_compile() {
+ if [ -n "`use xmms`" ]; then
+ emake || die
+ else
+ emake AudioCompress
+ fi
+}
+
+src_install() {
+ dodir /usr/bin
+ install -m 755 AudioCompress ${D}/usr/bin/ || die
+ if [ -n "`use xmms`" ]; then
+ installdir="${D}$(xmms-config --effect-plugin-dir)"
+ install -d ${installdir} || die
+ install -m 755 libcompress.so ${installdir} || die
+ fi
+ dodoc COPYING ChangeLog README TODO
+}