summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2004-08-30 19:32:52 +0000
committerTony Vroon <chainsaw@gentoo.org>2004-08-30 19:32:52 +0000
commiteabf2e965fc01ee87304d1e8ceb33096d5cf030e (patch)
tree06add8bc2ebca6ebca1e5ad370db0ff7afbcad6c /media-sound/beep-media-player
parentFixed DEPEND/RDEPEND (Manifest recommit) (diff)
downloadgentoo-2-eabf2e965fc01ee87304d1e8ceb33096d5cf030e.tar.gz
gentoo-2-eabf2e965fc01ee87304d1e8ceb33096d5cf030e.tar.bz2
gentoo-2-eabf2e965fc01ee87304d1e8ceb33096d5cf030e.zip
Add oss and mmx USE-flags. Mark ~amd64, no longer segfaults. Trigger more gnome features with gnome USE-flag.
Diffstat (limited to 'media-sound/beep-media-player')
-rw-r--r--media-sound/beep-media-player/ChangeLog9
-rw-r--r--media-sound/beep-media-player/Manifest13
-rw-r--r--media-sound/beep-media-player/beep-media-player-0.9.7_rc2-r1.ebuild103
-rw-r--r--media-sound/beep-media-player/files/beep-config163
-rw-r--r--media-sound/beep-media-player/files/digest-beep-media-player-0.9.7_rc2-r11
5 files changed, 283 insertions, 6 deletions
diff --git a/media-sound/beep-media-player/ChangeLog b/media-sound/beep-media-player/ChangeLog
index 00ffe845ae93..e63eeb82dad8 100644
--- a/media-sound/beep-media-player/ChangeLog
+++ b/media-sound/beep-media-player/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/beep-media-player
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/beep-media-player/ChangeLog,v 1.11 2004/08/30 15:38:43 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/beep-media-player/ChangeLog,v 1.12 2004/08/30 19:32:52 chainsaw Exp $
+
+*beep-media-player-0.9.7_rc2-r1 (30 Aug 2004)
+
+ 30 Aug 2004; Tony Vroon <chainsaw@gentoo.org> +files/beep-config,
+ +beep-media-player-0.9.7_rc2-r1.ebuild:
+ Add mmx and oss USE-flags. Enable more gnome functionality. Add beep-config to
+ get more plugins building. ~amd64, no longer segfaults.
30 Aug 2004; Luca Barbato <lu_zero@gentoo.org>
beep-media-player-0.9.7_rc2.ebuild:
diff --git a/media-sound/beep-media-player/Manifest b/media-sound/beep-media-player/Manifest
index 63327d4fbcb6..0620a684bb11 100644
--- a/media-sound/beep-media-player/Manifest
+++ b/media-sound/beep-media-player/Manifest
@@ -1,8 +1,11 @@
-MD5 df2a487dfae626a528f40c22f3d5b055 ChangeLog 2362
-MD5 2b0e9087ef8939ab0578160c97b115e0 metadata.xml 215
-MD5 8a374f72791674dc80b4dee42e2295b4 beep-media-player-0.9.6.1-r1.ebuild 2350
+MD5 3b6b3b96aa9550812c35afe1c7d0e2da beep-media-player-0.9.7_rc2-r1.ebuild 2353
MD5 871c4af251da9e41597c34433ecd230e beep-media-player-0.9.7_rc2.ebuild 2425
+MD5 8a374f72791674dc80b4dee42e2295b4 beep-media-player-0.9.6.1-r1.ebuild 2350
+MD5 38a6becb41fd67fda21f426254c19bf3 ChangeLog 2659
+MD5 2b0e9087ef8939ab0578160c97b115e0 metadata.xml 215
+MD5 49ac6fbcf87a9de0e4fb7f349c53805c files/beep-media-player.desktop 281
MD5 063233d8fba29761b83b023b6a367489 files/digest-beep-media-player-0.9.6.1-r1 64
-MD5 e80bc03ebda5e6071f584a50638e9630 files/beep-media-player-0.9.6.1-gcc34.patch 552
+MD5 b7d99875975dc75e79760f82bbeaf790 files/digest-beep-media-player-0.9.7_rc2-r1 65
+MD5 bcb43edf11b6364167d8c326ed04f6b0 files/beep-config 3253
MD5 b7d99875975dc75e79760f82bbeaf790 files/digest-beep-media-player-0.9.7_rc2 65
-MD5 49ac6fbcf87a9de0e4fb7f349c53805c files/beep-media-player.desktop 281
+MD5 e80bc03ebda5e6071f584a50638e9630 files/beep-media-player-0.9.6.1-gcc34.patch 552
diff --git a/media-sound/beep-media-player/beep-media-player-0.9.7_rc2-r1.ebuild b/media-sound/beep-media-player/beep-media-player-0.9.7_rc2-r1.ebuild
new file mode 100644
index 000000000000..679d36787c72
--- /dev/null
+++ b/media-sound/beep-media-player/beep-media-player-0.9.7_rc2-r1.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/beep-media-player/beep-media-player-0.9.7_rc2-r1.ebuild,v 1.1 2004/08/30 19:32:52 chainsaw Exp $
+
+inherit flag-o-matic
+
+MY_PN="bmp"
+MY_P=bmp-${PV/_/}
+
+DESCRIPTION="Beep Media Player"
+HOMEPAGE="http://beepmp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/beepmp/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~x86 ~sparc ~amd64 ~ppc"
+IUSE="nls gnome opengl oggvorbis mikmod alsa oss esd mmx"
+
+RDEPEND="app-arch/unzip
+ >=x11-libs/gtk+-2.2
+ >=x11-libs/pango-1.2
+ >=dev-libs/libxml-1.8.15
+ mikmod? ( >=media-libs/libmikmod-3.1.10 )
+ esd? ( >=media-sound/esound-0.2.29 )
+ opengl? ( virtual/opengl )
+ oggvorbis? ( >=media-libs/libvorbis-1.0 )
+ alsa? ( >=media-libs/alsa-lib-0.9.0 )"
+DEPEND="${RDEPEND}
+ nls? ( dev-util/intltool )"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ local myconf=""
+
+ # Bug #42893
+ replace-flags "-Os" "-O2"
+
+ if use gnome; then
+ myconf="${myconf} --enable-gconf --enable-gnome-vfs"
+ fi
+
+ if use mmx; then
+ myconf="${myconf} --enable-simd"
+ fi
+
+ econf \
+ --with-dev-dsp=/dev/sound/dsp \
+ --with-dev-mixer=/dev/sound/mixer \
+ `use_enable oggvorbis vorbis` \
+ `use_enable oggvorbis oggtest` \
+ `use_enable oggvorbis vorbistest` \
+ `use_enable esd` \
+ `use_enable esd esdtest` \
+ `use_enable mikmod` \
+ `use_enable mikmod mikmodtest` \
+ `use_with mikmod libmikmod` \
+ `use_enable opengl` \
+ `use_enable nls` \
+ `use_enable oss` \
+ `use_enable alsa` \
+ ${myconf} \
+ || die
+
+ emake || die "make failed"
+}
+
+src_install() {
+ einstall || die "install failed"
+
+ insinto /usr/share/pixmaps
+ doins beep.svg
+ doins beep/beep_mini.xpm
+
+ # Get the app registered in gnome
+
+ if use gnome; then
+ dodir /usr/share/gnome/apps
+ insinto /usr/share/gnome/apps/Multimedia
+ doins ${FILESDIR}/beep-media-player.desktop
+ fi
+
+ # We'll use xmms skins / plugins for the time being
+
+ dodir /usr/share/beep
+ dosym /usr/share/xmms/Skins /usr/share/beep/Skins
+ dosym /usr/share/xmms/Plugins /usr/share/beep/Plugins
+
+ # Plugins want beep-config, this wasn't included
+ dobin ${FILESDIR}/beep-config
+
+ dodoc AUTHORS ChangeLog COPYING FAQ NEWS README TODO
+}
+
+pkg_postinst() {
+ echo
+ einfo "This program is unstable on sparc when poking heavily with the GUI."
+ einfo "It's reportedly unstable on some x86 boxes also, YMMV."
+ echo
+ einfo "We're using xmms skins/plugins for the time being, they have been symlinked."
+ echo
+}
diff --git a/media-sound/beep-media-player/files/beep-config b/media-sound/beep-media-player/files/beep-config
new file mode 100644
index 000000000000..9ff712fe6810
--- /dev/null
+++ b/media-sound/beep-media-player/files/beep-config
@@ -0,0 +1,163 @@
+#!/bin/sh
+
+# beep-config
+#
+# Tool for retrieving the library/include paths BMP was compiled with.
+#
+# Useful for folks compiling their own BMP plugins outside the main
+# source tree.
+#
+# Original xmms-config written 15 December 1999 by Ben Gertzfield <che@debian.org>
+# Based *HEAVILY* on gtk-config from the GTK+ library package.
+#
+# Modified to beep-config 29 August 2004 by Tony Vroon <chainsaw@gentoo.org>
+#
+# This work is released under the GNU GPL, version 2 or later.
+
+
+version=`/usr/bin/pkg-config --variable=version bmp`
+prefix=`/usr/bin/pkg-config --variable=prefix bmp`
+exec_prefix=`/usr/bin/pkg-config --variable=prefix bmp`
+data_dir=`/usr/bin/pkg-config --variable=data_dir bmp`
+lib_dir=`/usr/bin/pkg-config --variable=lib_dir bmp`
+plugin_dir=`/usr/bin/pkg-config --variable=output_plugin_dir bmp`
+visualization_plugin_dir=`/usr/bin/pkg-config --variable=visualization_plugin_dir bmp`
+input_plugin_dir=`/usr/bin/pkg-config --variable=input_plugin_dir bmp`
+output_plugin_dir=`/usr/bin/pkg-config --variable=output_plugin_dir bmp`
+effect_plugin_dir=`/usr/bin/pkg-config --variable=effect_plugin_dir bmp`
+general_plugin_dir=`/usr/bin/pkg-config --variable=general_plugin_dir bmp`
+cflags=`/usr/bin/pkg-config --cflags bmp`
+libs=`/usr/bin/pkg-config --libs bmp`
+
+usage()
+{
+ cat <<EOF
+Usage: beep-config [OPTIONS]
+Options:
+ [--prefix]
+ [--exec-prefix]
+ [--version]
+ [--libs]
+ [--cflags]
+ [--data-dir]
+ [--plugin-dir]
+ [--visualization-plugin-dir]
+ [--input-plugin-dir]
+ [--output-plugin-dir]
+ [--effect-plugin-dir]
+ [--general-plugin-dir]
+
+EOF
+ exit $1
+}
+
+if test $# -eq 0; then
+ usage 1 1>&2
+fi
+
+
+while test $# -gt 0; do
+ case "$1" in
+ -*=*) optarg=`echo "$1" | sed 's/[-_a-zA-Z0-9]*=//'` ;;
+ *) optarg= ;;
+ esac
+
+ case $1 in
+ --prefix)
+ echo_prefix=yes
+ ;;
+
+ --exec-prefix)
+ echo_exec_prefix=yes
+ ;;
+
+ --version)
+ echo $version
+ ;;
+
+ --cflags)
+ echo_cflags=yes
+ ;;
+
+ --libs)
+ echo_libs=yes
+ ;;
+
+ --data-dir)
+ echo_data_dir=yes
+ ;;
+
+ --plugin-dir)
+ echo_plugin_dir=yes
+ ;;
+
+ --visualization-plugin-dir)
+ echo_visualization_plugin_dir=yes
+ ;;
+
+ --input-plugin-dir)
+ echo_input_plugin_dir=yes
+ ;;
+
+ --output-plugin-dir)
+ echo_output_plugin_dir=yes
+ ;;
+
+ --general-plugin-dir)
+ echo_general_plugin_dir=yes
+ ;;
+
+ --effect-plugin-dir)
+ echo_effect_plugin_dir=yes
+ ;;
+
+ *)
+ usage 1 1>&2
+ ;;
+ esac
+ shift
+done
+
+if test "$echo_prefix" = "yes"; then
+ echo $prefix
+fi
+
+if test "$echo_exec_prefix" = "yes"; then
+ echo $exec_prefix
+fi
+
+if test "$echo_cflags" = "yes"; then
+ echo $cflags
+fi
+
+if test "$echo_libs" = "yes"; then
+ echo $libs
+fi
+
+if test "$echo_data_dir" = "yes"; then
+ echo $data_dir
+fi
+
+if test "$echo_plugin_dir" = "yes"; then
+ echo $plugin_dir
+fi
+
+if test "$echo_visualization_plugin_dir" = "yes"; then
+ echo $visualization_plugin_dir
+fi
+
+if test "$echo_input_plugin_dir" = "yes"; then
+ echo $input_plugin_dir
+fi
+
+if test "$echo_output_plugin_dir" = "yes"; then
+ echo $output_plugin_dir
+fi
+
+if test "$echo_general_plugin_dir" = "yes"; then
+ echo $general_plugin_dir
+fi
+
+if test "$echo_effect_plugin_dir" = "yes"; then
+ echo $effect_plugin_dir
+fi
diff --git a/media-sound/beep-media-player/files/digest-beep-media-player-0.9.7_rc2-r1 b/media-sound/beep-media-player/files/digest-beep-media-player-0.9.7_rc2-r1
new file mode 100644
index 000000000000..ee9bb0f2a088
--- /dev/null
+++ b/media-sound/beep-media-player/files/digest-beep-media-player-0.9.7_rc2-r1
@@ -0,0 +1 @@
+MD5 1fcf7b7d8964f26cb5c0ebddc95d1a7d bmp-0.9.7rc2.tar.gz 1705197