summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStanislav Ochotnicky <sochotnicky@gentoo.org>2013-04-06 23:56:35 +0000
committerStanislav Ochotnicky <sochotnicky@gentoo.org>2013-04-06 23:56:35 +0000
commitab6d047b55638675bb79c83a918b891df5d3295a (patch)
treece0529a42f6ba5448c5af377b2cb6ca01dcda169 /media-sound/beets
parentVersion bump. (diff)
downloadgentoo-2-ab6d047b55638675bb79c83a918b891df5d3295a.tar.gz
gentoo-2-ab6d047b55638675bb79c83a918b891df5d3295a.tar.bz2
gentoo-2-ab6d047b55638675bb79c83a918b891df5d3295a.zip
Bump media-sound/beets to 1.1.0_beta3, remove old version
Updated dependencies on more recent mutagen and python-musicbrainz-ngs (Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key 7B087241)
Diffstat (limited to 'media-sound/beets')
-rw-r--r--media-sound/beets/ChangeLog11
-rw-r--r--media-sound/beets/beets-1.1.0_beta3.ebuild (renamed from media-sound/beets/beets-1.0_rc2.ebuild)18
-rw-r--r--media-sound/beets/files/0001-fix-VFS-tests.patch30
3 files changed, 51 insertions, 8 deletions
diff --git a/media-sound/beets/ChangeLog b/media-sound/beets/ChangeLog
index 1b9b9f5b3477..c55d4190cbe0 100644
--- a/media-sound/beets/ChangeLog
+++ b/media-sound/beets/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for media-sound/beets
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/beets/ChangeLog,v 1.12 2013/02/20 00:01:07 sochotnicky Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/beets/ChangeLog,v 1.13 2013/04/06 23:56:35 sochotnicky Exp $
+
+*beets-1.1.0_beta3 (06 Apr 2013)
+
+ 06 Apr 2013; Stanislav Ochotnicky <sochotnicky@gentoo.org>
+ +files/0001-fix-VFS-tests.patch, -beets-1.0_rc2.ebuild,
+ +beets-1.1.0_beta3.ebuild:
+ Bump media-sound/beets to 1.1.0_beta3, remove old version
+
+ Updated dependencies on more recent mutagen and python-musicbrainz-ngs
20 Feb 2013; Stanislav Ochotnicky <sochotnicky@gentoo.org> beets-1.0.0.ebuild:
Fix up test patching for stable version
diff --git a/media-sound/beets/beets-1.0_rc2.ebuild b/media-sound/beets/beets-1.1.0_beta3.ebuild
index 7c696b52c1ea..8db5f9aed1f6 100644
--- a/media-sound/beets/beets-1.0_rc2.ebuild
+++ b/media-sound/beets/beets-1.1.0_beta3.ebuild
@@ -1,18 +1,18 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/beets/beets-1.0_rc2.ebuild,v 1.2 2013/01/03 00:08:39 sochotnicky Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/beets/beets-1.1.0_beta3.ebuild,v 1.1 2013/04/06 23:56:35 sochotnicky Exp $
EAPI="4"
-PYTHON_DEPEND="2:2.6"
+PYTHON_DEPEND="2:2.7"
PYTHON_USE_WITH="sqlite"
SUPPORT_PYTHON_ABIS="1"
#There a few test failures with 2.6, worth investigating
-RESTRICT_PYTHON_ABIS="2.5 3.* 2.7-pypy-*"
+RESTRICT_PYTHON_ABIS="2.5 2.6 3.* 2.7-pypy-*"
inherit distutils eutils
-MY_PV=${PV/_rc/rc}
+MY_PV=${PV/_beta/-beta.}
MY_P=${PN}-${MY_PV}
DESCRIPTION="A media library management system for obsessive-compulsive music geeks"
@@ -26,9 +26,10 @@ IUSE="bpd chroma convert doc echonest_tempo lastgenre replaygain web"
RDEPEND="
dev-python/munkres
- dev-python/python-musicbrainz-ngs
+ >=dev-python/python-musicbrainz-ngs-0.3
dev-python/unidecode
- media-libs/mutagen
+ >=media-libs/mutagen-0.21
+ dev-python/pyyaml
bpd? ( dev-python/bluelet )
chroma? ( dev-python/pyacoustid )
convert? ( media-video/ffmpeg[encode] )
@@ -50,7 +51,10 @@ src_prepare() {
# we'll need this as long as portage doesn't have proper python
# namespace support (without this we would try to load modules from
# previous installation during updates)
- use test && epatch "${FILESDIR}/${P}-test-namespace.patch"
+ if use test;then
+ epatch "${FILESDIR}/${PN}-1.0_rc2-test-namespace.patch"
+ epatch "${FILESDIR}/0001-fix-VFS-tests.patch"
+ fi
# remove plugins that do not have appropriate dependencies installed
for flag in bpd chroma convert echonest_tempo lastgenre replaygain web;do
diff --git a/media-sound/beets/files/0001-fix-VFS-tests.patch b/media-sound/beets/files/0001-fix-VFS-tests.patch
new file mode 100644
index 000000000000..0c630a22412f
--- /dev/null
+++ b/media-sound/beets/files/0001-fix-VFS-tests.patch
@@ -0,0 +1,30 @@
+From 963b0d11d6f25ec8a8bd95e9fcea2d9933e31bcf Mon Sep 17 00:00:00 2001
+From: Adrian Sampson <adrian@radbox.org>
+Date: Sat, 6 Apr 2013 16:35:17 -0700
+Subject: [PATCH 1/3] fix VFS tests
+
+The configuration was not loaded for these tests because they didn't inherit
+the common test harness. These failures were hidden on my system because of
+some kind of dependency on another test.
+---
+ test/test_vfs.py | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/test/test_vfs.py b/test/test_vfs.py
+index 04ff3d6..755311b 100644
+--- a/test/test_vfs.py
++++ b/test/test_vfs.py
+@@ -18,8 +18,9 @@ from _common import unittest
+ from beets import library
+ from beets import vfs
+
+-class VFSTest(unittest.TestCase):
++class VFSTest(_common.TestCase):
+ def setUp(self):
++ super(VFSTest, self).setUp()
+ self.lib = library.Library(':memory:', path_formats=[
+ ('default', 'albums/$album/$title'),
+ ('singleton:true', 'tracks/$artist/$title'),
+--
+1.8.1.5
+