summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2005-10-24 13:24:26 +0000
committerMartin Schlemmer <azarah@gentoo.org>2005-10-24 13:24:26 +0000
commit91034334e24d55acabc3b8642ce9448f266a43a9 (patch)
tree0a9ba612624101d489d39aa6808083e34cd50d5f /media-sound/bmpx
parentFix ChangeLog. (diff)
downloadgentoo-2-91034334e24d55acabc3b8642ce9448f266a43a9.tar.gz
gentoo-2-91034334e24d55acabc3b8642ce9448f266a43a9.tar.bz2
gentoo-2-91034334e24d55acabc3b8642ce9448f266a43a9.zip
Version bump, bug #109776 (I am still not happy, as there is a memory leak
that we have difficulty to track). Should also resolve bug #109494. Add the gentoo_ice skin, which is also in XMMS (bug #109772). Some tweaks from Tony Vroon <chainsaw@gentoo.org>. (Portage version: 2.0.53_rc6)
Diffstat (limited to 'media-sound/bmpx')
-rw-r--r--media-sound/bmpx/ChangeLog10
-rw-r--r--media-sound/bmpx/Manifest16
-rw-r--r--media-sound/bmpx/bmpx-0.12.ebuild64
-rw-r--r--media-sound/bmpx/files/digest-bmpx-0.122
4 files changed, 79 insertions, 13 deletions
diff --git a/media-sound/bmpx/ChangeLog b/media-sound/bmpx/ChangeLog
index 2c577633bfe9..c53795048498 100644
--- a/media-sound/bmpx/ChangeLog
+++ b/media-sound/bmpx/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-sound/bmpx
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/bmpx/ChangeLog,v 1.9 2005/10/04 20:57:17 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/bmpx/ChangeLog,v 1.10 2005/10/24 13:24:26 azarah Exp $
+
+*bmpx-0.12 (24 Oct 2005)
+
+ 24 Oct 2005; Martin Schlemmer <azarah@gentoo.org> +bmpx-0.12.ebuild:
+ Version bump, bug #109776 (I am still not happy, as there is a memory leak
+ that we have difficulty to track). Should also resolve bug #109494. Add the
+ gentoo_ice skin, which is also in XMMS (bug #109772). Some tweaks from Tony
+ Vroon <chainsaw@gentoo.org>.
*bmpx-0.12_rc2 (04 Oct 2005)
diff --git a/media-sound/bmpx/Manifest b/media-sound/bmpx/Manifest
index d0a9356e7242..84adc68661c2 100644
--- a/media-sound/bmpx/Manifest
+++ b/media-sound/bmpx/Manifest
@@ -1,16 +1,8 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 908ef499d4f4785a36c356ccca02bbde bmpx-0.12_rc2.ebuild 1698
MD5 ea54e79a2ccc0bf04b84cf3862a5d04f ChangeLog 1356
+MD5 97d9ae1ebebdcfb46ac86c4fe6929a01 bmpx-0.12.ebuild 1900
MD5 21eeb355b8b22577ff6cd345af4744c4 bmpx-0.12_rc1.ebuild 1698
-MD5 b612d343db3c54560665171eb7db245c metadata.xml 223
+MD5 908ef499d4f4785a36c356ccca02bbde bmpx-0.12_rc2.ebuild 1698
+MD5 6af4667baf20ce71c693fda5a094e931 files/digest-bmpx-0.12 134
MD5 94e4107d5e7cc0d7ff964c94dc8962b9 files/digest-bmpx-0.12_rc1 66
MD5 939119e16de32d410715a7eb506a6ab3 files/digest-bmpx-0.12_rc2 66
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.2 (GNU/Linux)
-
-iD8DBQFDQu1B1ZcsMnZjRyIRAnb3AKC389RTa8T0gBMQX3wTI+FqhwT6lwCZAab+
-CYCp8j8Tb37+kQldr3TW020=
-=/hV4
------END PGP SIGNATURE-----
+MD5 b612d343db3c54560665171eb7db245c metadata.xml 223
diff --git a/media-sound/bmpx/bmpx-0.12.ebuild b/media-sound/bmpx/bmpx-0.12.ebuild
new file mode 100644
index 000000000000..c1343c8511da
--- /dev/null
+++ b/media-sound/bmpx/bmpx-0.12.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/bmpx/bmpx-0.12.ebuild,v 1.1 2005/10/24 13:24:26 azarah Exp $
+
+inherit gnome2 eutils
+
+MY_P=${P/_p/-}
+MY_P=${MY_P/_rc/_RC}
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="Next generation Beep Media Player"
+HOMEPAGE="http://bmpx.berlios.de/"
+SRC_URI="http://download.berlios.de/${PN}/${MY_P}.tar.bz2
+ mirror://gentoo/gentoo_ice-xmms-0.2.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="xine dbus mad ogg vorbis a52 flac theora"
+
+RDEPEND=">=dev-libs/glib-2.8.0
+ >=x11-libs/gtk+-2.8.0
+ >=gnome-base/libglade-2.5.1
+ >=x11-libs/pango-1.10.0
+ >=dev-libs/libxml2-2.6.18
+ >=x11-libs/cairo-1.0.0
+ >=media-libs/taglib-1.4
+ dbus? ( >=sys-apps/dbus-0.3.5 )
+ virtual/fam
+ net-misc/curl
+ >=media-libs/xine-lib-1.0.1"
+# gstreamer support is on hold until gstreamer 0.9
+# xine? ( >=media-libs/xine-lib-1.0.1 )
+# !xine? ( >=media-libs/gstreamer-0.8.9-r3
+# >=media-libs/gst-plugins-0.8.8
+# >=media-plugins/gst-plugins-pango-0.8.8
+# mad? ( >=media-plugins/gst-plugins-mad-0.8.8 )
+# ogg? ( >=media-plugins/gst-plugins-ogg-0.8.8 )
+# vorbis? ( >=media-plugins/gst-plugins-ogg-0.8.8
+# >=media-plugins/gst-plugins-vorbis-0.8.8 )
+# a52? ( >=media-plugins/gst-plugins-a52dec-0.8.8 )
+# flac? ( >=media-plugins/gst-plugins-flac-0.8.8 )
+# theora? ( >=media-plugins/gst-plugins-ogg-0.8.8
+# >=media-plugins/gst-plugins-theora-0.8.8 )
+# )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.29
+ >=dev-util/pkgconfig-0.12.0"
+
+DOCS="AUTHORS COPYING ChangeLog NEWS README"
+
+# gstreamer is default backend
+G2CONF="${G2CONF} $(use_enable dbus)"
+#useq xine || G2CONF="${G2CONF} --enable-gst"
+
+USE_DESTDIR="1"
+
+src_install() {
+ gnome2_src_install
+
+ insinto /usr/share/bmpx/skins/gentoo_ice
+ doins ${WORKDIR}/gentoo_ice/*
+ docinto gentoo_ice
+ dodoc ${WORKDIR}/README
+}
diff --git a/media-sound/bmpx/files/digest-bmpx-0.12 b/media-sound/bmpx/files/digest-bmpx-0.12
new file mode 100644
index 000000000000..083734ad6b02
--- /dev/null
+++ b/media-sound/bmpx/files/digest-bmpx-0.12
@@ -0,0 +1,2 @@
+MD5 d08d128f68c0fc66a6bc62dabe35da0f bmpx-0.12.tar.bz2 1010943
+MD5 41eababfa8bad11e9e34e467cdfb86be gentoo_ice-xmms-0.2.tar.bz2 51839