summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2003-04-02 15:43:38 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2003-04-02 15:43:38 +0000
commit02d2361fbde1241fa6da355c3c94edecfb40db18 (patch)
tree22213344c274c6226f00d03ef17658816c3f152c /media-sound/cymbaline
parentnew package, closes bug 660 (diff)
downloadgentoo-2-02d2361fbde1241fa6da355c3c94edecfb40db18.tar.gz
gentoo-2-02d2361fbde1241fa6da355c3c94edecfb40db18.tar.bz2
gentoo-2-02d2361fbde1241fa6da355c3c94edecfb40db18.zip
initial import, closes bug 676
Diffstat (limited to 'media-sound/cymbaline')
-rw-r--r--media-sound/cymbaline/ChangeLog12
-rw-r--r--media-sound/cymbaline/cymbaline-0.9r.ebuild40
-rw-r--r--media-sound/cymbaline/files/cymbaline-0.9r.patch20
-rw-r--r--media-sound/cymbaline/files/digest-cymbaline-0.9r1
4 files changed, 73 insertions, 0 deletions
diff --git a/media-sound/cymbaline/ChangeLog b/media-sound/cymbaline/ChangeLog
new file mode 100644
index 000000000000..1d59b5e11b9d
--- /dev/null
+++ b/media-sound/cymbaline/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for media-sound/cymbaline
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/cymbaline/ChangeLog,v 1.1 2003/04/02 15:43:38 phosphan Exp $
+
+*cymbaline-0.9r (02 Apr 2003)
+
+ 02 Apr 2003; Patrick Kursawe <phosphan@gentoo.org> ChangeLog,
+ cymbaline-0.9r.ebuild, files/digest-cymbaline-0.9r,
+ files/cymbaline-0.9r.patch :
+ Initial import. Closes bug #676 which was a submission by
+ Mark <mwdilla@ilstu.edu>, modified by
+ Tobias Klausmann <klausman-gentoo@schwarzvogel.de> and me.
diff --git a/media-sound/cymbaline/cymbaline-0.9r.ebuild b/media-sound/cymbaline/cymbaline-0.9r.ebuild
new file mode 100644
index 000000000000..8884bdf41ec0
--- /dev/null
+++ b/media-sound/cymbaline/cymbaline-0.9r.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/media-sound/cymbaline/cymbaline-0.9r.ebuild,v 1.1 2003/04/02 15:43:38 phosphan Exp $
+
+inherit eutils
+
+DESCRIPTION="Smart Command Line Mp3 Player"
+SRC_URI="http://www.silmarill.org/files/${P}.tar.gz"
+HOMEPAGE="http://silmarill.org/cymbaline.htm"
+IUSE="mikmod oggvorbis"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+RESTRICT="nostrip"
+
+DEPEND="dev-lang/python
+ media-sound/mpg123
+ media-sound/aumix
+ mikmod? ( media-sound/mikmod )
+ oggvorbis? ( media-sound/vorbis-tools ) "
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}.patch
+}
+
+src_compile() {
+ einfo No compilation necessary.
+}
+
+src_install () {
+ dodir /usr/lib/cymbaline
+ exeinto /usr/bin
+ newexe cymbaline.py cymbaline
+ insinto /usr/lib/cymbaline
+ doins ID3.py mp3.py cycolors.py
+}
+
diff --git a/media-sound/cymbaline/files/cymbaline-0.9r.patch b/media-sound/cymbaline/files/cymbaline-0.9r.patch
new file mode 100644
index 000000000000..6c19c8c8c850
--- /dev/null
+++ b/media-sound/cymbaline/files/cymbaline-0.9r.patch
@@ -0,0 +1,20 @@
+--- cymbaline.py 2003-03-11 09:16:49.000000000 +0100
++++ cymbaline.py.new 2003-03-11 09:17:16.000000000 +0100
+@@ -17,7 +17,7 @@
+ import sys, os, random, time, string, commands, getopt, thread, glob, urllib2
+ import re, termios, signal, select, cPickle, copy, struct, shutil
+ py_ver = sys.version[:3]
+-module_path = "/usr/local/cymbaline"
++module_path = "/usr/lib/cymbaline"
+ sys.path.append(module_path)
+ import ID3, mp3, fcntl, UserDict
+ import cycolors as col # edit colors.py for colors
+@@ -141,7 +141,7 @@
+ mp3_player = "mpg123"
+ ogg_player = "ogg123"
+ mod_player = "mikmod"
+-text_viewer = "vim"
++text_viewer = "less"
+ image_viewer = "feh"
+ debugging = 1
+ base_url = "http://silmarill.org/cymbaline/"
diff --git a/media-sound/cymbaline/files/digest-cymbaline-0.9r b/media-sound/cymbaline/files/digest-cymbaline-0.9r
new file mode 100644
index 000000000000..1094b28bd1eb
--- /dev/null
+++ b/media-sound/cymbaline/files/digest-cymbaline-0.9r
@@ -0,0 +1 @@
+MD5 29ecb3ef701ff7cdc6b40950ab6ca7eb cymbaline-0.9r.tar.gz 43710