summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2007-07-06 17:44:11 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2007-07-06 17:44:11 +0000
commit12f531df5b237335b127dd7329c5ce042f1a1bfe (patch)
tree8a896190088fe4ba7f55b39275eab3c73f3cda4c /media-sound/ecasound/ecasound-2.4.5.ebuild
parentebuild cleanups (diff)
downloadgentoo-2-12f531df5b237335b127dd7329c5ce042f1a1bfe.tar.gz
gentoo-2-12f531df5b237335b127dd7329c5ce042f1a1bfe.tar.bz2
gentoo-2-12f531df5b237335b127dd7329c5ce042f1a1bfe.zip
Add a pkg_setup check for midi USE flag in alsa-lib.
(Portage version: 2.1.3_rc6)
Diffstat (limited to 'media-sound/ecasound/ecasound-2.4.5.ebuild')
-rw-r--r--media-sound/ecasound/ecasound-2.4.5.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/media-sound/ecasound/ecasound-2.4.5.ebuild b/media-sound/ecasound/ecasound-2.4.5.ebuild
index 731355b693aa..28849735602d 100644
--- a/media-sound/ecasound/ecasound-2.4.5.ebuild
+++ b/media-sound/ecasound/ecasound-2.4.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/ecasound/ecasound-2.4.5.ebuild,v 1.1 2007/06/15 12:22:23 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ecasound/ecasound-2.4.5.ebuild,v 1.2 2007/07/06 17:44:11 flameeyes Exp $
inherit multilib
@@ -31,6 +31,15 @@ DEPEND="${RDEPEND}"
# We don't make RDEPEND for vorbis-tools, mpg123/mpg321, timidity++ or lame -- no
# use flags for them.
+pkg_setup() {
+ if use alsa && ! built_with_use --missing true media-libs/alsa-lib midi; then
+ eerror ""
+ eerror "To be able to build ${CATEGORY}/${PN} with ALSA support you"
+ eerror "need to have built media-libs/alsa-lib with midi USE flag."
+ die "Missing midi USE flag on media-libs/alsa-lib"
+ fi
+}
+
src_compile () {
local myconf