summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrank van de Pol <fvdpol@gentoo.org>2006-07-08 14:08:01 +0000
committerFrank van de Pol <fvdpol@gentoo.org>2006-07-08 14:08:01 +0000
commitb266424e1fb623718eedd7b89e4315d50c32c740 (patch)
tree3ba82b60c0e9a7911cfb5568b3f64405aae25faa /media-sound/fluidsynth
parentStable on ppc; bug #137121. (diff)
downloadgentoo-2-b266424e1fb623718eedd7b89e4315d50c32c740.tar.gz
gentoo-2-b266424e1fb623718eedd7b89e4315d50c32c740.tar.bz2
gentoo-2-b266424e1fb623718eedd7b89e4315d50c32c740.zip
Version bump to 1.0.7
(Portage version: 2.1.1_pre2-r4)
Diffstat (limited to 'media-sound/fluidsynth')
-rw-r--r--media-sound/fluidsynth/ChangeLog10
-rw-r--r--media-sound/fluidsynth/files/digest-fluidsynth-1.0.62
-rw-r--r--media-sound/fluidsynth/files/digest-fluidsynth-1.0.73
-rw-r--r--media-sound/fluidsynth/fluidsynth-1.0.7.ebuild54
4 files changed, 67 insertions, 2 deletions
diff --git a/media-sound/fluidsynth/ChangeLog b/media-sound/fluidsynth/ChangeLog
index 41b78d1b4b18..0ae56d1e5db2 100644
--- a/media-sound/fluidsynth/ChangeLog
+++ b/media-sound/fluidsynth/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/fluidsynth
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/fluidsynth/ChangeLog,v 1.20 2005/07/11 19:41:43 fvdpol Exp $
+# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/fluidsynth/ChangeLog,v 1.21 2006/07/08 14:08:01 fvdpol Exp $
+
+*fluidsynth-1.0.7 (08 Jul 2006)
+
+ 08 Jul 2006; Frank van de Pol <fvdpol@gentoo.org>
+ +fluidsynth-1.0.7.ebuild:
+ Version bump to 1.0.7.
*fluidsynth-1.0.6 (11 Jul 2005)
diff --git a/media-sound/fluidsynth/files/digest-fluidsynth-1.0.6 b/media-sound/fluidsynth/files/digest-fluidsynth-1.0.6
index 225235737409..51ce8b2f657b 100644
--- a/media-sound/fluidsynth/files/digest-fluidsynth-1.0.6
+++ b/media-sound/fluidsynth/files/digest-fluidsynth-1.0.6
@@ -1 +1,3 @@
MD5 f18fd54d3f877a547b8455d2b6c7b177 fluidsynth-1.0.6.tar.gz 1022289
+RMD160 7699dae455816844d80c204c99cf11efd8fb6d64 fluidsynth-1.0.6.tar.gz 1022289
+SHA256 76db2ec53b458daeb28543d8238413b591a9832b45c4a86bc89bf9704ef4b2c9 fluidsynth-1.0.6.tar.gz 1022289
diff --git a/media-sound/fluidsynth/files/digest-fluidsynth-1.0.7 b/media-sound/fluidsynth/files/digest-fluidsynth-1.0.7
new file mode 100644
index 000000000000..91cf96969d23
--- /dev/null
+++ b/media-sound/fluidsynth/files/digest-fluidsynth-1.0.7
@@ -0,0 +1,3 @@
+MD5 0f73d47990d859f19b8e9840bdab5c60 fluidsynth-1.0.7a.tar.gz 1064677
+RMD160 c4d31711443c0dad42937a38a0360d114525d076 fluidsynth-1.0.7a.tar.gz 1064677
+SHA256 337dcc5f0f337c37ee7979c9505589b3a84e6b1e245d31b637ad32996b6e113b fluidsynth-1.0.7a.tar.gz 1064677
diff --git a/media-sound/fluidsynth/fluidsynth-1.0.7.ebuild b/media-sound/fluidsynth/fluidsynth-1.0.7.ebuild
new file mode 100644
index 000000000000..87648d00beda
--- /dev/null
+++ b/media-sound/fluidsynth/fluidsynth-1.0.7.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/fluidsynth/fluidsynth-1.0.7.ebuild,v 1.1 2006/07/08 14:08:01 fvdpol Exp $
+
+IUSE="alsa jack sse lash static"
+
+inherit flag-o-matic eutils
+
+RELEASE_SUFFIX="a"
+DESCRIPTION="Fluidsynth is a software real-time synthesizer based on the Soundfont 2 specifications."
+HOMEPAGE="http://www.fluidsynth.org/"
+SRC_URI="http://savannah.nongnu.org/download/fluid/${P}${RELEASE_SUFFIX}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 -ppc ~sparc ~x86"
+
+DEPEND="jack? ( media-sound/jack-audio-connection-kit )
+ media-libs/ladspa-sdk
+ alsa? ( media-libs/alsa-lib
+ lash? ( >=media-sound/lash-0.5 ) )"
+
+# Alsa is required for lash support in this package.
+
+src_compile() {
+ local myconf
+ myconf="--enable-ladspa `use_enable jack jack-support` `use_enable static`"
+
+ if use alsa; then
+ myconf="${myconf} --enable-alsa `use_enable lash`"
+ else
+ myconf="${myconf} --disable-alsa --disable-lash"
+ fi
+
+ if use sse; then
+ myconf="--enable-SSE ${myconf}"
+ # If your CFLAGS include optimizations for sse, ie:
+ # -march=pentium4 -mfpmath=sse -msse2
+ # AND your USE flags include sse, ie: USE=sse,
+ # the sounds with fluidsynth will be distorted.
+ if [ `is-flag "-march=pentium4"` ]; then
+ filter-flags "-msse2"
+ filter-flags "-mfpmath=sse"
+ fi
+ fi
+
+ econf ${myconf} || die "./configure failed"
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS NEWS README THANKS TODO
+}