summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-08-21 02:53:34 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-08-21 02:53:34 +0000
commit966c17963f01cd3a7cdcb69a76a9923abb3a6dae (patch)
tree8b4ed86ce052a4bbd21464aa727c5d3156660276 /media-sound/freebirth/freebirth-0.3.2-r1.ebuild
parentBump the experimental binary package. Fixes bug #333269 by Mike Gilbert <flop... (diff)
downloadgentoo-2-966c17963f01cd3a7cdcb69a76a9923abb3a6dae.tar.gz
gentoo-2-966c17963f01cd3a7cdcb69a76a9923abb3a6dae.tar.bz2
gentoo-2-966c17963f01cd3a7cdcb69a76a9923abb3a6dae.zip
Respect LDFLAGS wrt #333727 by Diego E. Pettenò.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/freebirth/freebirth-0.3.2-r1.ebuild')
-rw-r--r--media-sound/freebirth/freebirth-0.3.2-r1.ebuild25
1 files changed, 14 insertions, 11 deletions
diff --git a/media-sound/freebirth/freebirth-0.3.2-r1.ebuild b/media-sound/freebirth/freebirth-0.3.2-r1.ebuild
index 7bccd851ddb9..7cdb2413fe81 100644
--- a/media-sound/freebirth/freebirth-0.3.2-r1.ebuild
+++ b/media-sound/freebirth/freebirth-0.3.2-r1.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/freebirth/freebirth-0.3.2-r1.ebuild,v 1.9 2010/06/12 20:12:07 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/freebirth/freebirth-0.3.2-r1.ebuild,v 1.10 2010/08/21 02:53:34 ssuominen Exp $
+EAPI=2
inherit eutils toolchain-funcs
DESCRIPTION="Free software bass synthesizer step sequencer"
@@ -13,26 +14,28 @@ SLOT="0"
KEYWORDS="amd64 ~ppc sparc x86"
IUSE=""
-RDEPEND=">=x11-libs/gtk+-2"
+RDEPEND="x11-libs/gtk+:2"
DEPEND="${RDEPEND}
dev-util/pkgconfig"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-gentoo-2.patch
- epatch "${FILESDIR}"/${P}-segfault.patch
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo-2.patch \
+ "${FILESDIR}"/${P}-segfault.patch
}
src_compile() {
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS} $(pkg-config --cflags gtk+-2.0)" || die "emake failed."
+ tc-export CC
+ emake || die
}
src_install() {
- dobin ${PN}
+ dobin ${PN} || die
+
insinto /usr/share/${PN}/raw
- doins raw/*.raw
+ doins raw/*.raw || die
+
dodoc CHANGES NEXT_VERSION README
+
doicon xpm/${PN}.xpm
- make_desktop_entry ${PN} ${PN} ${PN}
+ make_desktop_entry ${PN} ${PN}
}