summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2002-11-18 16:37:34 +0000
committerMarinus Schraal <foser@gentoo.org>2002-11-18 16:37:34 +0000
commiteceb121dc18d3f003433802b7e658a4f20ab474e (patch)
tree7abc8d52e8332e14363e0c5fd76eb887ac70a682 /media-sound/glame
parentsmall fix for compilation on newer alphas (diff)
downloadgentoo-2-eceb121dc18d3f003433802b7e658a4f20ab474e.tar.gz
gentoo-2-eceb121dc18d3f003433802b7e658a4f20ab474e.tar.bz2
gentoo-2-eceb121dc18d3f003433802b7e658a4f20ab474e.zip
Fix configure problem
Diffstat (limited to 'media-sound/glame')
-rw-r--r--media-sound/glame/ChangeLog7
-rw-r--r--media-sound/glame/glame-0.6.3.ebuild11
2 files changed, 12 insertions, 6 deletions
diff --git a/media-sound/glame/ChangeLog b/media-sound/glame/ChangeLog
index 78ce2bb19d39..16bc380945a2 100644
--- a/media-sound/glame/ChangeLog
+++ b/media-sound/glame/ChangeLog
@@ -1,8 +1,11 @@
# ChangeLog for media-sound/glame
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-sound/glame/ChangeLog,v 1.3 2002/09/21 02:08:09 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/glame/ChangeLog,v 1.4 2002/11/18 16:37:34 foser Exp $
-*glame-0.6.4 (05 Aug 2002)
+*glame-0.6.3 (05 Aug 2002)
+
+ 18 Nov 2002; foser <foser@gentoo.org> glame-0.6.3.ebuild :
+ unset CFLAGS to fix possible problems with configure (bug #7587)
05 Aug 2002; Leonardo Boshell <leonardop@gentoo.org> glame-0.6.3.ebuild:
New version. Thanks to Chris Arndt for pointing it out in bug #5987.
diff --git a/media-sound/glame/glame-0.6.3.ebuild b/media-sound/glame/glame-0.6.3.ebuild
index fc8ae6b27966..e40d1ee96206 100644
--- a/media-sound/glame/glame-0.6.3.ebuild
+++ b/media-sound/glame/glame-0.6.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/glame/glame-0.6.3.ebuild,v 1.2 2002/10/05 05:39:16 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/glame/glame-0.6.3.ebuild,v 1.3 2002/11/18 16:37:34 foser Exp $
IUSE="nls gnome"
@@ -33,10 +33,13 @@ src_compile() {
local myconf=""
- use nls || myconf="--disable-nls"
+ use nls && myconf="--enable-nls" \
+ || myconf="--disable-nls"
use gnome || myconf="$myconf --disable-gui"
-
- econf --with-included-gettext $myconf || die "Configuration failed"
+
+ # needed to not break configure
+ unset CFLAGS
+ econf --with-included-gettext ${myconf} || die "Configuration failed"
emake || die "Compilation failed"
}